+1-888-365-2779
Try Now
More in this section

Forums / Set-up & Installation / Can't login to newly created project

Can't login to newly created project

8 posts, 0 answered
  1. Kalvin MacLeod
    Kalvin MacLeod avatar
    19 posts
    Registered:
    15 Nov 2005
    08 Apr 2008
    Link to this post
    Hello,

    I'm having trouble with a new install of Sitefinity on Vista. I don't have UAC running (because it makes me want to kill myself) and I'm able to create a project but when I go to login to the newly created project with my adminstrator account, it keeps telling me Your login attempt was not successful. Please try again.

    I'm using my windows account to login in. Is there some other default that I'm supposed to use?
  2. Rebecca
    Rebecca avatar
    536 posts
    Registered:
    24 Sep 2012
    09 Apr 2008
    Link to this post
    Hello Kalvin MacLeod,

    Thank you for your interest in our CMS and getting in touch with us. We are sorry to hear you are having troubles installing Sitefinity.
    Most probably, you cannot log in the new project because the step at which you have to set the project database and the admin account had been skipped and the login page open straight after the project creation.
    This happens quite often and is basically due to incorrect IIS settings. We would recommend moving the Sitefinity3.x (Project Manager) virtual directory to the Classic.NET AppPool.
    This is how to do it:
    1. Launch IIS Manager from Control Panel > Administrative Tools.
    2. Expand the tree in the Connections pane and then expand Web Sites.
    3. Right-click the Sitefinity3.x directory and select Advanced Settings.
    4. Change the Application Pool setting to Classic .NET AppPool.
    5. Click OK to apply the changes.
    6. Restart the Classic .NET AppPool.
    The Project Startup wizard should then continue to the step where the database is configured. 

    Check the security settings for the Sitefinity3.x virtual folder, making sure that:
       1. Anonymous Authentication is disabled.
       2. ASP.NET Impersonation is enabled.
       3. Forms Authentication is disabled.
       4. Windows Authentication is enabled.

    You may also check if the Classic.NET AppPool is configured as described in section Installing Sitefinity under Windows® Vista of the Sitefinity User Manual.

    Hope everything runs smoothly now. Do let us know if you need any further assistance.

    Sincerely yours,
    Rebecca
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  3. Kalvin MacLeod
    Kalvin MacLeod avatar
    19 posts
    Registered:
    15 Nov 2005
    09 Apr 2008
    Link to this post
    Thanks that got me to the next step, but when trying to create the database I now get this:

    There was an error trying to connect to the Database Server:
    User does not have permission to perform this action.

    Sitefinity shows that I'm logged in as my adminstrator account. My administrator account shows as dbo in the list of users for the database. I've checked the permissions on the app_data folder and Network Service and Administrators have full control. What am I missing?
  4. Rebecca
    Rebecca avatar
    536 posts
    Registered:
    24 Sep 2012
    09 Apr 2008
    Link to this post
    Hello Kalvin MacLeod,

    Make sure the NETWORK SERVICE account has Read, Write and Modify permissions on App_Data folder and restart the application after setting the permissions, so the provider is initialized again.

    Also, did you install the .NET Framework after IIS? You can refer to the last post in this forum thread, it might help:
    Read-Only DB Error with Vista.

    Greetings,

    Rebecca
    the Telerik team


    Instantly find answers to your questions at the new Telerik Support Center
  5. Kalvin MacLeod
    Kalvin MacLeod avatar
    19 posts
    Registered:
    15 Nov 2005
    09 Apr 2008
    Link to this post
    Hi,

    Thanks, I've already tried what was proposed in the other thread. No luck. And my app_data folder has the proper permissions. What else can I try?
  6. Rebecca
    Rebecca avatar
    536 posts
    Registered:
    24 Sep 2012
    09 Apr 2008
    Link to this post
    Hello Kalvin MacLeod,

    Please check once again the settings for the Classic.NET AppPool, making sure that the user account which runs the WebSite is NETWORK SERVICE. Just open the Advanced Settings of the application pool and check if the Identity property is set to NETWORK SERVICE.

    Restart the pool and see if the problem still persists.

    Sincerely yours,
    Rebecca
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  7. Kalvin MacLeod
    Kalvin MacLeod avatar
    19 posts
    Registered:
    15 Nov 2005
    09 Apr 2008
    Link to this post
    I've checked all of those things about 20 times now and all is set up the way you've suggested. I ended up giving up trying to run the project from localhost and instead opened the newly created project in visual studio, ran it from there and it connected to the database and ran what it needed to run. Why this worked I have no idea. But in doing so, I now have another problem:

    When I try to go the admin part of the website I get this error:

    This type of page is not served.

    Description: The type of page you have requested is not served because it has been explicitly forbidden.  The extension '.aspx' may be incorrect.   Please review the URL below and make sure that it is spelled correctly.

    Requested URL: /habitat/Sitefinity/Admin/Default.aspx


    Which makes no sense to me since view aspx pages in the regular part of the project just not in the admin section. Please help.
  8. Kalvin MacLeod
    Kalvin MacLeod avatar
    19 posts
    Registered:
    15 Nov 2005
    09 Apr 2008
    Link to this post
    You can ignore that question. I figured it out. In my many fiddlings with settings I changed the default websites authentication so that forms authentication was disabled. Re-enabling that seemed to fix it.

    I still wonder why I wasn't able to access the newly created project database by going through localhost/project and instead had to go through visual studios web server. Vista?
Register for webinar
8 posts, 0 answered