+1-888-365-2779
Try Now
More in this section

Forums / Set-up & Installation / Cannot logon to University Sample using admin / admin

Cannot logon to University Sample using admin / admin

9 posts, 0 answered
  1. neil prideaux
    neil prideaux avatar
    1 posts
    Registered:
    21 Apr 2006
    05 Feb 2009
    Link to this post
    I installed Sitefinity Standard version 3.5 SP1 on Windows XP which already had IIS5.1, .NET 2.0 , Visual Studio 2005, and SQLExpress.

    Installed OK with no errors. Then I created the sample TIU OK.

    Problems
    1. documentation for the TIU Site Tutorial (chm help file) is Out of Date, it is for version 3.2 and lot of information is wrong, e.g. the links to access the Site and Admin site are wrong.
    2. Cannot log on to the Admin site at http://localhost/telerik/tiusite_v3.5_sp1/sitefinity. Everytime i type in admin / admin, it returns me to this page, with no error message or indication of what is going wrong.
    At this point i gave up. It may be a good product, but little details are important to me.
  2. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    09 Feb 2009
    Link to this post
    Hi,

    Thank you for posting your issue in our forums.
    Let me first elaborate on the problem you have.
    It might be caused, if the applicationPool is not set ClassicMode. Please try running the application under ClassicMode application pool. If the problem persists, you could try resetting the administrator password through the database.

    "The hashed format of a password is stored in the database table Telerik_Users. In order to access the password, the password format should be changed - the PasswordFormat value should be set from 1 to 0 (put into "Clear" mode) so that the password is saved as plain text in the table. After executing this, the new format of the password will be saved in the Password field. Copy this string and paste it into the password field when logging in into the Admin part of Sitefinity"

    Now about the details,
    I believe that they are important for everyone. You might not believe it, but they are important for us as well. That is why, we will appreciate if you could elaborate on the problems you have, the difficulties you have met, and share your oppinion/experience. You can mail me directly on georgi.chokov@telerik.com if you wish. I assure you that our team is ready to assist you with everything related with Sitefinity.

    Greetings,
    Georgi
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  3. David
    David avatar
    3 posts
    Registered:
    20 May 2005
    05 Mar 2009
    Link to this post
    I may be having the same problem with version 3.6.

    I am running under a brand new virtual machine built with
    Vista Ultimate 32 bit and SQL Express 2005 for this trial. I followed the Installation Guide to configure IIS and followid things as close as I could.

    The basic install seems to have worked and I can browse the Telerik University site.

    However when I click Edit from the sitefinity Project Manager, I can't log in!

    I have tried the basic PC user with windows login and also looked up the users in the telerik_users table and tried poly/poly, admin/admin, blogger/blogger, and john/john, but still no joy logging in.

    I'm not quite clear on the PasswordFormat. Can I use SQL to update PasswordFormat to 0 and then update the password and then set PasswordFormat back to 1? Or is there a web page I should use?

    Thanks Dave E
  4. Nikolai
    Nikolai avatar
    216 posts
    Registered:
    21 Nov 2016
    06 Mar 2009
    Link to this post
    Hi David Engelkemier,

    Here is how the password update should be done:
    1. Open table telerik_Users
    2. Change the Password format  for your user to 0
    3. Then just type your new password
    4. Commit changes to DB by going to the next row
    5. Log in your project with the new password.

    Sincerely yours,
    Nikolai
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  5. Frank
    Frank avatar
    19 posts
    Registered:
    03 Apr 2009
    08 Jun 2009
    Link to this post
    This not helping.

    The passwd is correct. Because when I mistype the password, sitefinity gives me and error. (Your login attempt was not successful. Please try again.)

    So when the passwd is correct it should redirect me to the dashboard, but this is not happening. It returns me to the login page, without any errormessage.

    the URL of the site is added with an ReturnUrl part. (http://www.site.com/sitefinity/login.aspx?ReturnUrl=%2fsitefinity%2fDefault.aspx)

  6. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    08 Jun 2009
    Link to this post
    Hello Frank,

    It seems that there is validation. Could you try to access the pages.aspx directly through the browser and see whether you will get permission error. Also try running the website in Classic Application pool mode. If the problem persists update the password through your DB.

    Kind regards,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  7. Frank
    Frank avatar
    19 posts
    Registered:
    03 Apr 2009
    08 Jun 2009
    Link to this post
    Yes, there is validation.

    We can enter the frontpages (site) and we are not getting any permission errors .

    We use IIS 6, so everything is running in Classic Application Pool Mode.

    And I did reset the password in the database using the trick with the passwordformat.

    No succes so far....

    please help :)
  8. Frank
    Frank avatar
    19 posts
    Registered:
    03 Apr 2009
    08 Jun 2009
    Link to this post
    Found the sollution!!!

    My hostheaders contained an underscore (_)..

    Internet Explorer does not save sessions from domainnames with an underscore!

    One complete day of bughunting down the drain.....

    So far so good.
  9. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    08 Jun 2009
    Link to this post
    Hello Frank,

    You are right, IE does not accept forms authentication cookies from hosts contain underscore. We had to mention this earlier.
    Anyway, I am glad everything is fine!

    Best wishes,
    Georgi
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
Register for webinar
9 posts, 0 answered