+1-888-365-2779
Try Now
More in this section

Forums / Set-up & Installation / cant add controls to template

cant add controls to template

8 posts, 0 answered
  1. Chris
    Chris avatar
    2 posts
    Registered:
    27 Mar 2008
    02 Apr 2008
    Link to this post
    Hi,

    I have created a template (via creating a master page in VS).  The template has several ContentPlaceHolders (menu, main, footer, etc).  However, when I edit the template I cant drag & drop any control onto any container. 
    I can only get the control added by going through the steps on the right of the page and hitting "Add".
    But even then, after adding in the control to the container, the system wont allow me to then edit the control.  Rather than saying "Edit" it says "Mouse-over to edit" - if you put the mouse over or click on it nothing happens.

    The only other thing going on is a Javascript error on the page saying : Line 117, Char 22, 'length' is null or not an object.
    I have checked my master page and I have no code that relates to 'length'.

    I did try the above again with another template - this time with just one ContentPlaceHolder on it - but I still couldnt add a control to the template.

    Please let me know what it is that I am doing wrong.
    Many thanks in advance,
    Chris Sassons
  2. Rebecca
    Rebecca avatar
    536 posts
    Registered:
    24 Sep 2012
    02 Apr 2008
    Link to this post
    Hi Chris,

    Thank you very much for describing the problem in detail. Please open the .master file used by your Sitefinity template and make sure there are no characters between the opening and closing tags:

    <asp:ContentPlaceHolder ID="main" runat="server"></asp:ContentPlaceHolder> 

    Alternatively, you can close the tags like this:

    <asp:ContentPlaceHolder ID="main" runat="server" /> 

    Feel free to send us your masterpages and css if the above doesn't help to fix this.

    Greetings,
    Rebecca
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  3. Carl-Johan
    Carl-Johan avatar
    4 posts
    Registered:
    14 May 2008
    24 Nov 2008
    Link to this post
    I hade the same problem.

    First I removed all the tables in the Masterpage. Then it worked. But now it’s stuck again and i haven’t figured out why. But what I do is that I use on of the "came a long" Masterpages. Then when I have added the control I switch back to the Masterpage that I have created. Just make sure that the content container have the same name in both Masterpages.
  4. Pepi
    Pepi avatar
    981 posts
    Registered:
    08 Dec 2016
    24 Nov 2008
    Link to this post
    Hello Carl-Johan,

    Please open a new support ticket and send us your .master page and all related .css and .js files to test the issue locally. Also, what browser do you use?

    Thanks for your cooperation in advance.

    Regards,
    Pepi
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  5. Carl-Johan
    Carl-Johan avatar
    4 posts
    Registered:
    14 May 2008
    24 Nov 2008
    Link to this post
    Sure. Thanks for the quick reply.
  6. Kiearn
    Kiearn avatar
    6 posts
    Registered:
    07 Aug 2008
    29 Jun 2009
    Link to this post
    Hi

    I was having the same issue, my error was a result of commenting out ContentPlaceHolders

    <!--
    <asp:ContentPlaceHolder id="ContentPlaceHolders1" runat="server" /> 
    -->


    Kieran
  7. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    29 Jun 2009
    Link to this post
    Hello Kiearn,

    Since the post in almost an year old. I hope that the problem was sorted out at your end.

    Regards,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  8. danfinney
    danfinney avatar
    51 posts
    Registered:
    09 Jul 2008
    24 Feb 2010
    Link to this post
    I just want to add to the record.  Yes, commenting = bad.

    -Dan Finney

    sitefinity web design
Register for webinar
8 posts, 0 answered