+1-888-365-2779
Try Now
More in this section

Forums / Set-up & Installation / Config Error moving a site to 3.2

Config Error moving a site to 3.2

5 posts, 0 answered
  1. Matt
    Matt avatar
    17 posts
    Registered:
    03 Jan 2008
    10 Mar 2008
    Link to this post
    Hello all.  So I'm trying to update the site I'm working on to 3.2 accoridng to the instructions on page 59 of UserManual_3_2.pdf.

    Once I point it to the old database and press go it throws the following error (which doesn't chance after I've completed steps 4-7):

    Configuration Error
    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

    Parser Error Message: Invalid object name 'sys.indexes'.
    Invalid object name 'sys.tables'.
    Invalid object name 'sys.schemas'.
    Invalid object name 'sys.index_columns'.
    Invalid object name 'sys.columns'.

    Source Error:


    Line 82: <clear />
    Line 83: <add connectionStringName="DefaultConnection" applicationName="/"
    Line 84: name="Sitefinity" type="Telerik.DataAccess.AspnetProviders.TelerikRoleProvider, Telerik.DataAccess" />
    Line 85: </providers>
    Line 86: </roleManager>


    Any ideas?


  2. Rebecca
    Rebecca avatar
    536 posts
    Registered:
    24 Sep 2012
    10 Mar 2008
    Link to this post
    Hi Matt,

    Most probably, the application is configured for SQL Server 2005, but the actual database is SQL Server 2000, since the sys.indexes view don't exist in that version.
    What version of SQL Server are you using? Make sure that the Nolics drivers are properly set in the web.config, e.g.:
        - in case of SQL Server 2000:    
      <telerik> 
        <dataAccess defaultConnection="DefaultConnection">  
          <connections> 
            <add name="DefaultConnection" driver="Nolics.ORMapper.DataProviders.SqlServer2000Provider" 
              connectionStringName="Sitefinity" /> 
            <add name="GenericContentConnection" driver="Telerik.Cms.Engine.Data.Providers.GCSql2000Provider, Telerik.Cms.Engine.Data" 
              connectionStringName="Sitefinity" /> 
          </connections> 

        </dataAccess> 


        - in case of SQL Server 2005:
      <telerik> 
        <dataAccess defaultConnection="DefaultConnection">  
          <connections> 
            <add name="DefaultConnection" driver="Nolics.ORMapper.DataProviders.SqlServer2005Provider" 
              connectionStringName="Sitefinity" /> 
            <add name="GenericContentConnection" driver="Telerik.Cms.Engine.Data.Providers.GCSql2005Provider, Telerik.Cms.Engine.Data" 
              connectionStringName="Sitefinity" /> 
          </connections> 

        </dataAccess> 


    Regards,
    Rebecca
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  3. Matt
    Matt avatar
    17 posts
    Registered:
    03 Jan 2008
    10 Mar 2008
    Link to this post
    Follow up:

    I meant to say 'change' instead of 'chance' in that last post.

    I tried to create a new site without upgrading anything and am running into the same error message.  Other info that may help:

    I'm using a remote SQL Server 2005 that I can connect to fine and am logging in as 'sa' to avoid any permissions issues.
    I still have SiteFinity 3.1 installed.
  4. Matt
    Matt avatar
    17 posts
    Registered:
    03 Jan 2008
    10 Mar 2008
    Link to this post
    Thanks for you reply Rebecca, but I'm afraid that wasn't it, it was already set up with 2005 there.  Would it help if I posted the web.config somewhere?
  5. Matt
    Matt avatar
    17 posts
    Registered:
    03 Jan 2008
    10 Mar 2008
    Link to this post
    Check that, your diagnosis was right on the money, I had fat fingered the server name and pointed it to the wrong one (which was indeed 2000), it's all good now, thanks for the help.
Register for webinar
5 posts, 0 answered