Try Now
More in this section

Forums / Set-up & Installation / Error after installation of SiteFinity

Error after installation of SiteFinity

2 posts, 0 answered
  1. chabian
    chabian avatar
    1 posts
    12 Sep 2005
    29 May 2008
    Link to this post
    I am receiving the error:

     System.Web.Hosting.HostingEnvironmentException: Failed to access IIS metabase.

    after installing the product. I get this when browsing localhost on the SiteFinity3.2 virtual directory. I am using IIS 5.1 on a Windows XP Pro machine. Any ideas on what I can check?

  2. Pepi
    Pepi avatar
    981 posts
    20 Oct 2016
    29 May 2008
    Link to this post
    Hi Eric,

    First, you may try to troubleshoot this following our advice here:
    Failed to access IIS metabase.

    Most probably, you have installed IIS after installing the .NET framework. Follow the instructions below as a possible solution:

    1. Find the Virtual Directory for your ASP.NET 2.0 application.
    2. Right-click for properties and see if you have a tab saying ASP.NET.
    3. If you do, see if your 2.0 application is trying to run using the 1.1 version (1.432...)
    4. Change that to the correct version of your .NET framework (it should be v2.0.50727).

    Also, you can try to repair your ASP.NET installation and set up all of the appropriate ISAPI extension mappings.
    For more information on this approach, please have a look at the following blog.

    Another solution is to reinstall the VS after you install IIS. You can perform these actions as an alternative.

    If these suggestions do not help, you can do a search with Google on this error.

    Do let us know how it goes.

    All the best,
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
2 posts, 0 answered