+1-888-365-2779
Try Now
More in this section

Forums / Set-up & Installation / Export site gives me database problems

Export site gives me database problems

3 posts, 1 answered
  1. Magnus
    Magnus avatar
    28 posts
    Registered:
    26 May 2009
    30 Oct 2009
    Link to this post
    Hi there.

    I've got a little problem which you guys might wanna help me out with a bit.

    We have a customer who's been building up their website on our devserver. Now when we are trying to export that website (SF 3.6, MySQL), we have some troubles with importing the database on the new server.

    Which way is the best way to export an site to another server?

    We just copied all files and exported the database with all structure/data. When we are trying to import the database we were getting errors for the procedures/functions queries. It seems it cannot created any functions or procedures. (I've exported some mssql/Sitefinity 3.6/3.7 sites with no problems before in that kind of way).

    So. I'v tried to search for an answer in a couple of minutes now, but had no luck. I'm sure we are not the only one with this problem.


    Thanks for any kind of help!

    Kind regards / Magnus
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    31 Oct 2009
    Link to this post
    Hi Magnus,

    Try creating a backup of the database. Then create a brand new database on the other server and restore the backup. Make sure that the process will not be interrupted. If the problem persists, send the errors you are getting. They could help us the figure out what the problem is.

    All the best,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
    Answered
  3. Magnus
    Magnus avatar
    28 posts
    Registered:
    26 May 2009
    02 Nov 2009
    Link to this post
    Hi there.


    I've solved the problem after some thinking and testing. I think this information can be useful for other peoples who's suffering with the same problem.

    1. I couldnt export my database from MySQL administrator to MySQL administrator without any problems. (that could depend on my lack of knowledge, dont know for sure). I couldn't either export/import the database from SQLyog to SQLyog (a mysql client program). But when i exported from MySQL administrator and imported from SQLyog it didnt receive any error messages.

    2. i had to remove the commando "DEFINER=`root`@`localhost" from the query "CREATE DEFINER=`root`@`localhost` PROCEDURE". Which of course was understodable when you noticed it.  But i dont know why that commando is there from the first place.

    3. Now to the curious part. I had to change the tablesnames so it had captitals letters in the name. I suspect that this problem have something to do with the server configuration/settings to do.

    4. Oh.. and i forgot. The webhotel need to give you the privilages to create procedures/functions for the database.


    Well. I got the site to work. Hope this information could be useful for anyone else out there.


    / Magnus.
Register for webinar
3 posts, 1 answered