+1-888-365-2779
Try Now
More in this section

Forums / Set-up & Installation / Failed to activate, please verify your SMTP setting and try again

Failed to activate, please verify your SMTP setting and try again

9 posts, 3 answered
  1. Slava
    Slava avatar
    7 posts
    Registered:
    30 Oct 2008
    19 Oct 2009
    Link to this post
    Hi All,
    Getting this message:
    Failed to activate, please verify your SMTP setting and try again
    I have tried configure smpt through web.config but it doesn't work as well
    and roleManger acheRolesInCookie="false" doesn't work ether.
    Can someone help me resolve it?
  2. Stoyanka Assenova
    Stoyanka Assenova avatar
    113 posts
    Registered:
    01 Dec 2016
    19 Oct 2009
    Link to this post
    Hi Slava,

    You should set SMTP Server settings in Newsletters module in the administration section in Sitefinity 3.6 and Sitefinity 3.7.

    Please, do the following steps:

    1. Log in to the Administration and go to section Modules>Newslettes.
    2. Click on the SMTP Server Settings link on the left side pane.
    3. In the page which opens, enter your SMTP Server settings.
    4. Click on "Test and save" current setting button.
    Using the SMTP server settings and email provided in step 3, a verification email will be sent.
    5. Click on the Activate button. The settings will be applied to the Newsletter Module.

    If you have any problem, do not hesitate to contact us.

    Greetings,
    Stoyanka Assenova
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
    Answered
  3. Slava
    Slava avatar
    7 posts
    Registered:
    30 Oct 2008
    19 Oct 2009
    Link to this post
    Hello Stoyanka,
     Thanks for quick reply.
    That the first thing that I did it doesn't work for me.
    I am running 3.7 sp1 on godaddy.com .
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    19 Oct 2009
    Link to this post
    Hello Slava,

    SMTP settings for Newsletters module cannot be set through web.config file, there are managed by DataProvider. The problem that have could be related to wrong settings you supply to the fields. Also if you are running on medium trust enviroment there could be a problem as well. Try setting the server settings on Full Trust - local host and then migrate the project.

    Sincerely yours,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
    Answered
  5. Slava
    Slava avatar
    7 posts
    Registered:
    30 Oct 2008
    19 Oct 2009
    Link to this post
    Hi Ivan,
    Thanks for the response.
    I guess that problem related to medium trust on my hosting server
    because I do have problems with file uploads as well.
    So if it Data Provider it storing smtp content in the database not in web config,
    should I redeploy database as well?
  6. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    19 Oct 2009
    Link to this post
    Hi Slava,

    You could check whether there is any data written to [sf_Notif_SMTPSetting] table. Note that the value from the following columns status and Active  is boolean type - 0 -fail, 1- ok.

    Kind regards,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
    Answered
  7. Slava
    Slava avatar
    7 posts
    Registered:
    30 Oct 2008
    19 Oct 2009
    Link to this post
    Hi Ivan,
    Well finaly I got this:
     

    Server Error in '/' Application.

    Security Exception

    Description: The application attempted to perform an operation not allowed by the security policy.  To grant this application the required permission please contact your system administrator or change the application's trust level in the configuration file.

    Exception Details: System.Security.SecurityException: Request failed.

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Stack Trace:

    [SecurityException: Request failed.]
       System.Security.CodeAccessSecurityEngine.ThrowSecurityException(Assembly asm, PermissionSet granted, PermissionSet refused, RuntimeMethodHandle rmh, SecurityAction action, Object demand, IPermission permThatFailed) +150
       System.Security.CodeAccessSecurityEngine.ThrowSecurityException(Object assemblyOrString, PermissionSet granted, PermissionSet refused, RuntimeMethodHandle rmh, SecurityAction action, Object demand, IPermission permThatFailed) +100
       System.Security.CodeAccessSecurityEngine.CheckSetHelper(PermissionSet grants, PermissionSet refused, PermissionSet demands, RuntimeMethodHandle rmh, Object assemblyOrString, SecurityAction action, Boolean throwException) +284
       System.Security.PermissionSetTriple.CheckSetDemand(PermissionSet demandSet, PermissionSet& alteredDemandset, RuntimeMethodHandle rmh) +69
       System.Security.PermissionListSet.CheckSetDemand(PermissionSet pset, RuntimeMethodHandle rmh) +150
       System.Security.PermissionListSet.DemandFlagsOrGrantSet(Int32 flags, PermissionSet grantSet) +30
       System.Threading.CompressedStack.DemandFlagsOrGrantSet(Int32 flags, PermissionSet grantSet) +40
       System.Security.CodeAccessSecurityEngine.ReflectionTargetDemandHelper(Int32 permission, PermissionSet targetGrant, CompressedStack securityContext) +123
       System.Security.CodeAccessSecurityEngine.ReflectionTargetDemandHelper(Int32 permission, PermissionSet targetGrant) +54
    

    I think Sitefinity is not designed to run on shared hosting with medium trust.
    I need to think about dedicated virtual server or so.
    Thanks for the help.
  8. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    19 Oct 2009
    Link to this post
    Hi Slava,

    If your host supports the default trust level permissions you can configure Sitefinity to work properly, but again SMTP settings need to be set in full trust. The best option is full trust account or VPS.

    Kind regards,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  9. Slava
    Slava avatar
    7 posts
    Registered:
    30 Oct 2008
    20 Oct 2009
    Link to this post
    Hi Ivan,
    It looks like discountasp.net supports sitefinity out of the box.
    I am going to try it.
    Thanks for the help.
Register for webinar
9 posts, 3 answered