+1-888-365-2779
Try Now
More in this section

Forums / Set-up & Installation / Finding it impossible to run SiteFinity 3.7 on 64-bit Windows 7

Finding it impossible to run SiteFinity 3.7 on 64-bit Windows 7

13 posts, 0 answered
  1. Sunil
    Sunil avatar
    32 posts
    Registered:
    27 Jan 2004
    05 Dec 2010
    Link to this post
    I have spent a full day trying to install SiteFinity 3.7 on my 64-bit laptop under Windows 7.
    I can easily create a ASP.Net website on my 64-bit laptop that I have been developing without any issues.
    But SiteFinity does not allow me to create a project because of which I am stuck forever and the funny thing is that the application for sitefinity does not even appear under Default website when I install through msi installer. You can see the attached screen-shot to see that there is no application under Default website even though its there under the applications under Default Pool.

    Any idea on how I can make the Sitefinity app appear under Default website? Atleast if it appears under default website I can configure it in the hope that Sitefinity will work.
  2. Sunil
    Sunil avatar
    32 posts
    Registered:
    27 Jan 2004
    05 Dec 2010
    Link to this post
    I got the application for telerik to come under Default website by creating a 'telerik' application under Default website but even then I cannot create a Project. It says:
    The account, you have authenticated with, has no permissions to create virtual directories. Please make sure that windows authentication is enabled.
    I tried all possible solutions as mentioned in other forum threads but without success.
    I installed using installer for .Net 4.0.

    Strange that SiteFinity install is like rocket science. Very frustrating.
  3. Sunil
    Sunil avatar
    32 posts
    Registered:
    27 Jan 2004
    05 Dec 2010
    Link to this post
    I just tried to install DotNetNuke, and it was quite easy and straightforward to install and it works very well also. It seems I will have to develop the website with DotNetNuke.
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    05 Dec 2010
    Link to this post
    Hi Sunil,

    You can take a  look at Bullet_Proof_Guide_to_Installing_Sitefinity or try using an installation from Blank project.

    Kind regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Sunil
    Sunil avatar
    32 posts
    Registered:
    27 Jan 2004
    05 Dec 2010
    Link to this post
    Hi Ivan,

    In my 64-bit Windows Ultimate O/S, I have two classic pools in IIS 7.x - Classic ASP.Net Pool and also Classic 4.0 ASP.Net pool. Which should I use for the project I create? I downloaded and installed .Net 4 installer.

    Thanks
    Sunil
  6. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    05 Dec 2010
    Link to this post
    Hi Sunil,

    You have to use the application pool that uses .NET Framework 4.0 if you have downloaded the installer for .NET 4.0.

    Greetings,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  7. Sunil
    Sunil avatar
    32 posts
    Registered:
    27 Jan 2004
    05 Dec 2010
    Link to this post
    Hi Ivan,

    Ok.
    I will try in next few minutes and let you know.

    Thanks
    Sunil
  8. Sunil
    Sunil avatar
    32 posts
    Registered:
    27 Jan 2004
    05 Dec 2010
    Link to this post
    Hi Ivan,

    I tried your recommended instructions for bullet-proof install of SiteFinity.
    But it did not work. Now I don't even get the Projects page to show as I see an error when rendering this page.
    The error is in attached image.
    One thing confuses me. You guys have made Sitfinity really complex. I tried to install DotNetNuke that has zero support, and I was able to install DotNetNuke in about 15 minutes including database etc on my 64-bit Windows 7 laptop.
    Why can't Telerik, make Sitefinity more simpler to install?

    Thanks
    Sunil
  9. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    05 Dec 2010
    Link to this post
    Hi Sunil,

    If you are running 64 bit OS I suggest that you should enable 32 bit application for IIS. Right click on the Application Pool and select "Advanced Settings" then "Enable 32-bit Applications." Also, try changing the  application pool from Default to Classic .NET AppPool. Check out whether you have configured your web server to handle ASP.Net extensions. Make sure that  ASP is installed (by default, ASP is not installed with IIS)
    The errors you see are most probably related to the configuration of the IIS server and the .NET version that your Application Pool uses. For instance, you are trying to set up a website that is build against .NET 3.5 or 2.0 under IIS server which application pool runs .NET Framework 4.0 or some similar combination.

    The project manager and installation process is optimized in Sitefinity 4.0 where we included built-in Project Manager.

    Regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  10. Sunil
    Sunil avatar
    32 posts
    Registered:
    27 Jan 2004
    05 Dec 2010
    Link to this post
    I have the 32-bit applications enabled, which I did yesterday after reading a lot of forum threads.

    I have been successfully developing ASP.NET apps for the last year on this laptop without any issues. If my IIS was not properly installed, do you think I would have been able to develop ASP.Net apps and also run DotNetNuke ?

    Also, yesterday I installed DotNetNuker with zero problems and I can create a website using DotNetNuke.

    I am really scared of SiteFinity since its meant for XP systems wen developing and definitely not for Windows 7.

    I will try running SiteFinity under Classic NEt Pool rather than Class Net 4 Pool and let you know.

    Also, another example of how you have made things so complex. Why don't you provide  mdf of sitefinity that will take a developer 1 second to attach, and then he can change the web config connection string. Easy and simple. You don't provide SiteFinit.mdf and then force the user to debug all sorts of attaching problems in their local database. Your database never attached cleanly, and then you blame the user that his/her computer is not properly configured. A 1 second job has been elongated tp a good 30 minutes job.

    Anyways, with all my frustrtaions I will give this one last try and then I am not going to waste my time and energy.

    Thanks
    Sunil
  11. Sunil
    Sunil avatar
    32 posts
    Registered:
    27 Jan 2004
    05 Dec 2010
    Link to this post
    I had the ASP.NET 4.0 Classic Pool running under .Net 2.0. I never had to use Classic ASP.Net pool.
    When I changed it to run under .Net 4.0 then the Project page came up without error. But when I click on the Next button I get an error as attached.
    I have enabled Impersonation and Windows Auth on SiteFinity application in IIS.

    Thanks
    Sunil
  12. Sunil
    Sunil avatar
    32 posts
    Registered:
    27 Jan 2004
    05 Dec 2010
    Link to this post
    I finally got to go past the project create page. The project is created successfully.
    What I did is enable Administrator account in Windows 7 using the following link instructions : http://www.sitefinitywatch.com/blog/09-04-21/Sitefinity_Project_Manager_Permission_Errors_in_IE8.aspx

    I then ran Mozilla FireFox as an adminstrator and it asked me for username/password, which I gave as Administrator user.

    Then I was able to create a project successfully in FireFox. But now I get a database error. I have created the database UnivPly. Do I need to specify the full connection string in the Instance textbox?

    Thanks
    Sunil
  13. Sunil
    Sunil avatar
    32 posts
    Registered:
    27 Jan 2004
    06 Dec 2010
    Link to this post
    I found something I did not see anywhere in the forums.
    If you succeeded in reaching up to the database create page, and you were always getting the error 26 : Error Locating Server\Instance, and you had a SQL Express 2008, then try the following:
    Do not select SQL Express in the database page because you will be stuck for your full lifespan on this page.
    Simply select SQL Server 2005/ 2008 even though you are running a SQL Express on your computer
    and provide a SQL Authentication userid that you should have created and made the owner of your new database before reaching the database page. Make sure 'Windows Authentication' is unchecked since there can a lot of hidden complexities associated with Windows authentication and the user under which your IIS App Pool is running. It can drive you crazy, and so just go with SQL Authentication that is not affected by IIS user being used to run a website.  I succeeded by doing this after being stuck on database page for 3 hours.

    Also, it will be helpful if you allow outgoing connection for SqlBrowser.exe on port 1434 using your anti-virus software or a firewall control program. I did this just before selecting SQL Server 2005/2008 on database page.

    Thanks
    Sunil
Register for webinar
13 posts, 0 answered