+1-888-365-2779
Try Now
More in this section

Forums / Set-up & Installation / HTTP Error 404.2 - Not Found

HTTP Error 404.2 - Not Found

13 posts, 0 answered
  1. David Penny
    David Penny avatar
    18 posts
    Registered:
    23 Jun 2006
    26 Oct 2010
    Link to this post
    Hi,

    I have just upgraded to 3.7 SP4 and get "HTTP Error 404.2 - Not Found"

    I am using Windows 7 64 bit and IIS 7.  I have checked that ISAPI and CGI are allowed against .Net 2.0. 

    It is not allowed against .Net 4.0 - do I need to enable this?

    Strangely, Sitefinity was running for a while but when I came out I cannot now get back in.

    Any help appreciated as this is stopping me updating the site completely.

    David Penny
  2. Casey
    Casey avatar
    25 posts
    Registered:
    22 Oct 2010
    26 Oct 2010
    Link to this post
    I'm getting this same error on windows 7 64-bit.
  3. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    26 Oct 2010
    Link to this post
    Hi David ,

    404.2 means that the ASP web service extension is not allowed or .aspx extension is not mapped to the aspnet isapi.

    Sincerely yours,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  4. David Penny
    David Penny avatar
    18 posts
    Registered:
    23 Jun 2006
    26 Oct 2010
    Link to this post
    Can you give me a clue on how to check whether this is the case, and what I need to do to correct it?

    I assume this is a function of the service pack, as SP2 was all working fine before the update.
  5. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    26 Oct 2010
    Link to this post
    Hi David,

    You could take a look at


    Greetings,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  6. David Penny
    David Penny avatar
    18 posts
    Registered:
    23 Jun 2006
    26 Oct 2010
    Link to this post
    I don't have time to do a whole lot of looking around.

    I'll just roll back to the old version and wait for the next major release.
  7. David Penny
    David Penny avatar
    18 posts
    Registered:
    23 Jun 2006
    26 Oct 2010
    Link to this post
    I have  now worked out how to add the CGI features, and Sitefinity is now running.

    However, when I try to browse or edit my sites (which are still shown) I get a big red message:

    Server Application Unavailable

    The web application you are attempting to access on this web server is currently unavailable.  Please hit the "Refresh" button in your web browser to retry your request.

    Administrator Note: An error message detailing the cause of this specific request failure can be found in the application event log of the web server. Please review this log entry to discover what caused this error to occur.


    Any hints on what to do now?

    David Penny
  8. Patricia
    Patricia avatar
    1 posts
    Registered:
    01 Nov 2010
    01 Nov 2010
    Link to this post
    I've also encountered same problem like this one. Any solutions?
  9. David Penny
    David Penny avatar
    18 posts
    Registered:
    23 Jun 2006
    01 Nov 2010
    Link to this post
    Patricia,

    I've been waiting on a reply from someone at Sitefinity.  In the meantime this might help you as well.

    I've now got it working by creating a new Application Pool.  The Sitefinity instructions go through how to create a Classic .Net AppPool and to run your sites under that.  Looking at the error in more detail it tells me I cannot run two versions of an application under the same App Pool.

    I created a new AppPool, called it Classic .Net AppPool 2
    I set the properties to be identical to the Classic .Net AppPool
    I assigned my website to this new AppPool and now seems to work OK.

    David Penny
  10. Ed Harper
    Ed Harper avatar
    2 posts
    Registered:
    08 Oct 2009
    03 Nov 2010
    Link to this post
    I also have have updated my home machine to Windows 7 Pro x64, and am having issues getting Sitefinity 3.7 working.

    I found that the "Enable 32-Bit Applications" default to "False", in the IIS application pools.  Set it to true for the sitefinity websites (Error 500 - Internal Server Error).  Now the Project manager works well enough to create the project, however the test web site does not run.  Every page of the site throws an ASP.net 4.0 error message, even though I have set the website to run under a .NET 2.0 ApplicationPool.  I am guessing that this is related to the ASP.Net impersonation setting, but I am really just grasping at straws.

    I un-installed the .NET 3.5 version and updated to .NET4.0 edition.  Reset my AppPool to my Classic v2.0 .NET framework.  Now the project manager has Virtual directory authentication issues.  (I am beginning to see why the 4.0 beta has an integrated web server)

    I went through the IE8 permissions issues (http://www.sitefinitywatch.com/blog/09-04-21/Sitefinity_Project_Manager_Permission_Errors_in_IE8.aspx) for the .NET v3.5, however I no longer am prompted to log in.  If IE8 does not prompt for a log in, how do I change to the administrator user?

    Finally, I followed the blank project blog on: http://www.sitefinitywatch.com/blog/09-02-24/Installing_Sitefinity_using_Blank_Project.aspx, which works through the Visual Studio port (http://localhost:49288/Blank).  Unfortunately, the installed IIS server still has issues, Http error 404.0..
  11. Grisha Karanikolov
    Grisha Karanikolov avatar
    19 posts
    Registered:
    23 Mar 2010
    11 Nov 2010
    Link to this post
    I recently had a communication with a client that encountered the same error. Apparently there were ISAPI and CGI restrictions set on his IIS. In order to resolve that, what he did was to allow the ISAPI extensions through the IIS Admin as per the attached screenshot.

    Hope that helps!
  12. Cii
    Cii avatar
    10 posts
    Registered:
    13 Jan 2011
    24 Feb 2011
    Link to this post
    Yes, this solved my problem...
    Thank you Grisha......

  13. David
    David avatar
    1 posts
    Registered:
    05 Jan 2011
    29 Mar 2011
    Link to this post
    I was getting application errors on first install and this solved my problem.
    This should probably be a check step in the install to make sure the ISAP and CGI 4.0 DLL's are authorized to run.
Register for webinar
13 posts, 0 answered