+1-888-365-2779
Try Now
More in this section

Forums / Set-up & Installation / Ingtegrated vs. Classic Pipeline

Ingtegrated vs. Classic Pipeline

4 posts, 0 answered
  1. Armysniper
    Armysniper avatar
    126 posts
    Registered:
    03 Mar 2005
    08 Apr 2010
    Link to this post
    I installed my SiteFinity installation according to the manual and have been running fine since September of 09. Lately I have seen cases where there are differences depending on whether you are running in integrated over classic mode. Can we run SiteFinity well with Integrated mode? What are the issue if I were to switch to it?

    I have seen some bugs show up recently with regards to 404 pages (my 404 page is configured in web.config custom errors but it shows up at HTTPS!?! when my site does not), and using the IIS Rewrite module. So I am wondering if I am running into problems with trying to do stuff that Classic mode does not support well.
  2. Richard
    Richard avatar
    24 posts
    Registered:
    25 Apr 2008
    09 Apr 2010
    Link to this post
    Integrated pipeline mode works fine but it's not documented well.

    Telerik, please add the bit about updating the web.config to include <modules runAllManagedModulesForAllRequests="true"> to the manual. This was necessary for me to get it running without errors. The only place I see it on your site is in a couple of posts in the forum.
  3. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    13 Apr 2010
    Link to this post
    Hi Richard, Armysniper

    Here are the main differences between classic and integrated mode



    Kind regards,
    Ivan Dimitrov
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  4. Richard
    Richard avatar
    24 posts
    Registered:
    25 Apr 2008
    13 Apr 2010
    Link to this post
    Ivan,

    Thanks for that, but these two links DO NOT include the runAllManagedModulesForAllRequests="true" setting that I needed to make this work. And my point was really that it needs to be in the manual.

    The manual is very good but it's incomplete. Right now to find all of the functionality you need to check the forums AND the knowledge base AND the manual. This takes a lot of time. I know documenting things is hard but answering the same questions over and over must be hard too.

    Another example is the Domain-Page mapping feature - nice knowledge base article but it's not in the manual.

Register for webinar
4 posts, 0 answered