+1-888-365-2779
Try Now
More in this section

Forums / Set-up & Installation / Installing on shared hosted space

Installing on shared hosted space

6 posts, 0 answered
  1. Ken Knepple
    Ken Knepple avatar
    7 posts
    Registered:
    16 Sep 2009
    27 Feb 2010
    Link to this post
    I am currently trying to get Sitefinity to work at my host (Softsys).  I downloaded the Sitefinity_3_7_2057_standard_trial.exe and installed it on Windows 7 configuring by watching the Bullet Proof Guide to Installing Sitefinity 3.x and following this step by step.  This installs and works beautifully on my local machine.  So I am then ready to install at Softsys so I create a db by basically copying over to Softsys.  I change the connection strings in the web.config and I alslo the  <customErrors mode="Off" /> as well as insert this <trust level="Full" /> otherwise the folders will go back to medium according to Softsys.  Oh one more thing Softsys did change this area to running on full control.
    So when this all gets uploaded via Filezilla the homepage.aspx loads and the company emerald is there and looks great.  Upon going to the admin section (http://www.avidlaser.com/sitefinity/)  it then will throw a configuration error.

    Configuration Error Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

    Parser Error Message: Could not load file or assembly 'Telerik.Framework' or one of its dependencies. The system cannot find the file specified.

    Source Error:

    Line 166:      </eventMappings>
    Line 167:      <providers>
    Line 168: <add name="Simple Web Event Provider" type="Telerik.Utilities.TextFileWebEventProvider,Telerik.Framework" logFileName="~/App_Data/sitefinity.log" />Line 169:        <add name="Simple Web Buffered Event Provider" type="Telerik.Utilities.BufferedTextFileWebEventProvider,Telerik.Framework" bufferMode="Notification" logFileName="~/App_Data/sitefinity.log" />
    Line 170:        <add name="Code Benchmark Provider" type="Telerik.Utilities.CodeBenchmarkTextFileProvider,Telerik.Framework" enabled="False" logFileName="~/App_Data/performance.log" />

    Source File: C:\HostingSpaces\avidlabs\avidlaser.com\wwwroot\web.config    Line: 168

    Assembly Load Trace: The following information can be helpful to determine why the assembly 'Telerik.Framework' could not be loaded.

    WRN: Assembly binding logging is turned OFF.
    To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
    Note: There is some performance penalty associated with assembly bind failure logging.
    To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].
    


    Version Information: Microsoft .NET Framework Version:2.0.50727.4200; ASP.NET Version:2.0.50727.4016

    -------------------------------------------------------------------------------
    I have tried about 10 different things only to get back to this point.  I have deleted and started over yet to get back to this error.  I have sent Softsys links to this forum especially this link, which looks very familiar. http://www.sitefinity.com/support/forums/sitefinity-3-x/deployment/new-deployment-can-t-find-how-to.aspx and they tell me i am missing bin files but i have loaded that folder over and over and compared file to file and still it is not running.  Someone please assist.
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    28 Feb 2010
    Link to this post
    Hi Ken Knepple,

    The error is thrown, because Telerik.Framework.dll cannot be loaded from your bin - it does not exists there or somehow you project does not have reference to this dll. Also if you are running the website in medium trust healthMonitoring should be disabled.

    Regards,
    Ivan Dimitrov
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  3. Ken Knepple
    Ken Knepple avatar
    7 posts
    Registered:
    16 Sep 2009
    01 Mar 2010
    Link to this post
    1.  I am running in full trust mode according to my web.config. 

    <

     

    trust level="Full" />

     

     in the <system.web> section so I do have health monitoring enabled. Although  When I do disable it I get a different configuration error.

     

    Server Error in '/sitefinity' Application.

    Configuration Error

    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

    Parser Error Message: Could not load file or assembly 'Telerik.Cms' or one of its dependencies. The system cannot find the file specified. (C:\HostingSpaces\avidlabs\avidlaser.com\wwwroot\web.config line 145)

    Source Error:

    Line 143:    <httpModules>
    Line 144:      <add name="ScriptModule" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
    Line 145: <add name="Cms" type="Telerik.Cms.Web.CmsHttpModule, Telerik.Cms" />Line 146:      <!-- Http Module for extension mappings in Library module.-->
    Line 147:      <!--<add name="LibraryModule" type="Telerik.Libraries.LibraryHttpModule, Telerik.Libraries"/>-->

    Source File: C:\HostingSpaces\avidlabs\avidlaser.com\wwwroot\web.config    Line: 145


    Version Information: Microsoft .NET Framework Version:2.0.50727.4200; ASP.NET Version:2.0.50727.4016


    -------------------------------------------------------------

    I reloaded everything and checked it twice. (maybe three times)

    especially the bin file.  I did however enable health monitoring since I am in full trust mode and now I am back after deleting everything and re-ftp'ing everything right back to my original spot.

    With this error:

     

    Server Error in '/sitefinity' Application.

    Configuration Error

    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

    Parser Error Message: Could not load file or assembly 'Telerik.Framework' or one of its dependencies. The system cannot find the file specified.

    Source Error:

    Line 166:      </eventMappings>
    Line 167:      <providers>
    Line 168: <add name="Simple Web Event Provider" type="Telerik.Utilities.TextFileWebEventProvider,Telerik.Framework" logFileName="~/App_Data/sitefinity.log" />Line 169:        <add name="Simple Web Buffered Event Provider" type="Telerik.Utilities.BufferedTextFileWebEventProvider,Telerik.Framework" bufferMode="Notification" logFileName="~/App_Data/sitefinity.log" />
    Line 170:        <add name="Code Benchmark Provider" type="Telerik.Utilities.CodeBenchmarkTextFileProvider,Telerik.Framework" enabled="False" logFileName="~/App_Data/performance.log" />

    Source File: C:\HostingSpaces\avidlabs\avidlaser.com\wwwroot\web.config    Line: 168

    Assembly Load Trace: The following information can be helpful to determine why the assembly 'Telerik.Framework' could not be loaded.

    WRN: Assembly binding logging is turned OFF.
    To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
    Note: There is some performance penalty associated with assembly bind failure logging.
    To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].
    


    Version Information: Microsoft .NET Framework Version:2.0.50727.4200; ASP.NET Version:2.0.50727.4016



    Like I said I have checked the bin file over and over and watched the transfer over to Softsys cause I decided to start over, and walked through every failed transfer file Filezila reported and come back to this error.  Runs fine locally but I am shared hostedly challenged.  Please assist!
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    01 Mar 2010
    Link to this post
    Hi Ken Knepple,

    ASP.NET looks in the Global Assembly Cache, and then in the application's bin folder. If it cannot find the class with the name you specified then it will not  load. Check the version of .NETbeing used by IIS on your webserver and make sure that it is the same as the dlls you have.

    Greetings,
    Ivan Dimitrov
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  5. Ken Knepple
    Ken Knepple avatar
    7 posts
    Registered:
    16 Sep 2009
    01 Mar 2010
    Link to this post
    Ok Softsys mentions they are using ".NET framework version on our server is .NET 3.5 SP1." I just do not understand this runs perfectly here and then once it goes to Softsys it dies.
  6. Ken Knepple
    Ken Knepple avatar
    7 posts
    Registered:
    16 Sep 2009
    03 Mar 2010
    Link to this post
    I was looking through the kb and did not see this listing, and was wondering if you can post for me so Softsys can match it up.  Can you A.  show me what the file permissions or groups look like on their end?  Also possibly Anything else you can be thinking of as to why the GAC or my local bin directory does not find or have access to these .dll's thanks!
Register for webinar
6 posts, 0 answered