+1-888-365-2779
Try Now
More in this section

Forums / Set-up & Installation / Localization Issue

Localization Issue

2 posts, 0 answered
  1. Kiearn
    Kiearn avatar
    6 posts
    Registered:
    07 Aug 2008
    22 Apr 2009
    Link to this post
    Hi

    I have 2 languages on my site English and German. When someone from Germany views my site they get taken to the german version of the homepage rather then the english one.

    Is there any setting that would allow me to force the user to go to the english version of the homepage first.

    I'm using Version 3.6

    thanks
    Kieran  
  2. Ivan
    Ivan avatar
    478 posts
    Registered:
    16 Jun 2015
    22 Apr 2009
    Link to this post
    Hello Kiearn,

    the behavior you are seeing happens because Sitefinity by default reads the browser settings and tries to determine the most appropriate culture. You can turn this feature off by doing following:

    • Open you web.config file
    • Locate the <localization> section in your web.config file. It should look more or less like this:
      <localization defaultProvider="Sitefinity" persistenceMode="PathPrefix" defaultCulture="en" cultures="en, de, es, hr"
    • Add autoSetClientLanguage property to the localization element and set it to false, so that localization element looks more or less like this:
      <localization defaultProvider="Sitefinity" persistenceMode="PathPrefix" defaultCulture="en" cultures="en, de, es, hr" autoSetClientLanguage="false"

    I hope you'll find this information useful and that this will solve your problem. Let us know if there is anything else we can do for you.

    Kind regards,
    Ivan
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
2 posts, 0 answered