+1-888-365-2779
Try Now
More in this section

Forums / Set-up & Installation / Make Sitefinity ignore certain virtual directories

Make Sitefinity ignore certain virtual directories

9 posts, 0 answered
  1. Adam
    Adam avatar
    17 posts
    Registered:
    26 Feb 2009
    23 Apr 2009
    Link to this post
    Hi all,

    I have Sitefinity controlling my Web site, but I want to exclude certain virtual directories from Sitefinity control. For example, right now I have:

    mysite.com and it's children controlled by Sitefinity

    But now I also want:

    mysite.com/app1 and mysite.com/app2 to be ignored by Sitefinity and I will do custom development on these apps.

    Is there an exclusion list somewhere, because currently I have these virtual directories set up, but they are not working when you try to browse to them.

    Thanks!

  2. Pete
    Pete avatar
    20 posts
    Registered:
    24 Mar 2009
    23 Apr 2009
    Link to this post
    Can you elaborate on "not working"?

    In general, try wrapping your <system.web> element within a <location path="." inheritInChildApplications="false"> element.

    Without seeing what you're getting for errors, my first kneejerk reaction would be you are inheriting the web.config from your sitefinity application within your virtual directories.
  3. Adam
    Adam avatar
    17 posts
    Registered:
    26 Feb 2009
    23 Apr 2009
    Link to this post
    Thanks, I tried wrapping the system.web element as you suggested but it didn't work.

    "Not working" in this case means I am just getting a 404 when accessing these virtual directories while everything in Sitefinity is working though.

    When I test these apps by putting them on non-Sitefinity sites, they run fine so that's what led me to believe that there might be an "ignore" list to stop Sitefinity from trying to service these virtual directories.

    Thanks!

  4. Pete
    Pete avatar
    20 posts
    Registered:
    24 Mar 2009
    23 Apr 2009
    Link to this post
    I'd be immediately suspect of the configuration options for your virtual directories.

    Have you ensured each virtual directory is configured to use the correct version of the .NET framework? 

    IIS will through erroneous 404's when it has problems passing an http request to what it thinks is a non-existent handler.  You can replicate this behavior by turning off ASP.NET access and then calling a .aspx page.


    Have you tried placing a simple test.html page in one of your virtual directories, then see if you can display the page?  Something VERY simple like:

    <html>
    <body>
    w00t!  Success!
    </body>
    </html>


    That will tell you if you have a .NET config issue or a resolution/pathing issue.
  5. Adam
    Adam avatar
    17 posts
    Registered:
    26 Feb 2009
    23 Apr 2009
    Link to this post
    Aha, you may be on to something because instead of seeing new test.html using the contents that you provided when I try it, I get just a blank page and view/source shows these contents:

    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
    <HTML><HEAD>
    <META http-equiv=Content-Type content="text/html; charset=windows-1252"></HEAD>
    <BODY></BODY></HTML>

    However, if I just type the virtual dir path in the url without specifying a file name, I get 404 as before. I noticed that if I use this test.html filename or even if I totally make up a fake name that I know doesn't exist, I still get the blank page response with the contents above instead of the expected 404.

    Thanks!
  6. Adam
    Adam avatar
    17 posts
    Registered:
    26 Feb 2009
    23 Apr 2009
    Link to this post
    Just an update, for testing I bypassed my loadbalancer (that was giving 404's and blank pages when testing) and trying to access the virtual directories or the test.html file directly on the servers just results in waiting forever, a timeout basically.

    Thanks for all the pointers!
  7. Jules
    Jules avatar
    65 posts
    Registered:
    20 Jul 2005
    29 Apr 2009
    Link to this post
    I'm having a (slightly) similar problem. I've got a virtual directory that houses classic ASP code. I can navigate to .htm pages in the directory with no issue, but all .asp pages throw a 404. Thoughts?

    Julez
  8. Jules
    Jules avatar
    65 posts
    Registered:
    20 Jul 2005
    29 Apr 2009
    Link to this post
    Nevermind. Turns out Sitefinity's script that sets up new projects doesn't map the .asp extension to a handler. Fixed that and now it all works.
    J
  9. Pete
    Pete avatar
    20 posts
    Registered:
    24 Mar 2009
    29 Apr 2009
    Link to this post
    Julia,

    Does this happen for ALL .net sites on your server?  If so, check to ensure that ASP.NET v2.x has been set to "Allowed" under Web Service Extensions in IIS Manager.
Register for webinar
9 posts, 0 answered