+1-888-365-2779
Try Now
More in this section

Forums / Set-up & Installation / New Project Setup Not Completing

New Project Setup Not Completing

4 posts, 0 answered
  1. Paul Dench
    Paul Dench avatar
    19 posts
    Registered:
    26 Oct 2009
    16 Nov 2009
    Link to this post
    I am trying to set up a new project named "GLAdvisor" and am getting an error message. The message comes up right after I enter the database connection information. Why would this be looking at the "c:\inetpub\wwwroot" directory? The new project is in this folder: C:\Program Files\telerik\Sitefinity3.7\WebSites\GLAdvisor. I've already tried to add the ASPNET user and the Network Service user to have access to both of these locations. Any help would be greatly appreciated.

    The URL is:

    http://glsource01/gladvisor/sitefinity/cmsstartup.aspx

    The error message is:

     

    Server Error in '/GLAdvisor' Application.

    Configuration Error

    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

    Parser Error Message: An error occurred loading a configuration file: Access to the path 'c:\inetpub\wwwroot\web.config' is denied.

    Source Error:

    [No relevant source lines]

    Source File: c:\inetpub\wwwroot\web.config    Line: 0


    Version Information: Microsoft .NET Framework Version:2.0.50727.3053; ASP.NET Version:2.0.50727.3053
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    16 Nov 2009
    Link to this post
    Hello Paul Dench,

    This is a permission issue. The web.config file under wwwroot cannot be read/write. Please verify the permissions settings for ASP.NET/NETWORK SERVICE account.

    Regards,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  3. Paul Dench
    Paul Dench avatar
    19 posts
    Registered:
    26 Oct 2009
    16 Nov 2009
    Link to this post
    Hi,

    I verified the access for both of those accounts and they both have full access to the wwwroot folder.

    Paul
  4. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    17 Nov 2009
    Link to this post
    Hello Paul Dench,

    Well, the message is clearly showing that the worker account could not access the application. Perhaps you use another application pool identity, not the Network Service or ASPNET. Could you please check that?
    You can temporary give access to "Everyone" and you will see that the web site will be loaded. 

    Regards,
    Georgi
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
Register for webinar
4 posts, 0 answered