+1-888-365-2779
Try Now
More in this section

Forums / Set-up & Installation / News Module not working

News Module not working

5 posts, 0 answered
  1. Kalvin MacLeod
    Kalvin MacLeod avatar
    19 posts
    Registered:
    15 Nov 2005
    27 Nov 2008
    Link to this post

    Hello,

    I've just started creating a new sitefinity website from the 3.5sp1 standard blank project. I created a few pages, added a few templates etc. Did notice right away but when I click Modules -> News I get a parser error:

    Parser Error

    Description: An error occurred during the parsing of a resource required to service this request. Please review the following specific parse error details and modify your source file appropriately.

    Parser Error Message: Root element is missing.

    Source Error:

    [No relevant source lines]

    Source File: /Sitefinity/Admin/ControlTemplates/News/App_LocalResources/ControlPanelEdit.ascx.resx    Line: 0

    I haven't done any work with the News module yet, so not even sure what to look for. The file exists where it says it is and has information in it.

    Can you let me know what to do to fix this?

    Thanks,

    Kalvin
  2. Kalvin MacLeod
    Kalvin MacLeod avatar
    19 posts
    Registered:
    15 Nov 2005
    27 Nov 2008
    Link to this post
    Sorry, I should add all the other modules work fine.
  3. Pepi
    Pepi avatar
    981 posts
    Registered:
    28 Oct 2016
    28 Nov 2008
    Link to this post
    Hi Kalvin MacLeod,

    It seems ~/Sitefinity/Admin/ControlTemplates/News/App_LocalResources/ControlPanelEdit.ascx.resx file is not formatted properly, more exactly it's missing the root node. Please open the file with notepad for example and make sure it has a <root> element:

    <?xml version="1.0" encoding="utf-8"?> 
    <root> 
      ... 
    </root> 

    For your convenience I have attached a working version of the resource file.

    Do let us know if this helps.

    Regards,
    Pepi
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  4. J.R. Garcia
    J.R. Garcia avatar
    24 posts
    Registered:
    12 Aug 2008
    15 Mar 2010
    Link to this post
    I'm having this same issue. The error shows that /sitefinity/Admin/App_LocalResources/ModifiedBlogPost.ascx.resx is the problem. This file doesn't exist, so I can't fix the root element of it. How do I go about fixing this if the file does not exist?

    Thanks,

    J.R. Garcia
  5. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    15 Mar 2010
    Link to this post
    Hi J.R. Garcia,

    We do not have a resx file called ModifiedBlogPost.ascx.resx that is located under /sitefinity/Admin/App_LocalResources/. Check,  in which template you are trying to use some resources from ModifiedBlogPost.ascx.resx. It seems that you are referencing this file somehow.

    Best wishes,
    Ivan Dimitrov
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
Register for webinar
5 posts, 0 answered