+1-888-365-2779
Try Now
More in this section

Forums / Set-up & Installation / Problem installing on Win7

Problem installing on Win7

11 posts, 1 answered
  1. Stuart Hemming
    Stuart Hemming avatar
    144 posts
    Registered:
    07 Jul 2004
    04 May 2010
    Link to this post
    I have, on my local machine, Win7 Ultimate.

    I've been following the installation guide. I've carried out all the steps up to the start of step 6, which is running the Project Manager.

    I fire up IE as administrator and navigate to the page and it returns ...

    HTTP Error 404.17 - Not Found

    The requested content appears to be script and will not be served by the static file handler.


    Can anyone tell me what I'm doing wrong?

    --
    Stuart
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    04 May 2010
    Link to this post
    Hi Stuart Hemming,

    To fix this error try changing you application pool from default to Classic .NET AppPool - IIS 7 HTTP Error 404.17 The requested content appears to be script

    Also under Handler Mappings make sure that you have ISAPI mapping handler for .aspx. If you are running 64 bit machine enable "Enable 32-bit Applications" in the "Advanced Settings" of Application Pool.

    Kind regards,
    Ivan Dimitrov
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
    Answered
  3. Stuart Hemming
    Stuart Hemming avatar
    144 posts
    Registered:
    07 Jul 2004
    05 May 2010
    Link to this post
    Ivan,

    Top Lad!

    >  If you are running 64 bit machine enable "Enable 32-bit Applications" in the "Advanced Settings" of Application Pool.
    This was the cause of the problem.

    TVM.

    -- 
    Stuart
  4. Neb
    Neb avatar
    7 posts
    Registered:
    09 Nov 2010
    09 Nov 2010
    Link to this post
    Hi,

    I installed Sitefinity 3.7 on Win 7 Enterprise (32-bit) desktop and followed all the steps in "Bullet Proof Guide to Installing Sitefinity 3.x"
    I am still getting the followoing error when I try opening the Sitefinity Project Manager web site.

     

    HTTP Error 404.17 - Not Found

    The requested content appears to be script and will not be served by the static file handler.

    Would you please advise if there is anything else I could check on my system?

    Thanks,
    Neb

  5. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    09 Nov 2010
    Link to this post
    Hi Neb,

    You can check whether the .NET version of the application pool under which the website runs is the same as the .NET version of the project you have downloaded.

    Sincerely yours,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  6. Neb
    Neb avatar
    7 posts
    Registered:
    09 Nov 2010
    10 Nov 2010
    Link to this post
    Hi Ivan,

    The application pool is set as Classic .NETAppPool and runs under .NET Framework v2.0.50727.
    I was able to complete installation of Sitefinity_3_7_2136_standard.exe but when I try to open a website
    http://localhost/telerik/sitefinity3.7/ I get the "HTTP Error 404.17 - Not Found" error.
  7. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    10 Nov 2010
    Link to this post
    Hi Neb,

    "The application pool is set as Classic .NETAppPool and runs under .NET Framework v2.0.50727.I was able to complete installation of Sitefinity_3_7_2136_standard.exe"

    Sitefinity 3.7 Standard.exe uses .NET Framework 3.5.

    "You can check whether the .NET version of the application pool under which the website runs is the same as the .NET version of the project you have downloaded."

    Sincerely yours,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  8. Neb
    Neb avatar
    7 posts
    Registered:
    09 Nov 2010
    10 Nov 2010
    Link to this post
    Hi Ivan,

    As recommended in the installation guide for Sitefinity 3.x I set the Application Pool to Classic .NETAppPool.
    My only options for .NET Framework Version for Classic .NETAppPool are:
        - v2.0
        - No Managed Code.
    The same options apply even if I select DefaultAppPool.

    I do have .NET Framework 3.5 installed on my machine, it came with Visual Studio 2008.

    Please advice what are the right settings for Sitefinity 3.7 or if there are any settings not covered in the installation guide that apply to this version only.

    Thanks,
    Neb

  9. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    10 Nov 2010
    Link to this post
    Hello Neb,

    There is not difference between installation process of .NET packages of Sitefinity. You are using lower version of .net to run the work process.  If your IIS does not have .NET 3.5, you can use our build for .NET 2.0 edition. The .NET 3.5 is not a stand alone framework like v2.0 in IIS. It is just an extension of the 2.0 framework. You could also proceed with Blank project installation

    Best wishes,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  10. Neb
    Neb avatar
    7 posts
    Registered:
    09 Nov 2010
    11 Nov 2010
    Link to this post
    Hi Ivan,

    Unfortunately, I still have issues opening http://localhost/telerik/sitefinity3.7/ site.
    I downloaded a patch for this version of Sitefinity (Sitefinity_3_7_2136_standard_patch.zip) and unzipped it but not sure how to apply the patch.
    Are there any instructions on how to apply this patch?

    Thanks,
    Neb
  11. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    11 Nov 2010
    Link to this post
    Hi Neb,

    Take a look at our Upgrade Instructions

    All the best,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Register for webinar
11 posts, 1 answered