Try Now
More in this section

Forums / Set-up & Installation / Rad Controls install breaks Sitefinity dev environment

Rad Controls install breaks Sitefinity dev environment

3 posts, 0 answered
  1. Jim
    Jim avatar
    1 posts
    09 Dec 2008
    19 Mar 2010
    Link to this post
    I downloaded the demo version of Sitefinity 3.7 a few weeks ago and installed successfully on my machine.  I created a basic solution and everything was working great. 

    Recently I also downloaded the Telerik RadControls and installed those on the same machine - however now I'm unable to build the Sitefinity solution I created.  The error I get is "Could not load file or assembly 'Telerik.Web.UI, Version=2009.3.1103.35, Culture=neutral, PublicKeyToken=121fae78165ba3d4' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)   C:\Dev\...\cmsentrypoint.aspx".

    Looking at cmsentrypoint.aspx didn't help - is there versioning information I need to change?
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    19 Oct 2016
    19 Mar 2010
    Link to this post
    Hi Jim,

    The located assembly's manifest definition does not match the assembly reference

    Most probably the version of the RadControls you have installed in not the same as this one used in Sitefinity. Then the referenced assemblies version has been changed and the application cannot find the correct dll. Check the project references and check your GAC to see what version is listed there. This Microsoft article states that assemblies found in the GAC are not copied locally during a build, so you might need to remove the old version before doing a rebuild all. 

    You can use the fuslogvw.exe application that ships with Visual Studio to get more information about the binding failures.

    Ivan Dimitrov
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  3. Thomas Weidman
    Thomas Weidman avatar
    38 posts
    19 Apr 2004
    02 Apr 2010
    Link to this post

    Hello.  I had the same issue with the last 2009 release of the RadControls.  The "auto" detection and update process integrated into Visual Studio was the cause for me.  With the latest 2010 release this has been fixed, but previously I was able to fix by uninstalling RadControls and replacing the update Telerik.Web.UI.dll that was overwritten with the original version I downloaded.

Register for webinar
3 posts, 0 answered