+1-888-365-2779
Try Now
More in this section

Forums / Set-up & Installation / Search not working correctly in patched website

Search not working correctly in patched website

7 posts, 0 answered
  1. Annie
    Annie avatar
    123 posts
    Registered:
    08 Apr 2009
    18 May 2010
    Link to this post
    Hi,

    We recently upgraded our website from 3.5 to 3.7 SP3. In the upgraded site, search is not working correctly, it is not returning all the same results as our old website what could be the reason for this?

    Thanks,
    Annie
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    18 May 2010
    Link to this post
    Hello Annie,

    What is the difference between the search results returned under build 3.5 and 3.7 of Sitefinity?

    Kind regards,
    Ivan Dimitrov
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  3. Annie
    Annie avatar
    123 posts
    Registered:
    08 Apr 2009
    19 May 2010
    Link to this post
    Hi Ivan,

    Thanks for your reply. Not all the pages are appearing in the upgraded website, even though all the pages are indexed. Is the search engine 3.7 same as the one in 3.5?

    Thanks,
    Annie
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    19 May 2010
    Link to this post
    Hi Annie,

    1. Check whether Index this page is set for the pages you think that are not added to the index.
    2. Check whether Index non-public pages checkbox is checked/not checked.
    3. Verify that the number of the indexed pages is the same as the number you have in your sitemap - when you go to Pages in 3.7 SP3 there is label that shows the number of all pages.


    There must be something in the problematic pages that prevents the crawler to get the HTML. It could be a control on these pages or some control or code in the master page. Th

    1. Crate a new master page without any css, js and controls on it. Add just one ContentPlaceHolder.
    2. Create a new page and set the page to use the newly created template with a single ContentPlaceHolder
    3. Drop a GenericContent control on this page and type a simple text in it - say "Telerik".
    4. Save the page and make sure that it is with status "Published".
    5. Run the search index.
    6. Go to the page where you have already dropped SearchResults and SearchBox control and look up for "Telerik"

    Make sure that you have not set any negative value for the weight in fieldsInfoProvider.xml -  How to customize the indexing of html documents

    You may find this post useful.

    Sincerely yours,
    Ivan Dimitrov
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  5. Annie
    Annie avatar
    123 posts
    Registered:
    08 Apr 2009
    19 May 2010
    Link to this post
    Hi Ivan,

    I tried what you suggested and the new page that I created with single contentplaceholder is not showing up in search

    Thanks,
    Annie
  6. Annie
    Annie avatar
    123 posts
    Registered:
    08 Apr 2009
    19 May 2010
    Link to this post
    Hi Ivan,

    Sorry I made a mistake the test page is showing up

    Thanks,
    Annie
  7. Annie
    Annie avatar
    123 posts
    Registered:
    08 Apr 2009
    20 May 2010
    Link to this post
    Hi,

    I removed the divs that were preventing the pages from being indexed, but the pages are still not appearing in search

    Thanks,
    Annie
Register for webinar
7 posts, 0 answered