+1-888-365-2779
Try Now
More in this section

Forums / Set-up & Installation / Service Application Unavailable Error

Service Application Unavailable Error

5 posts, 0 answered
  1. Femy
    Femy avatar
    37 posts
    Registered:
    02 Jan 2008
    16 Jul 2008
    Link to this post
    Hi

    I have installed Sitefinity Std Edition on XP/IIS 5.1/SQL server 2005. When I go to http://localhost/telerik/Sitefinity3.2/ I get the following error message.

    Server Application Unavailable

    The web application you are attempting to access on this web server is currently unavailable.  Please hit the "Refresh" button in your web browser to retry your request.


    I ahve configured the IIS (page 285)and db (page 265) as per the User manual. Am i missing something else here. Pls help.

    TIA

    FR


  2. Pepi
    Pepi avatar
    981 posts
    Registered:
    08 Dec 2016
    17 Jul 2008
    Link to this post
    Hi Femy,

    Please, make sure of the following:
        1. You have granted full access to
    the ASPNET worker process and the account running it has read/write permissions over Sitefinity directory.
        2. You have installed .NET Framework v2.x on your machine. Also, Project Manager should set as ASP.NET 2.0 web application. To check this, follow the instructions below:
    • Run IIS.
    • Right-click Sitefinity3.x virtual folder and select Properties.
    • Click the ASP.NET tab.
    • In the ASP.NET version field, 2.0.50727 should be selected.
        3. .NET Framework is properly registered in the IIS. For example installing IIS after the .NET Framework can cause problems and you need to run the following in the Command Prompt:

        (cmd.exe)
        C:\Windows\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis –i.

    Do let us know how it goes.

    Sincerely yours,
    Pepi
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  3. Femy
    Femy avatar
    37 posts
    Registered:
    02 Jan 2008
    30 Jul 2008
    Link to this post
    Thanks. This helped. I also did an IIS restart.

    FR
  4. Roberto Modica
    Roberto Modica avatar
    146 posts
    Registered:
    08 Feb 2008
    05 Sep 2008
    Link to this post
    Hi,

    I have given full access to Network Service, IIS_Usr IIS_Users ASP.Net and i know that ASP.Net 2.0 is being used.

    What else am i missing?

    Rob
  5. Pepi
    Pepi avatar
    981 posts
    Registered:
    08 Dec 2016
    08 Sep 2008
    Link to this post
    Hello Roberto,

    Most probably your Microsoft .NET Framework is not registered correctly. In this case you need to register the .NET Framework with the Microsoft IIS web server. To do so, follow the steps below:
       1. Click Start, and then click Run.
       2. Type cmd, and then click OK.
       3. At the Command Prompt, type the following command, and then press ENTER:
           "\WindowsFolder\Microsoft.NET\Framework\VersionNumber\aspnet_regiis.exe" -i

    Note: Replace WindowsFolder with the name of the directory where the operating system is installed. Replace VersionNumber with the .NET Framework version installed on your computer.

    Once you have completed this process, you should be able to run your application without any problems.

    Do let us know how it goes.

    Regards,
    Pepi
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
Register for webinar
5 posts, 0 answered