+1-888-365-2779
Try Now
More in this section

Forums / Set-up & Installation / Set Database

Set Database

10 posts, 0 answered
  1. WebDev
    WebDev avatar
    5 posts
    Registered:
    12 Nov 2008
    14 Nov 2008
    Link to this post

    Hello,

    I got the following error message when trying to set the Database; do you know what this means?

    Thank you.


    Server Error in '/sitename' Application.



     

    Configuration Error

    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

    Parser Error Message: Invalid object name 'sys.procedures'.
    Invalid object name 'sys.schemas'.
    Invalid object name 'sys.sql_modules'.

    Source Error:

    Line 87:         <clear />
    Line 88:         <add connectionStringName="DefaultConnection" applicationName="/"
    Line 89:           name="Sitefinity" type="Telerik.DataAccess.AspnetProviders.TelerikRoleProvider, Telerik.DataAccess" />
    Line 90:       </providers>
    Line 91:     </roleManager>

    Source File: C:\Program Files\telerik\Sitefinity3.5 Community\WebSites\sitename\web.config    Line: 89
  2. Joe
    Joe avatar
    138 posts
    Registered:
    24 Sep 2012
    14 Nov 2008
    Link to this post
    Hi,

    Thanks for contacting us.

    Are you, by any chance upgrading a project created with version 3.0? Please bear in mind that the automatic upgrade of projects created with Sitefinity 3.0 directly to 3.1 SP2 is not possible because the database and folder structure is now very different (e.g. the ~/Admin folder is now located under ~/Sitefinity/Admin) and there are a lot of changes made to the web.config file.

    In order to give further advice, we need to know the exact Sitefinity version with which the project was created.
    You can check this by opening your project bin folder and checking the version numbers of the Telerik.Cms.dll from the Properties > Version tab.


    All the best,
    Joe
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  3. WebDev
    WebDev avatar
    5 posts
    Registered:
    12 Nov 2008
    15 Nov 2008
    Link to this post
    Hi, thanks for the prompt response. The Sitefinity version with which the project was created is  '3.5.1747.3'.

    This was not an upgrade but a fresh install of the latest version of the product.

    Thank you again.
  4. Vlad
    Vlad avatar
    498 posts
    Registered:
    15 Jul 2016
    17 Nov 2008
    Link to this post
    Hello,

    What version of SQL Server are you using? Make sure that the Nolics drivers are properly set in the web.config, e.g.:

        - in case of SQL Server 2000:
    <telerik>  
        <dataAccess defaultConnection="DefaultConnection">   
          <connections>  
            <add name="DefaultConnection" driver="Nolics.ORMapper.DataProviders.SqlServer2000Provider"  
              connectionStringName="Sitefinity" />  
            <add name="GenericContentConnection" driver="Telerik.Cms.Engine.Data.Providers.GCSql2000Provider, Telerik.Cms.Engine.Data"  
              connectionStringName="Sitefinity" />  
          </connections>  
     
        </dataAccess> 
       
        - in case of SQL Server 2005:
    <telerik>  
        <dataAccess defaultConnection="DefaultConnection">   
          <connections>  
            <add name="DefaultConnection" driver="Nolics.ORMapper.DataProviders.SqlServer2005Provider"  
              connectionStringName="Sitefinity" />  
            <add name="GenericContentConnection" driver="Telerik.Cms.Engine.Data.Providers.GCSql2005Provider, Telerik.Cms.Engine.Data"  
              connectionStringName="Sitefinity" />  
          </connections>  
     
        </dataAccess>  



    Regards,
    Vlad
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  5. WebDev
    WebDev avatar
    5 posts
    Registered:
    12 Nov 2008
    18 Nov 2008
    Link to this post
    Well, I haven't even made the changes you suggested and now I'm not even able to access the Project manager; I came accross the following problem. Any thoughts?


    /////////////////////////////////////////////////////////////////////////
     

    Server Error in '/telerik' Application.

    The resource cannot be found.

    Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable.  Please review the following URL and make sure that it is spelled correctly.

    Requested URL: /telerik/Sitefinity3.x/default.aspx


    Version Information: Microsoft .NET Framework Version:2.0.50727.3053; ASP.NET Version:2.0.50727.3053



    /////////////////////////////////////////////////////////////////////////
  6. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    19 Nov 2008
    Link to this post
    Hello WebDev,

    Please refer to the troubleshooting article Error 404 when Starting Sitefinity from All Programs, hopefully this will help. You may also see if the default web site in IIS is started.
    We suggest you then to check your web.config file for the settings we mentioned in our previous post.

    Let us know about the results.

    Best wishes,
    Georgi
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  7. WebDev
    WebDev avatar
    5 posts
    Registered:
    12 Nov 2008
    20 Nov 2008
    Link to this post
    I'm running IIS 5.1 in Windows XP SP2 so the Web Service Extensions node that would allow me to set ASP.NET v2.0.50727 to 'Allow' isn't available. Are there any workarounds?
  8. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    24 Nov 2008
    Link to this post
    Hello WebDev,

    Could you check whether your default website is running and you have set ASP.NET v.2.0.50727 in ASP tab of IIS( you can check what is installed typing DOS command "aspnet_regiis.exe -lk" )?

    Kind regards,
    Ivan Dimitrov
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  9. WebDev
    WebDev avatar
    5 posts
    Registered:
    12 Nov 2008
    25 Nov 2008
    Link to this post
    Hello,

    Yes, the default web site is running; below are the results of running 'aspnet_regiis.exe -lk' from the command prompt.

    C:\WINDOWS\Microsoft.Net\Framework\v2.0.50727>aspnet_regiis.exe -lk
    W3SVC/ 2.0.50727.0
    w3SVC/1/ROOT/ 2.0.50727.0
    W3SVC/1/ROOT/telerik/ 2.0.50727.0
    W3SVC/1/ROOT/telerik/Sitefinity3.5.Community/ 2.0.50727.0

  10. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    26 Nov 2008
    Link to this post
    Hi WebDev,

    From one of the previous posts I noticed that you were trying to load Requested URL: /telerik/Sitefinity3.x/default.aspx
    As I see it, it should be Requested URL: /telerik/Sitefinity3.5/default.aspx

    Kind regards,
    Ivan Dimitrov
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
Register for webinar
10 posts, 0 answered