Try Now
More in this section

Forums / Set-up & Installation / Setting default settings for Radeditor right across admin

Setting default settings for Radeditor right across admin

2 posts, 0 answered
  1. UI Crew
    UI Crew avatar
    151 posts
    27 Sep 2012
    01 Jul 2008
    Link to this post

    In Sitefinity admin there is quite a few instances of Radeditor especially if you have lots of additonal providers and although there is I think 2 different toolbars in use which is fine there is some settings that we want to set across all instances of RadEditor used in Admin.

    I don't really want to have to go and add these settings to every single admin template that has a editor if I can help it.

    For example:
    StripFormattingOnPaste="MSWordRemoveAll" or

    Normally I would do this in my application by setting the default settings I want all instances of a control to have in my skin file but Sitefinity Admin doesn't seem to have a skin file.

    Is there a way to do this cause setting default properties for each instance isn't that convient or fool proof or tidy.



  2. Rebecca
    Rebecca avatar
    536 posts
    24 Sep 2012
    03 Jul 2008
    Link to this post
    Hello Seth Cleaver,

    You are right that currently it is way too complicated to configure the settings for all the editor instances in the same way. We have had similar requests and have discussed the possibilities for improving this functionality in one of our next releases and more specifically, the ability to enable and disable tools for the editor from the UI.
    As for setting properties like NewLineBr="False" across all editors in the admin, with the current implementation this is not possible. You have to edit the corresponding templates (ControlPanelEdit.aspx and ControlPanelInsert.aspx for each module) and then copy the whole folder for your custom providers. There is no simpler way, unfortunately. We are really sorry for the inconvenience this has been causing.

    Sincerely yours,
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
2 posts, 0 answered