+1-888-365-2779
Try Now
More in this section

Forums / Set-up & Installation / sitefinity install trouble on windows 7

sitefinity install trouble on windows 7

9 posts, 0 answered
  1. tim
    tim avatar
    1 posts
    Registered:
    27 Jul 2010
    14 Sep 2010
    Link to this post
    Sitefinity would not install for me on windows 7.  i tried again with my anitvirus off.

    I suspect this is an iis config issue, since this is a new network install of windows 7 that probably has iis shutdown by default.  

    I see an iis reset window pop up for second and then I get an error " error creating virtual directory telerik.  details unknown error 0x80005000.  

    so it sounds like a file permissions with iis 7.  i have never used iis7 before so not sure where to start.  

    thanks for help so i can evaluate this demo.  

    cheers


  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    15 Sep 2010
    Link to this post
    Hi tim,
    1. The Sitefinity installer isn’t being run as Administrator.
    2. IIS has not been installed.
    3. The necessary IIS features have not been installed.
    4. The Default Web Site in IIS has been removed or renamed.
    5. The current user you use does not have permissions to create virtual directories in IIS.
    You can also take a look at

    Cannot create virtual directory 'telerik'
    Sitefinity Project Manager: Permission Errors in IE8
    Regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. MattL
    MattL avatar
    7 posts
    Registered:
    21 Feb 2009
    30 Sep 2010
    Link to this post
    I can't install community 3.7 sp4 (.net 3.5sp1). I had no issues installing/creating with 3.7 service pack 3.
    First I uninstalled sp3 then I tried installing sp4 with same steps, but now I get a error "1001" towards the end of the msi install.
    WIN 7 x64 Ultimate, IIS 7.5, .net 3.5sp1.
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    30 Sep 2010
    Link to this post
    Hello MattL,

    1. You can use Blank project installation which does not uses executable. This should work for sure.

    2. You can backup the following files 

    Websites
    ProjectManager

    from your existing Telerik\Sitefinity3.7 directory.

    Uninstall the existing version of Sitefinity from ControlPanel  >> Programs

    Then try to install Sitefinity SP4 and if everything is file, merge Websites folder with the newly installed. You have to do the same for ProjectManager/App_Data/Projects.xml file. This XML file contains data for all projects you have installed and reference to them

    Note
    : if something fails, you will not be able to restore your old data, because the previous version of Sitefinity will be uninstalled. You can try this on a virtual machine or anther server.

    If you want you can provide us with RDP credentials to your/test server. We will log in and try to install Sitefinity or at least take a quick look what could be the problem. There are several more customers that reported the same issue, but we cannot reproduce it locally and we suspect the the problem comes from merging configuration between old project manager and the new one that is being installed.


    All the best,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. MMcRoberts
    MMcRoberts avatar
    1 posts
    Registered:
    05 Jun 2009
    01 Oct 2010
    Link to this post
    We are having the same problem as MattL... trying to upgrade from 3.7 sp3 to 3.7 sp4 goes through the install, reboots IIS, but then fails with "Error 1001" and no details.

    Have you made any further diagnosis of what causes this error?

    Your warning of "Note: if something fails, you will not be able to restore your old data" makes me reluctant to try the advice you gave MattL!
  6. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    01 Oct 2010
    Link to this post
    Hi Richard,

    Yes, we spend some time on this and we think that there could be some issue with any update installed on the servers. So far we have not found the actual issue of the problem and we will work next week again to see what could be the problem with this. For sure there is something wrong, but at this stage we are not able to determine whether the problem comes from our code or the bug is something in the installshied. The issue is somehow sporadic -it occurs only on certain machines and it is hard for us to find a logical reason.
    My warning note is in case you have not backed up your data, otherwise there should not be a problem. I suggest that you should use the Blank project which works fine and there is no difference between the code in the Blank project and projects that have been installed through the Project Manager.

    Best wishes,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  7. MattL
    MattL avatar
    7 posts
    Registered:
    21 Feb 2009
    20 Oct 2010
    Link to this post
    Correction to my first post: I had service pack 2
  8. Eric Tangedahl
    Eric Tangedahl avatar
    12 posts
    Registered:
    11 Aug 2009
    26 Oct 2010
    Link to this post
    I can't seem to uninstall everything to get a fresh start.  I've tried serveral times to reinstall IIS with the correct features only to get the 1001 Error again on install.  Do I need to manually uninstall some items to get me back to page 1?

    Thanks,
    Eric

  9. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    26 Oct 2010
    Link to this post
    Hi Eric,

    Have you tried Blank project installation?

    Greetings,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Register for webinar
9 posts, 0 answered