+1-888-365-2779
Try Now
More in this section

Forums / Set-up & Installation / There were errors during services initialization, check the error log for details.

There were errors during services initialization, check the error log for details.

9 posts, 0 answered
  1. Mike
    Mike avatar
    5 posts
    Registered:
    20 Oct 2011
    16 Nov 2011
    Link to this post
    On a brand new installation of 3.7 SP4 (so I can upgrade a 3.7 site to 4.3) I am getting this error immediately after the database set up page:

    There were errors during services initialization, check the error log for details.


    The information in the error log is useless. It is just repeating the error on the page. Trying to upgrade from 3.7 to 4.X seems to be a never-ending nightmare.

    Windows 7
    IIS7
    Also running 4.3 on the same machine

    -Mike
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    17 Nov 2011
    Link to this post
    Hello Mike,

    Could you clear the log (sitefinity.log) from App_Data, then restart the application, make a new request that will cause the issue and after that paste or attach all that is added to to the log.
    This error could not be caused if this is a new clean installation. You have made some config changes or this is an old project that is upgraded. This error means that one of the services like search, rss etc could not be initialized by the provider. So I hope that the log will have more information. Note that this error is result of another error that should be written in the log at the same time or several minutes before that. Generally the error appears when application poor recycling occurs, because this is the time when all services, providers etc are initialized.

    Regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Mike
    Mike avatar
    5 posts
    Registered:
    20 Oct 2011
    17 Nov 2011
    Link to this post
    Here you go:

    11/17/2011 12:25:22 PM [EXCEPTION]
    ************************************************************************************
    ID: 4fdd1afc-3c49-4271-8793-7484c3ef7981; Code: 100103; Occurrence: 1; Sequence: 2
    ------------------------------------------------------------------------------------


    Application information:
    Machine name: LT-F4MD5Q1
    OS Version: Microsoft Windows NT 6.1.7601 Service Pack 1
    Product Version: 3.7.2136.240
    Application Path: C:\Projects\Sites\salix37sp4\
    Debug: False


    Process information:
    Process ID: 7392
    Process Name: w3wp


    Request information:
    Request URL: /
    Rewrite URL: http://127.0.0.1/
    Url Referrer: Is Authenticated: False
    Authentication Type: User: User Agent: 
    User Address: 127.0.0.1


    Variables:
    System.Object: System.Object
    System.Object: System.Object


    - L0 -------------------------------------------------------------------------------


    Exception Type: System.ArgumentException


    Message: Could not find a type for a name.  The type name was 'CustomRssFeed, App_Code.q2z3hg0d, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null'.


    Source: Telerik.Framework


    Stack Trace: 
       at Telerik.Utilities.TypeResolutionService.GetType(String name, Boolean throwOnError, Boolean ignoreCase)
       at Telerik.Rss.RssFeedInfo..ctor(IRssFeed feed)
       at Telerik.Rss.RssProviderService.Initialize()
       at Telerik.Framework.ServiceHost.Initialize()
    ------------------------------------------------------------------------------------






    11/17/2011 12:25:22 PM [UNKNOWN]
    ************************************************************************************
    ID: 2fd6b363-3a9f-41ae-ac44-d6b0d81f1d34; Code: 3005; Occurrence: 1; Sequence: 3
    ------------------------------------------------------------------------------------


    Application information:
    Machine name: LT-F4MD5Q1
    OS Version: Microsoft Windows NT 6.1.7601 Service Pack 1
    Product Version: 3.7.2136.240
    Application Path: C:\Projects\Sites\salix37sp4\
    Debug: False


    Process information:
    Process ID: 7392
    Process Name: w3wp


    Request information:
    Request URL: /Sitefinity/Default.aspx
    Rewrite URL: http://salix37sp4.medthink-dev.local/Sitefinity/Default.aspx
    Url Referrer: http://salix37sp4.medthink-dev.local/sitefinity/cmsstartup.aspx
    Is Authenticated: False
    Authentication Type: User: User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/535.2 (KHTML, like Gecko) Chrome/15.0.874.120 Safari/535.2
    User Address: 127.0.0.1


    Variables:


    - L0 -------------------------------------------------------------------------------


    Exception Type: System.Web.HttpException


    Message: There were errors during services initialization, check the error log for details.


    Source: Telerik.Framework


    Stack Trace: 
       at Telerik.Framework.ServiceHost.Initialize()
       at Telerik.Cms.Web.CmsHttpModule.Init(HttpApplication context)
       at System.Web.HttpApplication.RegisterEventSubscriptionsWithIIS(IntPtr appContext, HttpContext context, MethodInfo[] handlers)
       at System.Web.HttpApplication.InitSpecial(HttpApplicationState state, MethodInfo[] handlers, IntPtr appContext, HttpContext context)
       at System.Web.HttpApplicationFactory.GetSpecialApplicationInstance(IntPtr appContext, HttpContext context)
       at System.Web.Hosting.PipelineRuntime.InitializeApplication(IntPtr appContext)
    ------------------------------------------------------------------------------------






    11/17/2011 12:25:22 PM [UNKNOWN]
    ************************************************************************************
    ID: 83017bb5-51b1-4832-94a2-232e7b23d258; Code: 3005; Occurrence: 2; Sequence: 4
    ------------------------------------------------------------------------------------


    Application information:
    Machine name: LT-F4MD5Q1
    OS Version: Microsoft Windows NT 6.1.7601 Service Pack 1
    Product Version: 3.7.2136.240
    Application Path: C:\Projects\Sites\salix37sp4\
    Debug: False


    Process information:
    Process ID: 7392
    Process Name: w3wp


    Request information:
    Request URL: /favicon.ico
    Rewrite URL: http://salix37sp4.medthink-dev.local/favicon.ico
    Url Referrer: Is Authenticated: False
    Authentication Type: User: User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/535.2 (KHTML, like Gecko) Chrome/15.0.874.120 Safari/535.2
    User Address: 127.0.0.1


    Variables:


    - L0 -------------------------------------------------------------------------------


    Exception Type: System.Web.HttpException


    Message: There were errors during services initialization, check the error log for details.


    Source: Telerik.Framework


    Stack Trace: 
       at Telerik.Framework.ServiceHost.Initialize()
       at Telerik.Cms.Web.CmsHttpModule.Init(HttpApplication context)
       at System.Web.HttpApplication.RegisterEventSubscriptionsWithIIS(IntPtr appContext, HttpContext context, MethodInfo[] handlers)
       at System.Web.HttpApplication.InitSpecial(HttpApplicationState state, MethodInfo[] handlers, IntPtr appContext, HttpContext context)
       at System.Web.HttpApplicationFactory.GetSpecialApplicationInstance(IntPtr appContext, HttpContext context)
       at System.Web.Hosting.PipelineRuntime.InitializeApplication(IntPtr appContext)
    ------------------------------------------------------------------------------------





  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    17 Nov 2011
    Link to this post
    Hi Mike,

    You have a custom class that breaks the project.


    Message: Could not find a type for a name.  The type name was 'CustomRssFeed, App_Code.q2z3hg0d, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null'.

    Check if it is there and defined correctly. Clean and rebuild the project.

    Kind regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Mike
    Mike avatar
    5 posts
    Registered:
    20 Oct 2011
    17 Nov 2011
    Link to this post
    Ivan, I didn't add the class. The install added it. I will try to clean it and see what happens.
  6. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    17 Nov 2011
    Link to this post
    Hi Mike,

    The installation could not add such a class - CustomRssFeed. Also we do not expose App_Code folder and the provider is compiled in the dll. Also there is no such naming convention, so this couldn't be added by the default installation. You have something left on your machine.

    Kind regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  7. Mike
    Mike avatar
    5 posts
    Registered:
    20 Oct 2011
    17 Nov 2011
    Link to this post
    This upgrade process from 3.7 to 4.x is an unbelievable pain. Why is there no direct upgrade path from 3.7 to 4.3 without having to upgrade to 3.7 SP4?  This is the entire reason I am trying to accomplish this.
  8. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    18 Nov 2011
    Link to this post
    Hello Mike,

    The minimum requirement for upgrade is 3.7 edition. I think that you don't need to have the latest SP. We made changes to the migration in the latest release - 4.3

    Greetings,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  9. Mike
    Mike avatar
    5 posts
    Registered:
    20 Oct 2011
    18 Nov 2011
    Link to this post
    I have tried the 4.3 build and the error that I keep getting is "installation package for the build version of the specified SF3.7 project is missing". This is after I have modified the web.config and added the appropriate zip file to the project to be migrated. This is why I was going down the manual route.

Register for webinar
9 posts, 0 answered