+1-888-365-2779
Try Now
More in this section

Forums / Set-up & Installation / unknown server tag sfBlogDesignSettings:BehaviorSetting

unknown server tag sfBlogDesignSettings:BehaviorSetting

7 posts, 0 answered
  1. Mikael Kleinwort
    Mikael Kleinwort avatar
    78 posts
    Registered:
    17 May 2004
    21 Feb 2009
    Link to this post
    After upgrading from 3.5 to 3.6, I get a build error in VS2008:

    VS2008 Build error 105: unknown server tag sfBlogDesignSettings:BehaviorSetting.
    C:\Program Files\Telerik\Sitefinity3.5\WebSites\MyWebSite\Sitefinity\Admin\ControlTemplates\Blogs\Design\BlogPostsControlDesigner.ascx 242 

    What can I do?

    Thanks, Mikael
  2. Mikael Kleinwort
    Mikael Kleinwort avatar
    78 posts
    Registered:
    17 May 2004
    21 Feb 2009
    Link to this post
    Happens also with 3.6 Hotfix applied.
  3. Pepi
    Pepi avatar
    981 posts
    Registered:
    28 Oct 2016
    23 Feb 2009
    Link to this post
    Hi Mikael Kleinwort,

    Please, open the following file:

    ~/Sitefinity/Admin/ControlTemplates/Blogs/Design/BlogPostsControlDesigner.ascx

    Then, change sfBlogDesignSettings:BehaviorSetting to sfBlogDesignSettings:BlogsBehaviorSetting.

    Do let us know if this helps.

    Regards,
    Pepi
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  4. Mikael Kleinwort
    Mikael Kleinwort avatar
    78 posts
    Registered:
    17 May 2004
    26 Feb 2009
    Link to this post
    Hello Pepi,

    yes this works. After fixing this, now during the buikd process I have 2 new errors, caused by "ratingControl.ascx":

    "File or assembly AjaxControlToolkit not found", and
    "unknown servertag ajaxToolkit:Rating"

    Any ideas?

    regards, Mikael
  5. Pepi
    Pepi avatar
    981 posts
    Registered:
    28 Oct 2016
    27 Feb 2009
    Link to this post
    Hi Mikael Kleinwort,

    It seems you have a control using the AjaxControlToolkit. So, please make sure you have a reference to the AjaxControlToolkit.dll assembly in the ~/bin folder of the web site (note that AjaxControlToolkit assembly is not currently distributed with Sitefinity).

    Best wishes,
    Pepi
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  6. Mikael Kleinwort
    Mikael Kleinwort avatar
    78 posts
    Registered:
    17 May 2004
    27 Feb 2009
    Link to this post
    Hello Pepi,

    the reported error happened after an upgrade from SF 3.5 to SF 3.6. I suspected that it might be an upgrade issue. So I just uninstalled all of SItefinity and did a new clean install of SF 3.6, vreated a new project and restored the project specific files.

    Now all the compile errors have disappeared.

    Regards, Mikael
  7. Sonya
    Sonya avatar
    231 posts
    Registered:
    24 Sep 2012
    02 Mar 2009
    Link to this post
    Hi Mikael Kleinwort,

    Thank you for letting us know you are not experiencing any problems after a clean installation of Sitefinity 3.6. The issues you had in the beginning were due to some changes we had to make for the new version, including removing the AjaxControlToolkit.dll assembly.

    Let us know if you need further assistance.

    Kind regards,
    Sonya
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
Register for webinar
7 posts, 0 answered