+1-888-365-2779
Try Now
More in this section

Forums / Set-up & Installation / User Profile Page - Null Exception

User Profile Page - Null Exception

2 posts, 1 answered
  1. Fernando
    Fernando avatar
    31 posts
    Registered:
    08 Jun 2009
    09 Feb 2011
    Link to this post
    Hi,

    I'm having a problem when I try to view the user profile (CMS -> Administration -> Users -> then clicking 'profile' for any user). When I do this I receive the following error:


    Server Error in '/' Application.

    Object reference not set to an instance of an object.

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.NullReferenceException: Object reference not set to an instance of an object.

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Stack Trace:

    [NullReferenceException: Object reference not set to an instance of an object.]
       Telerik.Security.WebControls.ManageProfile.SetTemplateControls() +1301
       Telerik.Security.WebControls.ManageProfile.CreateEditView() +188
       System.Web.UI.Control.EnsureChildControls() +145
       System.Web.UI.Control.PreRenderRecursiveInternal() +60
       System.Web.UI.Control.PreRenderRecursiveInternal() +223
       System.Web.UI.Control.PreRenderRecursiveInternal() +223
       System.Web.UI.Control.PreRenderRecursiveInternal() +223
       System.Web.UI.Control.PreRenderRecursiveInternal() +223
       System.Web.UI.Control.PreRenderRecursiveInternal() +223
       System.Web.UI.Control.PreRenderRecursiveInternal() +223
       System.Web.UI.Control.PreRenderRecursiveInternal() +223
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +3393
    


    Version Information: Microsoft .NET Framework Version:2.0.50727.4206; ASP.NET Version:2.0.50727.4209



    This seems to be the only problem in the site. We have installed the SP3 for this project, but I'm not sure if this problem started after upgrading to SP3.
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    09 Feb 2011
    Link to this post
    Hi Fernando,

    The issue was fixed in Sitefinity 3.7 SP4. Please check our release notes here.

    All the best,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
    Answered
2 posts, 1 answered