+1-888-365-2779
Try Now
More in this section

Forums / Set-up & Installation / v3 SP1 upgrade error

v3 SP1 upgrade error

7 posts, 0 answered
  1. mexner
    mexner avatar
    98 posts
    Registered:
    06 Apr 2006
    28 Jun 2007
    Link to this post
    Hello,

    Just upgraded to SP1, and am getting an error after I copy the BIN and SITEFINITY folders to my proj.

    "The resource object with key 'ProjectName' was not found."

    1Line 44:     <form id="form1" runat="server"
    2Line 45:     <div id="loginBox"
    3Line 46:         <h1><span>Site Finity |</span><strong id="projectName" runat="server"><asp:Literal runat="server" Text="<%$Resources:ProjectName %>"></asp:Literal></strong></h1> 
    4Line 47:         <h2><asp:Literal runat="server" Text="<%$Resources:Login %>"></asp:Literal></h2
    5Line 48:         <asp:Login ID="Login1" runat="server" DestinationPageUrl="Admin/Default.aspx"
    6 
    7 
    8Source File: /sitefinity/login.aspx    Line: 46 
    9 
    10Version Information: Microsoft .NET Framework Version:2.0.50727.42; ASP.NET Version:2.0.50727.210 

    what do I do?  Thanks for all your help!
    Chris

  2. mexner
    mexner avatar
    98 posts
    Registered:
    06 Apr 2006
    28 Jun 2007
    Link to this post
    In attempt to keep working while I wait to hear back from you guys, I rolled back my BIN and SF folders.  I had backed up those folders before overwritting them with SP1.

    Now, when I log in, all my pages are gone!  Argghh...the interface works smoothly and shows all my templates, but the pages I've created are gone.

    I know my DB conn is good, I was able to log in.

    Please let me know what  I need to do.  I have a looming deadline over my head.  As always, thank you for all your help!

    Chris,


  3. Bob
    Bob avatar
    330 posts
    Registered:
    24 Sep 2012
    28 Jun 2007
    Link to this post
    Hello CHRIS,

    You need to rollback the database as well. Usually the database is also upgraded.

    Please check if the following file exists:
    ~/Sitefinity/App_LocalResources/Login.aspx.resx and if there is an entry with key ProjectName.

    If this is missing, then something went wrong while replacing the Sitefinity folder with the new version.

    Greetings,
    Bob
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  4. mexner
    mexner avatar
    98 posts
    Registered:
    06 Apr 2006
    28 Jun 2007
    Link to this post
    Bob, 

    In my default install directory, ProjectManager\EmptyProject\Sitefinity,
    I do not have a App_LocalResources folder.

    Here are the files and folders I do have....
    Admin
    Common
    ControlTemplates
    AccessDenied.aspx
    cmsentrypoint.aspx
    cmsstartup.aspx
    default.aspx
    default.aspx.cs
    login.aspx
    login.aspx.cs
    web.config

    Hmm....
  5. mexner
    mexner avatar
    98 posts
    Registered:
    06 Apr 2006
    28 Jun 2007
    Link to this post
    Bob, I just re-downloaded SP1 on a 'clean' computer and installed from scratch.  The Sitefinity folder now has a App_LocalResources folder.

    I'm uploading the bin and sitefinity folders to my live site....i'll keep you posted.

    thanks,
  6. mexner
    mexner avatar
    98 posts
    Registered:
    06 Apr 2006
    28 Jun 2007
    Link to this post
    Bob, Ok, that appears to have worked.

    I was hoping SP1 would fix my 'style sheet switcher' problem posted here.

    Thanks for your help, any ideas about the other post?

    Thanks again.
  7. Bob
    Bob avatar
    330 posts
    Registered:
    24 Sep 2012
    28 Jun 2007
    Link to this post
    Hi Chris,

    I’m glad you managed to fix your problem. Unfortunately, the new installation does not always remove all old files and I guess that caused your problem. We need to improve the installation and upgrade process and this will be one of the main emphases for the next release.

    I will answer you last question in a little while in the other thread.

    All the best,
    Bob
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
Register for webinar
7 posts, 0 answered