+1-888-365-2779
Try Now
More in this section

Forums / Set-up & Installation / Web.Config Lauch Issue in mix mode

Web.Config Lauch Issue in mix mode

7 posts, 0 answered
  1. An Vuong
    An Vuong avatar
    3 posts
    Registered:
    30 Sep 2009
    30 Sep 2009
    Link to this post
    I have siteinfinity is my primary website in asp.net 3.5. I also has older application in Asp.net 1.1. When I configure the older application 1.1 to run as vitual directory. It keep read root web.config file which it in 3.5 version. I try to use inheritInChildApplications attribute in the parent website but it doesn't work. Any help asap is appreciated.

    Thank you in advance.
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    01 Oct 2009
    Link to this post
    Hi An Vuong,

    First make sure that you have added the location element in the right place. In collections, configuration settings are typically added to the collection via an add child element, removed by key name via a remove child element, or the entire collection can be cleared via a clear child element. An added setting in a child configuration file overrides a setting of the same key name in a parent configuration file unless duplicates are allowed. You can take a look at the following articles at MSDN - ASP.NET Configuration File Hierarchy and Inheritance and General Attributes Inherited by Section Elements

    Also it will be good if you could have both the applications using the same .NET Framework version.

    Regards,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  3. An Vuong
    An Vuong avatar
    3 posts
    Registered:
    30 Sep 2009
    01 Oct 2009
    Link to this post
    It doesn't work.
    I have the following configuration in the root (top level)  asp.net 3.5 version.
    <location inheritInChildApplications="false">
        <
    system.web>
        </system.web>
     </location>

     I also have following configuration in the virtual directory level asp.net 1.1
    <configuration>
        <configSections>
            <clear/>
        </configSections>
    </configuration>
    Still doesn't work. I think location is only cover system.web section only not the configSections. Can you post code and location for me.

    Thank you.
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    05 Oct 2009
    Link to this post
    Hi An Vuong,

    SectionGroup is correctly declared ( more information at sectionGroup Element for configSections (General Settings Schema. The issue you are experiencing is mainly related to not correct version of the ASP.NET framework for the application in IIS( example - version 1 instead of 2.0).

    As suggested before try to compile both the applications in the same .NET Framework version( "Also it will be good if you could have both the applications using the same .NET Framework version.")

    Sincerely yours,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  5. An Vuong
    An Vuong avatar
    3 posts
    Registered:
    30 Sep 2009
    05 Oct 2009
    Link to this post
    That is what I am trying to avoid. Is there a way around it? What if someone has alot of asp.net 1.1 applications and if they are having a new website in 3.5; it will take time to convert which it people trying to avoid. Is there away we can configure them?

    Thank you
  6. Crusader
    Crusader avatar
    12 posts
    Registered:
    28 Oct 2009
    19 Feb 2010
    Link to this post
    Hi An Vuong.
    I have similar problem. Try to use such tags construction.
    <location path="." inheritInChildApplications="false">
         <system.web>
         ....
         </system.web>
    </location
    Your application in subdirectory will use it's own web.config file.

    Regards,
    Crusader.
  7. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    19 Feb 2010
    Link to this post
    Hello Crusader, An Vuong,

    You should also consider clearing providers in child application before declaring the ones specific to it (connection strings too):
    <localization defaultProvider="Sitefinity" persistenceMode="PathPrefix" defaultCulture="en" cultures="en, es, fr, de, bg">
        <providers>
            <clear/>
            <add name="Sitefinity" type="Telerik.Localization.Data.DefaultProvider, Telerik.Localization.Data" connectionStringName="DefaultConnection"/>
        </providers>
    </localization>

     This can be done for all functionality which uses provider model.

    Sincerely yours,
    Radoslav Georgiev
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
Register for webinar
7 posts, 0 answered