+1-888-365-2779
Try Now
More in this section

Forums / Sitefinity SDK / Cannot install SDK - Windows Installer Issue

Cannot install SDK - Windows Installer Issue

6 posts, 0 answered
  1. Chris
    Chris avatar
    49 posts
    Registered:
    20 Jul 2010
    27 Aug 2010
    Link to this post
    When I attempt to run the Sitefinity_SDK_4_0_beta.msi It takes an unusually long time to "prepair for install" then after about 5-8 minutes I get a small window which reads:

    This installation package cannot be installed by the Windows Installer service. You must install a Windoes service pack that contains a newer version of the Windows Installer service.

    I've ran windows update and made sure all things are up to date. I've tried running the msi on mutiple machines aswell.
     I was able to run the regular Sitefinity_4_0_beta.exe just fine but this SDK msi never runs.

    What am I missing?
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    29 Aug 2010
    Link to this post
    Hi Chris,

    Which version of Windows you use and which SP you have installed. We are not able to reproduce issues locally on Windows 7 and Vista.

    Regards,
    Ivan Dimitrov
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  3. Chris
    Chris avatar
    49 posts
    Registered:
    20 Jul 2010
    30 Aug 2010
    Link to this post
    Hi, thanks for the reply. I'm using Windows Server 2003 Standard Edition with Service Pack 2.
  4. Chris
    Chris avatar
    49 posts
    Registered:
    20 Jul 2010
    31 Aug 2010
    Link to this post
    Hi, has there been any development yet on what I should do in order to be able to install the SDK?
  5. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    03 Sep 2010
    Link to this post
    Hi Chris,

    Thank you for getting back to us.

    We have tested the installation package of the Sitefinity 4.0 SDK before the release, we have also tested this after you have reported your issue, still unable to reproduce it. We have tested on Windows Server 2008 SP2 with Windows Installer version 4.5.6001.22159 as in attached image. You can check the version of the installer runtime by running msiexec.exe.

    Best wishes,
    Radoslav Georgiev
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  6. Chris
    Chris avatar
    49 posts
    Registered:
    20 Jul 2010
    07 Sep 2010
    Link to this post
    Thanks it did turn out to be a problem with my version of windows installer. I guess the installer isn't something that get updated automatically with windows update as I had to goto microsofts site and download the latests installer manually.
6 posts, 0 answered