+1-888-365-2779
Try Now
More in this section

Forums / Sitefinity SDK / Custom module without the Title field issues

Custom module without the Title field issues

2 posts, 0 answered
  1. Duneel
    Duneel avatar
    166 posts
    Registered:
    08 Dec 2010
    22 Feb 2011
    Link to this post
    Hi Ivan/Radoslav,

    I've created a custom module based on the product sample module provided with the official release. The module was created without the TITLE and CONTENT fields unlike the products module. I successfully registered the module in my SF4 website. When I go to create a new content item in the new module it takes me to the create new dialog which shows correctly all the fields I need (without the Title and Content fields). I published the changes after typing the new values for the item and then an ajax error occurs, once that happenes the content list page no longer loads/accessible. I have uploaded my module project to sendspace.com and I really appriciate if you could take a look at it and let me know what is really wrong in that. I've spent several hours today trying to figureout the issue but I couldnt. I'm in a tight schedule with a project and great if you can tell me by Wednesday moroning (EST).

    The module source code can be downloaded at: http://www.sendspace.com/file/6t923w

    EDIT: Attached the Javascript error i'm receiving.

    Thanks and awaiting a quick response.

    Duneel
  2. Duneel
    Duneel avatar
    166 posts
    Registered:
    08 Dec 2010
    23 Feb 2011
    Link to this post
    ANSWER:

    No worries guys. I found the issue and fixed. It was an error in the backend grid view which is showling the item list. I had some extra quotations in the ClientTemplate value of the first column (='' after UIStatus.toLowerCase).

    ClientTemplate =

     

    @"<a sys:href='javascript:void(0);' sys:class=""{{ 'sf_binderCommand_edit sfItemTitle sf' + UIStatus.toLowerCase=''()}}"">

    <strong>{{Title}}</strong>

    <span class='sfStatusLocation'>{{Status}}</span></a>"

     



2 posts, 0 answered