+1-888-365-2779
Try Now
More in this section

Forums / Suggestions / Insert image dialog needs some work

Insert image dialog needs some work

8 posts, 0 answered
  1. Michael
    Michael avatar
    8 posts
    Registered:
    06 May 2004
    08 Feb 2011
    Link to this post
    The insert image dialog only shows thumbnails that are cropped, which makes it difficult when you have several images that are similar and no way to tell the difference. Also, there are no image names displayed either below the thumbnail or as an alt text display. This also makes it difficult to distinguish between similar images. An alternate "list or grid" view of the images would be helpful also as the thumbnail view can be difficult to navigate especially if you have many images in an album.

    The Insert Image button is hidden at first because the thumbnails view pushes it down below the bottom of the dialog so you have to scroll down everytime to click the "Insert ..." button, which is a pain.
  2. Antoaneta
    Antoaneta avatar
    258 posts
    Registered:
    02 Nov 2015
    09 Feb 2011
    Link to this post
    Hello Michael Sumption,

    Thank you for your comments and suggestions.

    We planned a set of improvements in the Image Widget for Q1 and we hope all the issues you decribed will be fixed as soon as possible.

    Regards,
    Antoaneta
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    09 Feb 2011
    Link to this post
    I hope the ability to pick filesystem images in the dialog will be there too?
  4. Antoaneta
    Antoaneta avatar
    258 posts
    Registered:
    02 Nov 2015
    10 Feb 2011
    Link to this post
    Hi Steve,

    images stored in the filesystem will not be visible in the Image dialog, you will still need to upload them first into a library.

    This feature will be included in our plans for Q2.

    Kind regards,
    Antoaneta
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    10 Feb 2011
    Link to this post
    Oh common, really?...

    It took so long for us to get FS integration into 3.x, now we're back to everything living in the DB

    My host gives me signifigantly more space on the filesystem than the DB

    If it has to wait that long, at least then let us pick either FS\Library images in the Image control AND the GC add image toolbar please :/
  6. Michael
    Michael avatar
    8 posts
    Registered:
    06 May 2004
    10 Feb 2011
    Link to this post
    I tried referencing an image from the FS in a content block like this ~/images/image.png and it worked in Firefox, but not in IE. But then I also noticed that Sitefinity was replacing the path (automatically) with something like this /MyAppName/images/image.png. It was very strange and I couldn't get it to consistently work in both IE and FF, so I just started uploading images - oh well.
  7. Kalina
    Kalina avatar
    176 posts
    Registered:
    27 Oct 2016
    14 Feb 2011
    Link to this post
    Hi Steve,
    We are planning a set of improvements in the Image Widget in Q1.  We added your request for ability to select from the file system in the list as well (ID 107944).

    Michael,
    The bug you reported is logged in our bug tracking system (ID 107946). We are planning to have a solution within a week

    Greetings,
    Kalina
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  8. Lyubomir Dokov
    Lyubomir Dokov avatar
    43 posts
    Registered:
    01 Nov 2016
    22 Feb 2011
    Link to this post

    Hello Michael,

    I tried to reproduce the problem you described with referencing an image from file system from within a Content Block. It worked fine for me. What I did:

    1. Go to Administration->Files.
    2. Create a folder "images" in the root folder.
    3. Upload an image "tulips.jpg".
    4. Go to Pages and create a new page.
    5. Inserte a Content Block and click "Enter content" to edit its properties.
    6. In the Edit dialog switch to HTML and insert an <img src="~/images/tulips.jpg" /> tag. (screenshot attached)
    7. Save the Edit dialog - the image appears in the page editor.
    8. Publish the page. Then "View" from the Pages grid - the image also appears fine in the frontend.

    Is this what you are doing? If not, please provide us with exact steps or a video so that we can reproduce the problem. I tested with Firefox and IE - both worked fine.

    Note: the "src" attribute really gets replaced with an absolute path of the image, based on the virtual path of your application. This is normal, since the browser does not understand application-relative paths, e.g. paths starting with "~/".



    Best wishes,
    Lyubomir Dokov
    the Telerik team
8 posts, 0 answered