+1-888-365-2779
Try Now
More in this section

Forums / Thunder / Can't connect to Sitefinity instance on network

Can't connect to Sitefinity instance on network

7 posts, 0 answered
  1. Chris
    Chris avatar
    9 posts
    Registered:
    08 Aug 2011
    19 Apr 2012
    Link to this post
    We are using Thunder 1.0.7.0 with a Sitefinity 5.0 site that we migrated from Sitefinity 3.7SP4. We can connect Thunder to the local instance without any problems (and it is a nice tool :)) but we can't connect to another Sitefinity instance on the same network. Apart from the location of the files and database, the sites are identical.

    The "Test connection" button indicates that connection was successful, but when trying to refresh the Sitefinity explorer, the progress bar reaches 99% and stalls forever at "Initializing connection Sitename."

    The site is accessible in every way we can see, and the installed Sitefinity Thunder module is up-to-date. Are there any common problems that can cause this? Thunder makes things much nicer to work with, so we are looking forward to getting it working for us.

    Thank you,
    Chris
  2. Dimitar Dimitrov
    Dimitar Dimitrov avatar
    35 posts
    Registered:
    02 Dec 2016
    20 Apr 2012
    Link to this post
    Hello Chris,

    Would you please open the Sitefinity Explorer under Telerik menu - Sitefinity Thunder and check if your Sitefinity project needs upgrade ( instead of the Themes and Widget Templates, there will be a message indicating that you need an update of your project). If there is an update install it and test again.

    Greetings,
    Dimitar Dimitrov
    the Sitefinity team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Chris
    Chris avatar
    9 posts
    Registered:
    08 Aug 2011
    20 Apr 2012
    Link to this post
    The Sitefinity Explorer is entirely blank; it never finishes initializing the connection to the site, even though "Test connection" indicates that the connection was successful.

    As I mentioned, the site is a 1:1 mirror of a local site, which is running the latest version of the Thunder module. I can connect to the local copy, but not to the other copy, which is on another computer on the same network.

    Additionally, even locally, the only context menu item on themes is "Add Frontend Theme" - isn't there supposed to be a download theme option? It's mentioned in the documentation  http://www.sitefinity.com/documentation/gettingstarted/connecting-to-sitefinity-using-thunder 

    Thank you,
    Chris
  4. Dimitar Dimitrov
    Dimitar Dimitrov avatar
    35 posts
    Registered:
    02 Dec 2016
    20 Apr 2012
    Link to this post
    Hi Chris,

    I am attaching you a picture showing you the download button, it opens when you click with right button on a Theme.

    What are the rights that your user has to the remote Sitefinity project?
    In your Sitefinity explorer all you see is the Themes and Widget templates nodes and nothing underneath them?



    All the best,
    Dimitar Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Chris
    Chris avatar
    9 posts
    Registered:
    08 Aug 2011
    20 Apr 2012
    Link to this post
    Hello,

    There is no right-click menu at all when I right-click a theme. Everything shows up for the user, though. We are logging in as the administrator that created the site. I reiterate that this is not working for a local site - the Sitefinity explorer is completely empty for the remote site, and it is populated, but not usable, for local sites. We are encountering the same problem on every workstation here (blank explorer on other sites on the network, no popup menus for local sites.)

    Thank you,
    Chris
  6. Chris
    Chris avatar
    9 posts
    Registered:
    08 Aug 2011
    30 Apr 2012
    Link to this post
    Hi,

    After upgrading to Sitefinity Thunder 1.0.8.0, it now completely crashes Visual Studio instead of hanging.

    Could this be an issue with the migration from 3.7 to 5.0? The 5.0 site has been upgraded to SP1 and the latest Thunder module installed.

    Thank you,
    Chris
  7. Dimitar Dimitrov
    Dimitar Dimitrov avatar
    35 posts
    Registered:
    02 Dec 2016
    02 May 2012
    Link to this post
    Hi Chris,

    It is a really strange case, would you please provide us with the information from your Visual Studio: Help - About Visual Studio - Copy Info and System Info. It would be great if you can make a simple video showing how the visual studio crashes and also send us your project and database to check it locally.

    Sorry for the inconvenience.

    Greetings,
    Dimitar Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
7 posts, 0 answered