+1-888-365-2779
Try Now
More in this section

Forums / Upcoming Features / Sitefinity 6.2 Beta 2 Announced

Sitefinity 6.2 Beta 2 Announced

30 posts, 0 answered
  1. Kali
    Kali avatar
    158 posts
    Registered:
    25 Feb 2009
    09 Oct 2013
    Link to this post

    Dear all,

    This is to let you know that Sitefinity 6.2 Beta 2 is available for download on this link.

    In addition to many improvements since the last Beta, this release includes reworked Comments which enable users to comment on Pages, Dynamic Modules, Images, Videos, and basically everything in Sitefinity.

    A brief overview of the Comments’ improvements:
    --- Users can manage Comments in a new dedicated section under Content
    --- Comments are included in the Frontend Widgets of these modules:
        Dynamic Modules (created with Module Builder)
        Images, Videos, Documents
        Lists
    --- Users can enable page comments by dropping a Comments widget to the page
    --- Administrators can set comments preferences (default and per content type) in Advanced Settings> Comments Module

    Known Issues:
    --- Permissions per Comments and Content Type are not supported yet
    --- After upgrade, no comments are shown in the old version of the frontend widgets (news, blogs, etc.).Workaround: Drop the new version of the frontend widgets (news, blogs, etc.) on the place of the old.

    Upgrade instructions can be seen in this post.

    We need your help with testing upgrades! Please upgrade your projects and check if all comments are transferred properly in the backend, together with the corresponding comments settings.

    Your feedback and comments:) are welcome!

    -The Sitefinity Team

  2. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    09 Oct 2013
    Link to this post
    WOOOOHOOOO!!!!!

    DEEP LINKING TO ADVANCED SETTINGS!!!!!

    ...I mean the deepness only goes one level (afaik), but still :)
  3. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    09 Oct 2013
    Link to this post
    6.2 Beta 2 notes:
    - Comment Widget
        - I find it odd that we're rendering out the name\email fields, then hiding them with javascript...how about we just don't render them if they are not needed.  Who's enabling them on the client side?  Same deal with the captcha markup...why is it there if it's not used??  The name\email fields espeically because when the widget loads all 3 inputs are visible, then 2 pop away and the 3rd becomes the kendo editor.
        - Like that the submit is on a rest call and fast
        - How to I configure the kendo editor\tools?
        - Put multiple comments on a page (default, one with "title" set, one with "content type" set).  http://screencast.com/t/EowLTsH3pEN5
            - ...I have no idea which comment is from where, and where's the Custom Title I'm supposed to see in the backend
            - Could you make the submit button a more common class so if we drop this on a page it uses the style we've likely already defined?  Like the more common syntax of sfSubmitButton, or k-button or something?...maybe"sfSubmitButton sfcommentsSubmitBtn"?
    - Submit template doesn't seem to exist in the widget templates backend...I see it in the designer, but when I click edit it shows as being part of "Login" (new project not upgrade)
    - Enable the captcha on a type, then log out...visit the comments page...click the editor.  The name\email box weirdly pop in http://screencast.com/t/h0twJ9RDqg


        - Designer:
            - Advanced
               - Labels don't make a lot of sense...I'm not clear what either do?
                   -Suggest:
                      1) Custom Content Type or ID (with example text below the input)
                      2) Title (With example text below the input)
            - Typo (copy\paste) on the submit template label?  Not sure why "view" is in there.
            
            
    - Comment Backend
        - Can you please give me better aggregate\filters?  It has no way to show custom stuff at all.  We're needing this to be on a type that's not sitefinity defined, but a custom control.  So there's no way to filter those out in here with this UI....or is this the "Commentable types" in the backend settings?  Not aggregate, but hardcoded?
        - Batch operations please, pain to kill multiple items
  4. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    10 Oct 2013
    Link to this post
    Sorry to post here but http://www.sitefinity.com/developer-network/forums/sitefinity-preview/internal-builds/sitefinity-6.2-beta-announced was already locked.

    Look at this screencast www.marktold.com/screencast/sf_dashboard_stats_layout.swf

    1) clicking on stats icon produces error
      a) this might be another start from manager problem like the one with dashboard not beeing loaded first
    b) your argument that if Analytics is not configured and will take you to setup does not make sense to me because if Analytics is not set up every single user who clicks on the icons will be taken to setup but might not have a clue about what to do, or even not have the right for administration.

    I can not test this since its not taking me to admin. But how about adding a user without admin rights and see what happens if he clicks on the icon link. Taken to admin where he has no rights?

    So why not simply hide when not set-up like its hidden if the modul is deactivated.

    Markus


    PS: could you send me an SBE license to mb @ marktold.com so I can do some stripped down testing. Often you seem to test with Enterprise and SBE is not going trough the same amount of testing.


  5. Stoimen
    Stoimen avatar
    12 posts
    Registered:
    08 May 2013
    10 Oct 2013 in reply to Markus
    Link to this post
    Hi Markus,

    In the first beta we didn't have those links working. Could you try the new beta version that Kali has uploaded to this thread. The whole experience should be much better now.

    Stoimen
  6. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    10 Oct 2013 in reply to Stoimen
    Link to this post
    Did dozens of updates but from beta 1 to beta 2 I forgot to build :-)

    - Asked me for new license
    - Front worded
    - Backend -> DashboardConfig.config was still version 6.1.4733.0 giving me an error on backend load

    ould not load file or assembly 'Telerik.Sitefinity, Version=6.1.4733.0, Culture=neutral, PublicKeyToken=b28c218413bdf563' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

    After Rebuild in VS 2010 instad of Build I get

    Could not load file or assembly 'Telerik.Sitefinity.Services.Comments, Version=6.2.4821.0, Culture=neutral, PublicKeyToken=b28c218413bdf563' or one of its dependencies. Das System kann die angegebene Datei nicht finden.

    copied the .dll over from empty projects

    back to  

    Could not load file or assembly 'Telerik.Sitefinity, Version=6.1.4733.0, Culture=neutral, PublicKeyToken=b28c218413bdf563' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

    SystemConfig.config has some references to 6.1.4733.0

    <add title="SalesForce Connector" type="Telerik.Sitefinity.SalesForceConnector.SalesForceConnectorModule, Telerik.Sitefinity.SalesForceConnector, Version=6.1.4733.0, Culture=neutral, PublicKeyToken=b28c218413bdf563" startupType="Disabled" name="SalesForceConnector" />
            <add errorMessage="You are trying to access item that no longer exists. The most probable reason is that it has been deleted by another user." name="Comments" />
            <add moduleId="00000000-0000-0000-0000-000000000000" startupType="OnFirstCall" version="6.2.4821.0" name="DashboardModule" />

    as well as the dashboardConfig.config

    <dashboardConfig xmlns:config="urn:telerik:sitefinity:configuration" xmlns:type="urn:telerik:sitefinity:configuration:type" config:version="6.1.4733.0" usedWorkflowStatuses="Published,Unpublished,Draft,Scheduled,AwaitingApproval,AwaitingPublishing,Rejected,RejectedForPublishing,Locked," />


    Don't know how I messed it up or how I could fix it no time - will start new beta 2 project.
    Markus
  7. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    10 Oct 2013 in reply to Markus
    Link to this post
    How about finaly removing this 

    again: 
    90% probably fresh installations
    95% of all editors of 3.x sites have no business with migrating.

    I though I had  a post somewhere from telerik were you state that this will finaly be removed.

  8. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    10 Oct 2013 in reply to Stoimen
    Link to this post
    I guess you take any bug feedback for 6.2 :-)

    a) the bug seems to be fixed were you could not pick thumb size and/or fullscreen size in gallery when you selected a nested library

    b) BUT -> it seems that if you select an library which has nested libraries -> ALL images get displayed

    c) back to my complaining about analytics link when not set up -> see screencast

    www.marktold.com/screencast/sf_beta2_feedback_1.swf

    Kind Regards
    Markus
  9. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    10 Oct 2013 in reply to Markus
    Link to this post
    When I click on an image in a gallery I get the image twice for commenting also in big format -> unexpected behavoir to me

    www.marktold.com/screencast/sf_image_gallery_comment.swf
    www.marktold.com/screencast/sf_image_gallery_comment_2.swf


    Markus
  10. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    10 Oct 2013 in reply to Markus
    Link to this post
    While of course appreciating new features - it realy would be nice if the bugs know to Telerik would be taken into consideration to be fixed.

    For example sorting images with nested libraries still not possible or understandable for endusers.

    www.marktold.com/screencast/image_reorder_still_not_fixed.swf

    Markus
  11. Jochem Bökkers
    Jochem Bökkers avatar
    787 posts
    Registered:
    13 Aug 2007
    10 Oct 2013
    Link to this post
    With inline editing turned on the following gets loaded:
    1. Telerik.Sitefinity.Resources.Scripts.jquery-1.8.3.min.js
    2. Telerik.Sitefinity.Resources.Scripts.jquery.cookie.js
    3. Telerik.Sitefinity.Resources.Scripts.Kendo.kendo.all.min.js
    4. Telerik.Sitefinity.Resources.Scripts.jquery.ba-outside-events.min.js
    5. Telerik.Sitefinity.Resources.Scripts.RequireJS.require.js
    6. Telerik.Sitefinity.Resources.Scripts.JSON2.js
    7. Telerik.Sitefinity.Web.UI.PublicControls.InlineEditing.Scripts.InlineEditingManager.js

    Can we update & optimize this ?

    1. Sitefinity still has jQuery 1.8.3 while KendoUI 2013 Q2 expects jQuery 1.9.1 minimum.

    2. Minified?

    3A. Currently Kendo UI Beta v2013.2.716 is included, can we update that to release?
    3B. Do we need Kendo.all.min,js can't we just load Kendo.web.min.js ?

    4. Isn't listed/exportable in Sitefinity.Resources yet.

    5. Also not exportable and is using the non-minified/heavy commented dev version (83Kb vs 15Kb)

    6. Minified.

    7. Minified.

    ---
    While all these are wrapped in a webresource.axd they still pull down 1.2Mb while minified & optimized it would be about 760Kb.
    ---

    Perhaps a silly question, but why are we loading jquery, kendo and requireJS 'the old way' and not have requireJS take care of the Kendo & jQuery loading as well?

    Now I have to wait for 1.3 Mb extra to be downloaded until the page is ready while on initial page-load I'm not even using any of the extra inline-editing bits, after all it's not until I click on 'edit-content' before Kendo and the rest of the magic needs to kick in.
  12. Jochem Bökkers
    Jochem Bökkers avatar
    787 posts
    Registered:
    13 Aug 2007
    10 Oct 2013
    Link to this post
    Inline-editing and/or regular editing doesn't lock a page/content-block, allowing me to edit the same content block on the same page through the backend and inline-editing.

    Shouldn't either one be locked? Just as it would be if we tried to edit the same page through the backend twice?
  13. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    10 Oct 2013 in reply to Jochem Bökkers
    Link to this post
    Not sure if you talk abou this when you say permissions not working.

    But when I set in backend that comments must be approved I exepct them to be needed to be approved before showing

    www.marktold.com/screencast/permissions_not_working.swf

    Might be my bad

    1) if you are on content module and click on settings you are taken to basic comment module setting

    but

    If you go directly to admin - settings you will not see comments module in basic. I just read from top to bottom and took the first comments entry. and thats what you see in the screencast.

    www.marktold.com/screencast/comments_approval_where_what.swf


    Like smtp settings - this is hard to know when does which setting take effect

    Comments - authentication
    Coments Module Default - authentication
    Comments Module images - authentification

    Which does what where and overrule?

    Markus

    PS: Soon I need more serverspace for all those screencasts :-)


  14. Jochem Bökkers
    Jochem Bökkers avatar
    787 posts
    Registered:
    13 Aug 2007
    10 Oct 2013
    Link to this post
    The new dashboard has the following class:

    .sfDashboardWidgetWrp{
     position:relative;padding:15px 20px;
     background-color:#fff;
     border:1px solid #e4e4e4;
     max-width:750px;
     min-height:360px
    }

    This max-width property causes the 50% blocks to look 'weird' on desktops > 1680px, when removed no harm is done and 50% will actually look 50% again...

    ---

    Speaking of large desktops, why can't we instead of a two column layout, simply do 4 column 'responsive' layout? 

    Assuming the previous 'max-width' should have been a min-width instead, you could apply the default translations like you're using for the repsonsive front-end.

    @media only screen and (max-width : 1680px){
        body { min-width: 0 !important; }
        .sfPublicWrapper { width: auto !important; }
        .sf_colsOut.sf_4cols_1_25,
        .sf_colsOut.sf_4cols_2_25,
        .sf_colsOut.sf_4cols_3_25,
        .sf_colsOut.sf_4cols_4_25 {
        width: 50% !important;
        }
        .sf_colsOut.sf_4cols_3_25 {
        clear: left;
        }
        .sf_colsOut.sf_4cols_3_25 .sf_colsIn {
        margin-left: 0 !important;
        margin-right: 0 !important;
    }

    I know we should make it usable for everyone and 'responsive' might 'upset' a few users who're still using IE8 to edit their website, but on a large screen this can't be what Telerik wants for a new shiny dashboard...
  15. R. Atanasov
    R. Atanasov avatar
    3 posts
    Registered:
    29 Jan 2013
    10 Oct 2013 in reply to Markus
    Link to this post
    Markus said:
    as well as the dashboardConfig.config

    <dashboardConfig xmlns:config="urn:telerik:sitefinity:configuration" xmlns:type="urn:telerik:sitefinity:configuration:type" config:version="6.1.4733.0" usedWorkflowStatuses="Published,Unpublished,Draft,Scheduled,AwaitingApproval,AwaitingPublishing,Rejected,RejectedForPublishing,Locked," />

    Markus


    Sorry Markus, this was a breaking change between beta 1 and beta 2. We improved the way the usedWorkflowStatuses property is kept - from a comma separated string to a real ConfigElementList . It should be safe to delete the property before upgrade (the default value now includes all common statuses).
  16. R. Atanasov
    R. Atanasov avatar
    3 posts
    Registered:
    29 Jan 2013
    10 Oct 2013 in reply to Steve
    Link to this post
    Steve said:WOOOOHOOOO!!!!!

    DEEP LINKING TO ADVANCED SETTINGS!!!!!

    ...I mean the deepness only goes one level (afaik), but still :)


    This is actually there for a very long time, but as you noticed it's not really deep, and I guess this is the reason it hasn't been advertised.
  17. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    10 Oct 2013 in reply to Jochem Bökkers
    Link to this post
    Dear Jochem

    While it might does not harm I have other priorities

    In english the buttons to add / edit new translations have text add / edit -> nice an short.

    Now in any other language the texts are longer so as of 3 languages you get double the hight on rows. I rather have telerik work on that then on the dashboard responsive.

    I guess its hard to explain but screencast shows this (besides me not understanding when which language is realy used/displayed in the backend :-(

    www.marktold.com/screencast/language_creazyness.swf

    Markus
  18. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    10 Oct 2013 in reply to Markus
    Link to this post
    @Telerik

    Don't expect any more beta testing from me! 

    Markus
  19. Jochem Bökkers
    Jochem Bökkers avatar
    787 posts
    Registered:
    13 Aug 2007
    10 Oct 2013 in reply to Markus
    Link to this post
    @Markus,

    You're totally right - bug fixing should always be a priority.

    But I'm pretty sure the 'dashboard' while be a highly marketed new feature, so while it's still not released, there's still a chance to improve the first thing people see when they login to the backend...
    And while I may be OCD - it's the thing that caught my eye.

    Jochem
  20. Georgi
    Georgi avatar
    7 posts
    Registered:
    11 Feb 2013
    10 Oct 2013 in reply to Jochem Bökkers
    Link to this post
    Hi Jochem,

    Thanks for your remarks about the Inline editing. Please find our comments bellow:

    1. There are some breaking changes in jQuery 1.9 which need to be handled on our side and we will need to invest more time. That’s why we are still using jQuery 1.8.3.

    3a. Kendo UI v2013.2.716 is the official 2013 Q2 version. There is a mistake in the generated comments: http://www.kendoui.com/forums/kendo-ui-framework/general-discussions/q2%2713-release---beta-source-code-comments.aspx

    3b. Thanks for the note. kendo.web.min.js will be used in the official version.

    4. I’m not quite sure what exactly you mean. Could you please clarify?

    5. Minified version will be used in the official version.

    2, 6, 7 – These files are small ones, loaded only in the inline editing mode. We will minified them in the next version.

    About page locking the behavior should be the same as in the backend. If the page is locked by someone else you should not be able to edit it through the Inline editing and vice versa if you are  editing a content block on a page it should appear locked in the backend. You are allowed to edit a page in the backend and Inline editing mode at the same time with the same user, the same way that you are allowed to edit a page in multiple tabs.

    Regards,
    Georgi Dimitrov

  21. Jochem Bökkers
    Jochem Bökkers avatar
    787 posts
    Registered:
    13 Aug 2007
    10 Oct 2013 in reply to Georgi
    Link to this post
    Hey Georgi,

    Thanks for getting back. 

    1. Ok... I can understand the breaking changing with jQuery 1.9 vs 1.83, but how about Kendo and it's minimum requirement of 1.9.1? Is this basically 'non-implied' and off-the-record saying Kendo might break?

    3A. My official release version says "Kendo UI Complete v2013.2.918" installed from Telerik Control panel and just re-downloaded from the website to not be a fool.

    4. I used JustDecompile, it didn't show up in the resources, or I needed more coffee.

    ---
    Would be great if we could standardize on somename.js being 'debug' and somename.min.js being 'production' instead of the mix-match even if it's just a few kb's - just ask around size matters ;) 

    ---
    Ok so one browser logged in as 'admin' on the backend. One (anonymous) browser logged in as 'jochem' - still I can simultaneously edit the same content block as two different users.




     
  22. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    10 Oct 2013 in reply to Jochem Bökkers
    Link to this post
    Can we just remove KendoAll from the source, or have some sort of build alert that someone used it?  There's never going to be a case where a web frontend widget needs KendoMobile loaded.

    I would also love it if there was one sitefinity embedded kendo css theme to use.  We have both metro and default embedded.  I noticed that on a new project with the basic theme I get the kendo default.css loaded (about 66k on the axd), if I drop on a comments widget it's loading in the metro.css and I'm now at 156k (with everything)...(or visa versa on the files).  The NICE thing though is I can change it in the widget templates, HOWEVER...I would need to do that on every project.  If instead there was only just "Telerik.Sitefinity.Resources.Scripts.Kendo.styles.kendo_metro_min.css" or "Telerik.Sitefinity.Resources.Scripts.Kendo.styles.kendo_sitefinity_min.css" ...no issue.

    This may sound selfish, but I just want to save myself some time needing to look for these things on every alpha\beta.
  23. Jochem Bökkers
    Jochem Bökkers avatar
    787 posts
    Registered:
    13 Aug 2007
    10 Oct 2013 in reply to Steve
    Link to this post
    @Steve +1 on the sitefinity theme.

    And it's actually the current implementation is even a bit weirder:
    Anonymous browsing with a comment block you get: default.
    Browsing comment block+inline editing turned on: default+metro.
    Browsing empty page+inline you get: metro.
  24. Georgi
    Georgi avatar
    7 posts
    Registered:
    11 Feb 2013
    11 Oct 2013 in reply to Jochem Bökkers
    Link to this post
    Hi Jochem,

    1.We didn’t find any problems so far. It is too late to upgrade jQuery version for this release. We will consider an upgrade for the next one.
    3A. Kendo UI v2013.2.918 is Q2 SP1 version, we are using the previous one which is 2013.2.716
    4. I found the files in Telerik.Sitefinity.Resources dll with JustDecompile: http://screencast.com/t/9QMFBmbzs0AA

    About items locking I tested it again and it seems to work fine. Please see the video: http://screencast.com/t/eo8GKNPrD. Could you please provide steps how you reproduce this issue.

    Regards,
    Georgi Dimitrov
  25. Georgi
    Georgi avatar
    7 posts
    Registered:
    11 Feb 2013
    11 Oct 2013 in reply to Jochem Bökkers
    Link to this post
    Hi Steve and Jochem,

    About Kendo themes, we removed default theme from the frontend and replace it with metro. So we have only one theme loaded on the frontend. The default theme is still used in the backend we will replace it for the next release.

    Regards,
    Georgi Dimitrov
  26. Jochem Bökkers
    Jochem Bökkers avatar
    787 posts
    Registered:
    13 Aug 2007
    11 Oct 2013 in reply to Georgi
    Link to this post
    Hey Georgi,

    Thanks for getting back. I must have been lacking caffeine that I didn't see it in Telerik.Sitefinity.Resources.dll sorry.

    Regarding the simultaneous edit, the problem comes from the 'exit editing'.
    - Go edit a page in the backend.
    - Open a new browser/different user and click on inline editing.
    - You get the message everything is locked.
    - Click on exit-editing.
    - (Imagine you grab a coffee before trying again).
    - Click on inline-editing.
    - Now the content isn't locked anymore and you can freely edit.

    https://dl.dropboxusercontent.com/u/19007909/sitefinity/sfv624821-sitefinity-simuledit.mp4

    As you see in the video, it starts of with 'inline editing' taking over, and ends up with both being able to publish the page without warnings/errors... 
  27. Georgi
    Georgi avatar
    7 posts
    Registered:
    11 Feb 2013
    15 Oct 2013 in reply to Jochem Bökkers
    Link to this post
    Hi Jochem,

    Thanks for detailed information. The issue is fixed for the release.

    Regards,
    Georgi Dimitrov
  28. Kali
    Kali avatar
    158 posts
    Registered:
    25 Feb 2009
    15 Oct 2013
    Link to this post
    Hi Steve, sorry for the late response, we were busy with the release. Replies are below with >>>>- Comment Widget
        - I find it odd that we're rendering out the name\email fields, then hiding them with javascript...how about we just don't render them if they are not needed.  Who's enabling them on the client side?  Same deal with the captcha markup...why is it there if it's not used??  The name\email fields espeically because when the widget loads all 3 inputs are visible, then 2 pop away and the 3rd becomes the kendo editor.
    >>>> Everything is rendered and then there is a service call to deduce what should be hidden. We decided to take this approach so output cache can be used with authenticated and anonymous users without rendering different versions on the server.    
    - Like that the submit is on a rest call and fast
        - How to I configure the kendo editor\tools?
    >>> This was logged as feature request for next releases.
        - Put multiple comments on a page (default, one with "title" set, one with "content type" set).  http://screencast.com/t/EowLTsH3pEN5
            - ...I have no idea which comment is from where, and where's the Custom Title I'm supposed to see in the backend
    >>> Comments posted through the Comments widget are logged for Pages. So, when you don't specify a Content Type, this is the default one. There is usability  problem currently which we will try to solve with a more user friendly designer. Until then advanced settings will be hidden from Comments widget. We will provide instructions on how to post comments for custom content types via code.
            - Could you make the submit button a more common class so if we drop this on a page it uses the style we've likely already defined?  Like the more common syntax of sfSubmitButton, or k-button or something?...maybe"sfSubmitButton sfcommentsSubmitBtn"?
    >>>> The template is editable through the CommentsWidget designer and you can associate custom css classes when needed.
    - Submit template doesn't seem to exist in the widget templates backend...I see it in the designer, but when I click edit it shows as being part of "Login" (new project not upgrade)
    >>>>This issue is logged for fixing in the next release.
    - Enable the captcha on a type, then log out...visit the comments page...click the editor.  The name\email box weirdly pop in http://screencast.com/t/h0twJ9RDqg
    >>>>Email and author name fields appear on focus of the message field. (by design)

        - Designer:
            - Advanced
               - Labels don't make a lot of sense...I'm not clear what either do?
                   -Suggest:
                      1) Custom Content Type or ID (with example text below the input)
                      2) Title (With example text below the input)
            - Typo (copy\paste) on the submit template label?  Not sure why "view" is in there.
            >>> This section will be hidden as it results in confusion and misuse. We will provide examples to achieve comments for custom content type via with code.
           
    - Comment Backend
        - Can you please give me better aggregate\filters?  It has no way to show custom stuff at all.  We're needing this to be on a type that's not sitefinity defined, but a custom control.  So there's no way to filter those out in here with this UI....or is this the "Commentable types" in the backend settings?  Not aggregate, but hardcoded?
    >>> When you can add new Commentable types in Advanced Settings, automatic filers for them will show in Comments Backend>Right side menu .
        - Batch operations please, pain to kill multiple items
    >>> Will be included in the next release.

    Thanks again for the extensive feedback. And looking forward to getting more from you on the coming release later this week.
    Regards,
    Kalina
  29. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    15 Oct 2013 in reply to Kali
    Link to this post
    1) Okay, why "by design" do email\name show up on focus ONLY when capcha is enabled...on which site have you seen this as common\desired functionality?  It's just weird
    2) If you're dead-set on rendering out all elements, can you at LEAST put style="display:none" on the elements, then SHOW the needed ones on the service callback?...instead of the user seeing everything then things disappear, they'd only see the required elements appear.
  30. Tihomir
    Tihomir avatar
    10 posts
    Registered:
    04 Jul 2013
    16 Oct 2013 in reply to Steve
    Link to this post
    Hi Steve,

    I agree that the behavior of the email\name fields is a bit weird. I will discuss it with the UX team and I believe that we will find a better solution. I also agree that it makes sense to put style="display:none" on the elements, so we will try to address this issue as soon as possible.

    Thank you for your valuable feedback.

    Kind Regards,
    Tihomir
30 posts, 0 answered