+1-888-365-2779
Try Now
More in this section

Forums / Upcoming Features / Sitefinity 6.2 Internal Build Available for Download

Sitefinity 6.2 Internal Build Available for Download

34 posts, 3 answered
  1. Kali
    Kali avatar
    158 posts
    Registered:
    25 Feb 2009
    17 Sep 2013
    Link to this post
    Hi all,

    Internal preview of Sitefinity 6.2 is available for download on this link.
    *** Update: added alternative download link from dropbox to address cases with problematic download.

    This build contains major improvement in Page editing and publishing performance in the backend. We are kindly asking for your assistance in testing projects upgrades.

    More on what we did

    We focused on optimizing the number of database operations when opening for edit and publishing a page. The achieved results are great, decreasing in some cases the number of DB inserts/deletes more than 10 times. This ultimately leads to very improved speed, including the case when multiple users work simultaneously in the pages backend.
    To achieve this we did a lot of refactoring and improvements in the page publishing code and the pages persistent model. Also, on the 6.2 upgrade we are executing a clean-up procedure which additionally optimizes the storage of pages – and in some cases removes up to 80% of the stored data – which was used inefficiently.

    How you can help 

    Even though we performed very comprehensive testing of real-world projects for possible regressions and upgrade problems, it will be of a great help if you can help us at this stage and do some test upgrades with this 6.2 alpha release.
    We want to make sure we are not missing some specific for you project and you have a flawless experience once you decide to upgrade to the official 6.2.

    Please, focus on the following problems:

    1)    After the upgrade passes please check UpgradeTrace. Log for any Fail messages
    2)    After the upgrade passes please check Error. Log for any Fail messages
    3)    Please check that your pages look ok – the widgets are there , are not misplaced or broken
    4)    Please check that you can open, edit and publish successfully a single page
    5)    If you find something out of order – please reply to this forum thread – also we might contact you to get more details or your project and test locally.

    Important Note: Please note that this build is for review purposes
    only. Upgrades from it to next versions will not be supported.


    We look forward to receiving any feedback you might have.
    Thanks in advance for your assistance!

    Regards,
    Sitefinity Team
  2. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    17 Sep 2013
    Link to this post
    Busted link, still uploading, or permissions?
  3. Mark
    Mark avatar
    147 posts
    Registered:
    01 Jun 2010
    17 Sep 2013
    Link to this post
    Gets to 50mb and breaks. The 6.1 SP2 download link is also broken, only downloads 8mb.
    Answered
  4. Kali
    Kali avatar
    158 posts
    Registered:
    25 Feb 2009
    17 Sep 2013
    Link to this post
    Steve and Mark,
    I uploaded a new file and updated the download link. Please let me know if the problem persists. Could be the case as I am not sure what caused the problem to start with.

    Kalina
    Answered
  5. Randy
    Randy avatar
    7 posts
    Registered:
    07 Nov 2012
    17 Sep 2013
    Link to this post
    Would this help with an issue that we've always had where we cannot go into backend pages on sitefinity or publish pages during our peak traffic times.  It causes our site to crash.  We think it had to do with it causing the app pool to recycle while we have numerous live connections pulling market data.  THis happened even when just working with content blocks before puiblishing.
  6. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    17 Sep 2013
    Link to this post
    Where should we be registering problems, or should I just send you the project?
  7. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    17 Sep 2013
    Link to this post
    okay so for me eComm update failed, but I got it re-registered, needed some assembly bindings and things

    But WOW page publishing appears fast now....like so fast I can't even see the loading icon.

    Just blinks quick then i'm navigating back to /Pages

    (Sidenote: could you show in light grey the Full Path the page on that pages dash widget)...I think you do the same on a Page search.  Some of the names I'm seeing are just too generic to know where they are located.
  8. Mark
    Mark avatar
    147 posts
    Registered:
    01 Jun 2010
    17 Sep 2013
    Link to this post
    WebAPI as blogged here breaks because a route for "defaultapi" has been declared by sitefinity somewhere in this release. Changing the name fixes it, but there might be a significant amount of people with this now.

    http://www.sitefinity.com/blogs/patrick-dunn-s-blog/2013/08/15/developing-javascript-widgets-for-sitefinity-cms-building-the-web-api

  9. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    17 Sep 2013 in reply to Mark
    Link to this post
    @Mark
      It seems webapi is being used for the inline editing?

    Anyway @Kali...I have a weird one where my inline editing rest call 404s, so I can't activate it.
  10. Sean
    Sean avatar
    271 posts
    Registered:
    31 May 2006
    17 Sep 2013 in reply to Kali
    Link to this post
    Hi Kali,

    I can't download at all, I only receive a 500 server error.

    Thanks

    ---
    Edit, all working for now me now...
  11. Kali
    Kali avatar
    158 posts
    Registered:
    25 Feb 2009
    18 Sep 2013
    Link to this post
    Hi all, and thanks for the quick follow-up.

    @Randy - the new release should solve this case. It would be of great help if you could upgrade your project and let us know if you encounter any issues.

    @Steve - you can report the problems here so that others can see them as well. As to the project, please, send it over email.
    eEcommerce upgrade problem will be investigated.
    "could you show in light grey the Full Path the page on that pages dash widget"  - I am not quite sure what you mean. Please, elaborate.
    For the inline editing rest calls 404, we are using service stack services, and the following portion should be added to the webconfig:
      <!-- SERVICE STACK-->
      <location path="Sitefinity/Restservices">
        <system.web>
          <httpHandlers>
            <add path="*" type="ServiceStack.WebHost.Endpoints.ServiceStackHttpHandlerFactory, ServiceStack" verb="*"/>
          </httpHandlers>
        </system.web>
        <!--Required for IIS7-->
        <system.webServer>
          <modules runAllManagedModulesForAllRequests="true"/>
          <validation validateIntegratedModeConfiguration="false" />
          <handlers>
            <remove name="ServiceStack.Factory" />
            <add path="*" name="ServiceStack.Factory" type="ServiceStack.WebHost.Endpoints.ServiceStackHttpHandlerFactory, ServiceStack" verb="*" preCondition="integratedMode" resourceType="Unspecified" allowPathInfo="true" />
          </handlers>
        </system.webServer>
      </location>
      <!-- END SERVICE STACK-->

    @Mark - we will investigate the porblem with WebAPI and follow-up if we need more info .

    Thanks again for your valuable feedback!
    Kalina
  12. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    18 Sep 2013 in reply to Kali
    Link to this post
    @Kalina
    Answered
  13. Kali
    Kali avatar
    158 posts
    Registered:
    25 Feb 2009
    18 Sep 2013
    Link to this post
    @ Mark,
    We tested the example from this blog post and it works properly. Can you send a project on which the error can be reproduced to this email: kalina.maneva@telerik.com? We would like to investigate the specific problem you face. For Inline editing we use Service stack and not WebAPI. Adding the portion above to webconfig will enable the feature.

    @Steve, thanks for the screenshot. This is available in Pages Backend when sorting by date or alphabetically. Where else do you want to see it, what do you mean by "page dash widget"?

    Thanks again,
    Kalina
  14. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    18 Sep 2013 in reply to Kali
    Link to this post
    @Kalina
      The only widget on the dash right now shows what...recent content?  In the site I migrated we have a few pages which have similar names (like "Browse" or "Detail"), it'd be nice to get just a bit more detail on those...
  15. Kali
    Kali avatar
    158 posts
    Registered:
    25 Feb 2009
    18 Sep 2013
    Link to this post
    Thanks, Steve, I didn't realize you meant dashboard by dash. it's clear now!
  16. Mark
    Mark avatar
    147 posts
    Registered:
    01 Jun 2010
    18 Sep 2013
    Link to this post
    Kali, email sent with a link to the project. For anyone else that runs into the issue, the only thing that needs to be done for the WebAPI sample from Patrick to work is to rename DefaultApi in Global.asax to anything else, ex: MyProjectApi.

    Just curious, why was ServiceStack chosen over WebAPI?
  17. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    18 Sep 2013 in reply to Mark
    Link to this post
    @Mark
    I was wondering the same thing, WebAPI is the fancy new guy on the block...but real world perf tests...I mean...clearly it's a better choice

    https://github.com/ServiceStack/ServiceStack/wiki/Real-world-performance
  18. Daniel Plomp
    Daniel Plomp avatar
    952 posts
    Registered:
    18 Feb 2004
    19 Sep 2013 in reply to Kali
    Link to this post
    Probably this is a known issue, but I'll mention it anyways:
    When clicking on Analytics I'm getting this error:

    There was an error:
    {"readyState":4,"responseXML":{"location":null},"responseText":"<html>\r\n    <head>\r\n        <title>Not Found</title>\r\n        <style>\r\n        \tbody {font-family:\"Verdana\";font-weight:normal;font-size: 8pt;color:black;} \r\n        \tp {font-family:\"Verdana\";font-weight:normal;color:black;margin-top: -5px}\r\n        \tb {font-family:\"Verdana\";font-weight:bold;color:black;margin-top: -5px}\r\n        \th1 { font-family:\"Verdana\";font-weight:normal;font-size:18pt;color:red }\r\n        \th2 { font-family:\"Verdana\";font-weight:normal;font-size:14pt;color:maroon }\r\n        \tpre {font-family:\"Lucida Console\";font-size: 8pt}\r\n        \t.marker {font-weight: bold; color: black;text-decoration: none;}\r\n        \t.version {color: gray;}\r\n        \t.error {margin-bottom: 10px;}\r\n        \t.expandable { text-decoration:underline; font-weight:bold; color:navy; cursor:hand; }\r\n        </style>\r\n    </head>\r\n    <body bgcolor=\"white\">\r\n\r\n            <span><h1>Server Error in '/test' Application.<hr width=100% size=1 color=silver></h1>\r\n\r\n            <h2> <i>HTTP Error 404 - Not Found.</i> </h2></span>\r\n\r\n            <hr width=100% size=1 color=silver>\r\n\r\n            <b>Version Information:</b> Telerik Web Server 6.1.4683.0\r\n\r\n            </font>\r\n\r\n    </body>\r\n</html>\r\n","status":404,"statusText":"Not Found"}

    -Daniel
  19. Kali
    Kali avatar
    158 posts
    Registered:
    25 Feb 2009
    19 Sep 2013
    Link to this post
    Hi Daniel,
    Thanks for reporting this! It is a known issues which was not fixed since for this build as we were in a hurry to release the page optimizations.
    This will be fixed.
    Kalina
  20. Jochem Bökkers
    Jochem Bökkers avatar
    787 posts
    Registered:
    13 Aug 2007
    23 Sep 2013
    Link to this post
    Hey Kali,

    I've upgraded a 6.1.4300 project and error/trace.log didn't flinch. However on first view of the website the following error was logged several times:

    Type : System.Reflection.ReflectionTypeLoadException, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
    Message : Unable to load one or more of the requested types. Retrieve the LoaderExceptions property for more information.
    Source : mscorlib
    Help link :
    Types : System.RuntimeType[]
    LoaderExceptions : System.Exception[]
    Data : System.Collections.ListDictionaryInternal
    TargetSite : System.RuntimeType[] GetTypes(System.Reflection.RuntimeModule)
    HResult : -2146232830
    Stack Trace :    at System.Reflection.RuntimeModule.GetTypes(RuntimeModule module)
       at System.Reflection.RuntimeModule.GetTypes()
       at System.Reflection.Assembly.GetTypes()
       at Telerik.Sitefinity.Mvc.Store.ControllerScanner.GetControllers()
       at Telerik.Sitefinity.Mvc.Store.ControllerScanner.ScanControllers()
       at Telerik.Sitefinity.Mvc.MvcCore.EnableMvcSupport()
       at Telerik.Sitefinity.Services.SystemManager.Initialize()

    This was on default home/footer & right-side-bar templates.

    Jochem
  21. Kali
    Kali avatar
    158 posts
    Registered:
    25 Feb 2009
    23 Sep 2013
    Link to this post
    Hi Jochem,
    The error below is caused by custom assemblies added to bin which refer to the previous version.
    To resolve it you need to recompile the assemblies or add bindingRedirect to the new version in the web.config file.
    Let me know if that doesn't solve the problem or you encounter other problems. We look forward to receiving more feedback!
    Regards,
    Kalina

  22. Jochem Bökkers
    Jochem Bökkers avatar
    787 posts
    Registered:
    13 Aug 2007
    23 Sep 2013 in reply to Kali
    Link to this post
    Hi Kali,

    Been there - done that :)
    And the errors only appear first time a 'default' template is viewed publicly.

    Jochem.
  23. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    23 Sep 2013
    Link to this post
    @Kali
    Inline editing Feedback:
    - Exit editing popup box should disappear if I click anywhere else on the page
    - How do I edit the available tools, these defaults will generate severely ugly content (font, colors, etc)
    - Html popup window is WAYYYY too small, shouldn't see scrollbars on the window.
    - Yellow background on Show\Hide statuses looks just terrible, and needs cursor:pointer applied to it.
    - Edit\Exit content link needs cursor:pointer, not clear it's clickable
    - Why bother with a popout if the only option is to enable\disable editing? ...I think a logout button there is a bit overkill.  Most sites will have their own login\logout buttons in the template.
    - Instead of 7 HiddenField controls (in "sfInlineEditingPageMenu") for properties, why not go html5 and just do data-* attributes on the link...way less markup....more clean\modern.
    - Rename the script functions\global vars to something less generic than "openUpdateWindow" and $popup?...conflicts and such.


    - (see video) I find it odd that I need to click the content twice to get the editor to showup
    - (see video) Watch when I try to select and apply an h1...it's getting a bit "RadEditor"-ness markup mangling going on.
    Video: http://screencast.com/t/9s9dUouv2u

    - Can we get the ability to configure if the "stauts" is shown by default?
    - Select image from uploaded UI is terrible on a bunch of levels
    - Edited content block, clicked out, chose "Save as draft", label still said Published, had to reload the page to get it to show Draft (newer than published)
    - Might be conflicting styling, but the publish\draft buttons have no margin below them (see attached)
    - I feel like when I'm clicking to edit a block and it's highlighed...if I click out it should remove the highlighting and let me edit something else - http://screencast.com/t/tjk04zHkB
    - "sfInlineEditingPageMenu" needs to override render, it's wrapping itself with an empty div.
    - You could squeek out a bit more performance by not initalizing the 2 kendo windows on page load...load on demand and cache the loaded object.
    - Somehow now stuck in perma-object ref unable to edit mode....no feedback to the user that it's borked aside from the loading icon, I'd like something better so the user doesn't tell me "It doesn't work, just blinks".
      http://www.screencast.com/t/F508Md8YVS

    Notes:
    - /Sitefinity/Administration/Settings/Advanced "Requirejs Modules"?  Are we now using requirejs? :)  I see it in the header...is this just for inline editing or are we moving this way instead of resourcelinks?
    - Functionality is defiantly WAY nicer than the previous revision...WAYYY nicer.
  24. Kali
    Kali avatar
    158 posts
    Registered:
    25 Feb 2009
    24 Sep 2013
    Link to this post
    Hi Steve, and thanks for the extensive review! My comments are with >>> below:

    - Exit editing popup box should disappear if I click anywhere else on the page
    >>> Will be fixed.  

    - How do I edit the available tools
    >>> Such option will be included in the next Service Pack.

    - Html popup window is WAYYYY too small, shouldn't see scrollbars on the window.
    >>> Will be fixed.

    - Yellow background on Show\Hide statuses looks just terrible, and needs cursor:pointer applied to it.
    >>> This message was there for testing purposes only. Will be restyled.  

    - Edit\Exit content link needs cursor:pointer, not clear it's clickable
    >>> Fixed already. Will be included in the beta release coming later this week.

    - Why bother with a popout if the only option is to enable\disable editing? ...I think a logout button there is a bit overkill.  Most sites will have their own login\logout buttons in the template.
    >>> We have plans to add more options/features there over time.

     - Instead of 7 HiddenField controls (in "sfInlineEditingPageMenu") for properties, why not go html5 and just do data-* attributes on the link...way less markup....more clean\modern.
    >>>We’ll see what can be done about this.

    - Rename the script functions\global vars to something less generic than "openUpdateWindow" and $popup?...conflicts and such.
    >>>Our functions are wrapped in requirejs modules. Which functions/global vars do you mean?

    - (see video) I find it odd that I need to click the content twice to get the editor to showup
    >>> Fixed already.

    - (see video) Watch when I try to select and apply an h1...it's getting a bit "RadEditor"-ness markup mangling going on.
    Video: http://screencast.com/t/9s9dUouv2u
    >>> Submitted request to Kendo team.
    They explained that when you change the styles using block tags, the change is applied to the whole block/paragraph. If you apply styles using inline tags, these are be applied to the selection of text only. The workaround in this case is to hit enter after the text, and apply style to it after that.  Please let me know if that makes sense.

    - Can we get the ability to configure if the "stauts" is shown by default?
    >>> Status indicator will be displayed for Drafts and Locked items only . This will give indicator to the user that he is working with content which is not published on the site or that content is locked. Switching off/on of statuses is there for test purposes only. What do you expect to be the default state?

    - Select image from uploaded UI is terrible on a bunch of levels
    >>> Work in progress. Will be polished in the beta build coming later this week.  

    - Edited content block, clicked out, chose "Save as draft", label still said Published, had to reload the page to get it to show Draft (newer than published)
    >>> Will be fixed.

    - Might be conflicting styling, but the publish\draft buttons have no margin below them (see attached)
    >>> We couldn’t reproduce this problem. Can you please submit a project which we can review?

    - I feel like when I'm clicking to edit a block and it's highlighed...if I click out it should remove the highlighting and let me edit something else - http://screencast.com/t/tjk04zHkB
    >>> Will be fixed.


    - "sfInlineEditingPageMenu" needs to override render, it's wrapping itself with an empty div.
    >>> Will be fixed.

    - You could squeek out a bit more performance by not initalizing the 2 kendo windows on page load...load on demand and cache the loaded object.
    >>> We’ll see what can be done about this.

    - Somehow now stuck in perma-object ref unable to edit mode....no feedback to the user that it's borked aside from the loading icon, I'd like something better so the user doesn't tell me "It doesn't work, just blinks".
      http://www.screencast.com/t/F508Md8YVS
    >>> Will be fixed. Global error handling displaying exception message is implemented.

    Notes:
    - /Sitefinity/Administration/Settings/Advanced "Requirejs Modules"?  Are we now using requirejs? :)  I see it in the header...is this just for inline editing or are we moving this way instead of resourcelinks?
    >>> We are using requirejs for the Inline editing and new Dashboard. We use it for the new features in order to modularizing our client side code and make it more reusable.

    - Functionality is defiantly WAY nicer than the previous revision...WAYYY nicer.
    >>> Thanks for the kind words. And thanks for taking the time to write such an extensive review.
    We’ll make sure most requests are implemented for the release.

    Regards,
    Kalina


  25. Jochem Bökkers
    Jochem Bökkers avatar
    787 posts
    Registered:
    13 Aug 2007
    24 Sep 2013 in reply to Kali
    Link to this post
    @Kali,

    Perhaps off topic but Is it to late to suggest jspm.io instead of RequireJS ?

    I love requireJS, it works great and does what it supposed to do in a fabulous way but jspm seems more tailored to the needs of websites vs web apps and future friendly.

    Its supports not only AMD but also CommonJS and already offers support for ES6's Javascript Modules. So we can use our RequireJS style notation as we're familiar with if we want but can also look ahead.

    Aside from JS modules it also offers support for CSS, Images, JSON and webfonts and offers better CDN and versioning support so probably easier to avoid conflicts when we're messing with RadControls, Kendo and Sitefinity...

    Aside from that, If we are going forward with RequireJS and Kendo will it be module based and not simply load the kendo.all.min.js as it does now?

    p.s.
    I'm late with uploading the project, apologies - you'll have it tonight.

    Jochem
  26. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    24 Sep 2013 in reply to Kali
    Link to this post
    Thanks Kali :)

    - Rename the script functions\global vars to something less generic than "openUpdateWindow" and $popup?...conflicts and such.
    >>>Our functions are wrapped in requirejs modules. Which functions/global vars do you mean?
    *** In edit more there's a function inserted into the page called "openUpdateWindow" with kendo window code in it, and a global variable called $popup in the same method.  The names are just too crazy generic, especially openUpdateWindow. 


    >>> Submitted request to Kendo team.

    They explained that when you change the styles using block tags, the
    change is applied to the whole block/paragraph. If you apply styles
    using inline tags, these are be applied to the selection of text only.
    The workaround in this case is to hit enter after the text, and apply
    style to it after that.  Please let me know if that makes sense.
    *** Makes sense, but you're (well I guess us developers) gonna have to explain that to everyone having that experience.  IMO if I'm selecting some text I only want that text wrapped.

    - Can we get the ability to configure if the "stauts" is shown by default?

    >>> Status indicator will be displayed for Drafts and Locked
    items only . This will give indicator to the user that he is working
    with content which is not published on the site or that content is
    locked. Switching off/on of statuses is there for test purposes only.
    What do you expect to be the default state?
    *** I would want to see them by default, right now it's hard to know when I'm in edit mode

    - Might be conflicting styling, but the publish\draft buttons have no margin below them (see attached)
    >>> We couldn’t reproduce this problem. Can you please submit a project which we can review?
    **** JUST saw this on the partner webinar as well, they were using quantum (attached)

    *** Error messages are nice, but I'm more concerned that I was able to take a page that was editable into a state where every ajax call crashed :)


    Thanks for looking into these things for us, I really like that we can give feedback before release.  Instead of "Here's what you get" then we have to wait months or years for the feature to be touched again for tweaks.



  27. Daniel Plomp
    Daniel Plomp avatar
    952 posts
    Registered:
    18 Feb 2004
    24 Sep 2013 in reply to Jochem Bökkers
    Link to this post
    @Jochem: jspm.io, that is a nice one. I would opt for a mechanism like that also!
    As far as I know Kendo is already AMD?

    -Daniel
  28. Jochem Bökkers
    Jochem Bökkers avatar
    787 posts
    Registered:
    13 Aug 2007
    24 Sep 2013 in reply to Daniel Plomp
    Link to this post
    @Daniel, looks more promising that requireJS no?

    Especially with the already added new Javascript Modules support that'll soon become the standard it would be great to look ahead and not jump through the similar hoops and struggles which we've had with jQuery support.

    Yes kendo is, but a quick peak at the current beta shows they're just 'loading' the full .all.min.js async instead of taking proper advantage of its dependencies.
  29. Kali
    Kali avatar
    158 posts
    Registered:
    25 Feb 2009
    25 Sep 2013
    Link to this post
    Hi Jochem and Daniel,
    And thanks for the suggestion! I have logged a  task to evaluate the proposed option after the release.
    -Kalina
  30. Jochem Bökkers
    Jochem Bökkers avatar
    787 posts
    Registered:
    13 Aug 2007
    25 Sep 2013
    Link to this post
    @Kali,

    With the project I've send earlier - after upgrade and editing the web.config to include service stack, I'm able to inline-edit a summary and title on a default bloglist template.

    However when I view the blogpost in detail view and choose in-line edit, the url changes, I see the top bar with the options but nothing is selectable/editable.

    Is this a current limitation of having the template set to 'auto-generate detail page' ?

    Jochem
34 posts, 3 answered
1 2