More in this section
Categories
Bloggers
Blogs RSS feed

Support for .NET 4.7 Coming to Sitefinity 11

by Peter Filipov

Today the Sitefinity assemblies are built against .NET framework 4.5. However, Microsoft no longer provides security updates, technical support or hotfixes for it. Because of this we decided to upgrade to the latest .NET framework and technology trends and move to .NET 4.7.

Sitefinity 11.0, which is coming this spring, will bring full support for .NET 4.7.1. This change will help us improve our productivity and resolve many bugs faster thanks to the new features that come with C# 7. In addition, three big features of the framework are worth mentioning - support for .NET Standard 2.0, security improvements and the improved performance of garbage collection. Following the latest trends, we want to make sure that Sitefinity developers have everything they need to code more productively.

How does this affect my work as a developer or IT administrator?

The 4.7.1 version of the .NET framework doesn’t come with each Windows/Windows Server machine and you should install it. This is an expected implication 🙂, since this is the newest .NET framework. In this comparison table you can find more information about which Windows versions support it. Keep in mind that in addition to the development environment, the server on which your Sitefinity application is deployed should also have the framework installed.

We’re excited about all the new features and upgrades we’ll be bringing you with Sitefinity 11.0, including this update to the latest version of the .NET framework. But this is not all, the UX in the admin area will be reimagined. To get a better idea, check at least the screenshots from this post.  

We hope this notice gives you plenty of time to prepare yourself until you upgrade to Sitefinity 11.0 or start coding new projects on it.

Are you interested? Let's get started!

Schedule a Demo    Start a trial

5 comments

Leave a comment
  1. Mark Terry Apr 23, 2018
    Whats the ETA for v11? Very much looking forward!
  2. ben May 27, 2018
    im unable to install .net error while  installing https://lenovosupport.net/
  3. ben May 27, 2018
    <a href="https://lenovosupport.net">lenovo support</a>    im unable to install .net error while  installing
  4. SitefinitySteve May 31, 2018
    Yeah but what about .NET core?
  5. Peter Jun 04, 2018

    Hi Steve,

    We are currently doing internal researches about it and what are the prerequisites this to happen. We don't have a specific timeline for it, once we know more details will let the community know.

    Peter

    Leave a comment