More in this section

Forums / Bugs & Issues / 4.1 SP1 - meta "noindex" tab inserted even though pages set to index

4.1 SP1 - meta "noindex" tab inserted even though pages set to index

20 posts, 0 answered
  1. Phill Hodgkinson
    Phill Hodgkinson avatar
    362 posts
    Registered:
    10 Nov 2004
    13 May 2011
    Link to this post
    Hi there,

    This seems to be a new bug in 4.1 SP1 and a huge show stopper at that! In my 4.1 (and 4.1 w/ hotfix) my pages based on my .master files (I only have pages based on master files) have the checkbox "Allow search engines to index this page" checked. I've unchecked, published, checked and republished and yet if I look at the source code of my pages they all have "<meta name="robots" content="noindex" />" inserted into the header.  I looked at the table sf_page_data and Crawlable is set to true for all pages.

    Can someone confirm this bug? It's a serious one! I was hoping to go live with a site today now that SP1 is out but I can't go live if the site isn't going to be indexed by search engines!!!!

    Thanks!
    Phill

    p.s. I will need a hotfix for this, not another 1 month wait for the next SP!!
  2. Phill Hodgkinson
    Phill Hodgkinson avatar
    362 posts
    Registered:
    10 Nov 2004
    13 May 2011
    Link to this post
    Small update that may help narrow down this bug. The unwanted meta tag doesn't get inserted into my home page. If I take a problem page, make it my home page the tag is no longer inserted and it's now added to my original home page. So the setting seems to work on the page that's set as home page but not on any other pages.

    Would love a response on this from Telerik before you all leave for the day!

    Thanks,
    Phill
  3. Phill Hodgkinson
    Phill Hodgkinson avatar
    362 posts
    Registered:
    10 Nov 2004
    13 May 2011
    Link to this post
    Ugly Fix... for anyone who may also have this issue here's my temp fix so that until Telerik fixes this your pages will still be indexed by site crawlers (assuming I'm not the only one having this issue).

    I've added the following code to each of my custom .master pages.
    protected void Page_Load(object sender, EventArgs e)
    {
        // ToDo temp fix to prevent noindex meta tag
        foreach (Control hm1 in Page.Header.Controls)
        {
            if (hm1 is HtmlMeta && (((HtmlMeta)hm1).Name.ToLower() == "robots"))
            {
                Page.Header.Controls.Remove(hm1);
            }
        }
    }

    I can't tell you how sick and angry it makes me to have to add hacks like this to a $2000 CMS!! Especially when this bug wasn't here in 4.0 or 4.1!

    Regards,
    Phill
  4. Phill Hodgkinson
    Phill Hodgkinson avatar
    362 posts
    Registered:
    10 Nov 2004
    16 May 2011
    Link to this post
    I just got a response from Support Ticket and this is indeed a known bug. So if you want to have your site running 4.1 SP1 and also have your site content indexed by the search engines you're out of luck. You can add the hack I created but not sure if that's the best solution, if anyone else has a better suggestion I'd love to hear it. At current rate we probably won't see a fix for this for another couple months.

    If you think having your site indexed by search engines is important, please visit PITS and vote for this issue to be fixed: http://www.telerik.com/support/pits.aspx#/public/sitefinity/6009

    Cheers,
    Phill
  5. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    16 May 2011
    Link to this post
    Hello Phill Hodgkinson,

    Unfortunately it's a regression that we didn't cover :/. 
    We will try to fix it for this week's internal build, or next one at last.

    Thanks for sharing the workaround with the others - we appreciate it.

    Greetings,
    Georgi
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  6. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    16 May 2011
    Link to this post
    Hello Phill,

    Update: We fixed it today, the solution will be available this Friday.

    Kind regards,
    Georgi
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  7. Phill Hodgkinson
    Phill Hodgkinson avatar
    362 posts
    Registered:
    10 Nov 2004
    16 May 2011
    Link to this post
    Will it be available as an official supported release that can be used in production or just another unsupported (useless) internal release? This is important because if it's supported and I can roll out to production sites I'll allocate time, but if not I'll leave my hack in and wait until official release.

    Regards,
    Phill
  8. Ed Hardy
    Ed Hardy avatar
    17 posts
    Registered:
    28 Aug 2012
    16 May 2011
    Link to this post
    Thanks Georgi for your efforts. Much appreciated. I wouldn't think of putting nasty hacks in my enterprise project. Hope to see more fixes from you guys in the next service pack. Started working on a government site and I cannot use ugly code there.
  9. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    17 May 2011
    Link to this post
    Hello,

    Thanks once again for the understanding.
    We will release a hotfix today for this issue, and a problem with localized characters in the database. We will name it Sp1 hotifx and it will be officially supported so that you can go live with it, and don't use any hacks. The risk of regressions after upgrading with be near to none. 

    We believe this is the best way to address these issues, let me know if you have any other ideas. Your feedback was taken into account while making the decision.

    Kind regards,
    Georgi
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  10. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    17 May 2011
    Link to this post
    @Georgi

    Any chance the hotfix will fix custom role problems if there are any (there is still a chance I am to dumb)

    Markus
  11. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    17 May 2011
    Link to this post
    Hi,

    This fix is going to appear in the internal build this Friday. We will also deliver couple of other things, but will support you guys, if you hit any problems even with the internal build.

    Phil and Ed, I am going to mail you with suggestions, so that you can have a clean code. Markus, let's keep this in a separate thread, please.

    Best wishes,
    Georgi
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  12. William
    William avatar
    108 posts
    Registered:
    15 Feb 2011
    17 May 2011
    Link to this post
    Hi Georgi,

    Just to be clear, then.  There is no hotfix coming today to fix Phil's issue.  Instead, that fix is in an internal build on Friday?

    - William
  13. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    17 May 2011
    Link to this post
    Hi William,

    Yes, the workaround is good enough, and we can also send you another solution if you do not want to go with it.

    Regards,
    Georgi
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  14. William
    William avatar
    108 posts
    Registered:
    15 Feb 2011
    17 May 2011
    Link to this post
    Georgi,

    I'm fine with Phill's fix, however it doesn't account for situations where you might want to have pages excluded from SEO.  But I suppose that's an edge case.

    - William
  15. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    17 May 2011
    Link to this post
    Hello William,

    There is a solution for that, I saw that my colleague have just provided you with it.
    Let us if you need further help.

    All the best,
    Georgi
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  16. Madhavan
    Madhavan avatar
    19 posts
    Registered:
    31 Jan 2011
    19 Jul 2011
    Link to this post
    Hi Georgi,

      Can you please post the hotfix for this issue again. We are still in sp1 and this is creating a problem for our production site with Search and SEO.

    Thanks
    Madhavan
  17. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    20 Jul 2011
    Link to this post
    Hello Madhavan,

    Here it is, posted by Phil:

    protected void Page_Load(object sender, EventArgs e)
    {
        // ToDo temp fix to prevent noindex meta tag
        foreach (Control hm1 in Page.Header.Controls)
        {
            if (hm1 is HtmlMeta && (((HtmlMeta)hm1).Name.ToLower() == "robots"))
            {
                Page.Header.Controls.Remove(hm1);
            }
        }
    }

    All the best,
    Georgi
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  18. Madhavan
    Madhavan avatar
    19 posts
    Registered:
    31 Jan 2011
    20 Jul 2011
    Link to this post
    Hi Georgi,

      I had already implemented the same on my master pages. I was of the opinion that telerik had released  fix for this. I am wondering if that was ever released and if so is it still available for users to implement on SP1. I could not migrate my production sites to SP2 because of altogether different issue which I am working with Telerik through a different support ticket.

    Thanks
    Madhavan
  19. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    21 Jul 2011
    Link to this post
    Hi Madhavan,

    You are right actually. I have attached 2 assemblies, which are considered as a hotfix for this issue. Just replace them with the ones in your project (please backup first).

    Greetings,
    Georgi
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  20. Madhavan
    Madhavan avatar
    19 posts
    Registered:
    31 Jan 2011
    21 Jul 2011
    Link to this post
    Thanks Georgi

    Madhavan
20 posts, 0 answered