More in this section

Forums / Bugs & Issues / 4.2 - Lots of bugs...so it seems

4.2 - Lots of bugs...so it seems

2 posts, 0 answered
  1. Allen
    Allen avatar
    71 posts
    Registered:
    04 Aug 2007
    12 Sep 2011
    Link to this post
    I recently upgraded a client's site to 4.2 and I am now very sad.  I am getting a lot of errors:

    1) Using the log in control:
        a. Setting the Title does not "stick" and the value comes back as null after a save.
        b. Cannot make the  "login" link an image.
        c. Set login control to not show when logged in....It does anyway- but randomly.
    2) News
        a. Inserting a document link makes the new item HTML broken in some weird way.  This seems to only happen if you edit the item after insering the document link...I think.  (It behaves differently in IE vs. Chrome)
    3) Created new template for a widget which had C# code in the template (created in 4.1 - and it worked).  Template stopped working, went in to modify the template, editor STRIPPED out C# code.
        a. Tried to add fields to the template using the "<%Eval("")>" markup. The template simply ignored the values.


    Is this just me or is anyone else getting all these random errors?  I don't think I have ever experienced a release of SiteFinity so buggy.  At this point, I am very concerned about moving forward with the project.

  2. MBA
    MBA avatar
    11 posts
    Registered:
    08 Jul 2008
    12 Sep 2011
    Link to this post
    Allen,

    Stripping out code within the CMS (Backend) editor is normal SiteFinity 4.2+ behaviour. See this post and this post (and Telerik's response, below, on applying the hotfix which may solve some more issues). 

    The video posted here by Boyan should help you create and integrate and external template. 

    Thanks!

    http://www.sitefinity.com/devnet/forums/sitefinity-4-x/developing-with-sitefinity/external-widget-templates.aspx#1754482
    Adding an external template [VIDEO] > http://www.sitefinity.com/ClientsFiles/291234_News-widget-external-template.rar
2 posts, 0 answered