More in this section

Forums / Bugs & Issues / Return Code 12031

Return Code 12031

10 posts, 0 answered
  1. Atle
    Atle avatar
    22 posts
    Registered:
    11 Jan 2011
    26 Dec 2011
    Link to this post
    Whatever I try to do I get this error on new projects created with 4.4. I suspect it is a permission problem since I dont get the error if I work on the server directly (localhost) or run from the Project Manager. This was not a problem with project created before 4.4. I use SQL Server Express
     
    What can it be, could it be permissions? NETWORK SERVICE have "Full Control" over App_Data.

    Atle
  2. Atle
    Atle avatar
    22 posts
    Registered:
    11 Jan 2011
    27 Dec 2011
    Link to this post
    Update:
    In FireFox the message is "Return Code 0"
    I also created a fresh new project, and same problem unless I'm working directly on the server.
  3. Lubomir Velkov
    Lubomir Velkov avatar
    688 posts
    Registered:
    03 Nov 2014
    28 Dec 2011
    Link to this post
    Hello Atle,

    Could you give us access to your backend so that we could try and see for ourselves what might be the problem? In previous versions of Sitefinity this error happened sometime but starting from 4.3 we thought we eraticated it. As for the Return Code 0 - this eror is reproduceable with other browsers too - it happens when you click somewhere on the backend before the previous service call finished executing.

    Regards,
    Lubomir Velkov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  4. Atle
    Atle avatar
    22 posts
    Registered:
    11 Jan 2011
    28 Dec 2011
    Link to this post
    I apologize if I've let people believe that this was a Sitefinity problem.
    I have investigated this more. It might be a firewall issue because the error is not for 4.4 only.

    I have discoverd that an old 4.2 project now has the same error. Since this error was not there before, I suspect someone in our organisation has changed the settings on the firewall. Maybe Silverlight is blocked or something.
    I need to get in contact with our server team to be sure. I'll let you know.
  5. Lubomir Velkov
    Lubomir Velkov avatar
    688 posts
    Registered:
    03 Nov 2014
    30 Dec 2011
    Link to this post
    Hi Atle,

    No problem. If you wish you could give us access to your backend so that we could try and investigate the issue on our side.

    All the best,
    Lubomir Velkov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  6. HC
    HC avatar
    4 posts
    Registered:
    11 Oct 2009
    16 Feb 2012
    Link to this post
    Hi Atle

    We are getting the same error. Did you solve this eventually?

    Thanks heaps
    HC
  7. Lubomir Velkov
    Lubomir Velkov avatar
    688 posts
    Registered:
    03 Nov 2014
    20 Feb 2012
    Link to this post
    Hi HC,

    What version of Sitefinity are you using? If it is not the latest (4.4) did you try upgrading to it and checking if the error still happens?

    Kind regards,
    Lubomir Velkov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  8. Charles
    Charles avatar
    61 posts
    Registered:
    18 Jul 2012
    08 Aug 2012
    Link to this post
    Hello,
    I appear to be having this error. We're using 5.1.3270. Steps to reproduce
    1.Click on 'Documents & Files'
    2.Click on 'xxxxxx.zip' document

  9. Charles
    Charles avatar
    61 posts
    Registered:
    18 Jul 2012
    08 Aug 2012
    Link to this post
    Sry. Double post.
  10. Randy Hodge
    Randy Hodge avatar
    96 posts
    Registered:
    03 Nov 2014
    12 Aug 2012
    Link to this post
    Hi, Charles.

    Error code 12031 is a general message with WCF services that something went wrong on the DB level.
    Since the error might be coming from a number of different areas, can you try and login to your website and reproduce the error, tracing the web service exceptions as described here, then send the trace log to me so I can have a closer look at the service exceptions?

    Thank you in advance.

    All the best,
    Randy Hodge
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
10 posts, 0 answered