More in this section

Forums / Bugs & Issues / 5.0 fresh install ~/Telerik.Web.UI.WebResource.axd' is missing in web.config

5.0 fresh install ~/Telerik.Web.UI.WebResource.axd' is missing in web.config

5 posts, 0 answered
  1. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    07 Mar 2012
    Link to this post
    Good day 

    I have a special way of setting up fresh projects.

    1) Run Sitefinity.exe and create project localy file system
    2) Upload the whole project TPT to server
    3) Access the site which will trigger the initial setup
    4) Connect to my DB on server
    -----
    If all works then I download the App_Data/Sitefnity to my local project and start backing up my SQL Database.

    This time I get the error as shown in screenshot_01.png. I had this kind or error before but building and republishing the sitefnity.dll or even simply uploading the web.config again (restating app) would solve this problem.

    Not this time with the fresh 5.0 install. Any idea?

    I got this section in the web.config

    <httpHandlers>
         <remove verb="*" path="*.asmx" />
         <add verb="*" validate="false" path="Telerik.Web.UI.SpellCheckHandler.axd" type="Telerik.Web.UI.SpellCheckHandler, Telerik.Web.UI" />
         <add verb="*" path="Telerik.RadUploadProgressHandler.ashx" type="Telerik.Web.UI.Upload.RadUploadProgressHandler, Telerik.Web.UI" />
         <add verb="*" path="Telerik.Sitefinity.FilesDownloadHandler.ashx" type="Telerik.Sitefinity.Modules.Files.FilesDownloadHandler, Telerik.Sitefinity" />
         <add verb="*" path="Telerik.Sitefinity.LibrariesRadUploadHandler.ashx" type="Telerik.Sitefinity.Modules.Libraries.Web.LibrariesRadUploadHandler, Telerik.Sitefinity" />
         <add verb="*" path="Telerik.Sitefinity.ThumbnailUploadHandler.ashx" type="Telerik.Sitefinity.Modules.Libraries.Web.ThumbnailUploadHandler, Telerik.Sitefinity" />
         <add verb="*" path="*.asmx" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
         <add verb="*" path="*_AppService.axd" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
         <add verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" validate="false" />
         <add verb="*" validate="false" path="Telerik.Web.UI.DialogHandler.axd" type="Telerik.Web.UI.DialogHandler, Telerik.Web.UI" />
         <add verb="*" path="Telerik.Sitefinity.AsyncImageUploadHandler.ashx" type="Telerik.Sitefinity.Modules.Libraries.Web.AsyncImageUploadHandler, Telerik.Sitefinity" />
         <add verb="*" path="Telerik.Sitefinity.AsyncFileUploadHandler.ashx" type="Telerik.Sitefinity.Workflow.AsyncFileUploadHandler, Telerik.Sitefinity" />
         <add verb="*" path="Telerik.Sitefinity.AsyncToolsetXmlUploadHandler.ashx" type="Telerik.Sitefinity.Configuration.Web.Services.AsyncToolsetXmlUploadHandler, Telerik.Sitefinity" />
         <add verb="*" path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource" validate="false" />
         <add path="Telerik.Web.UI.DialogHandler.aspx" verb="*" type="Telerik.Web.UI.DialogHandler" validate="false" />
         <add verb="*" path="Telerik.ReportViewer.axd" type="Telerik.ReportViewer.WebForms.HttpHandler, Telerik.ReportViewer.WebForms" />
       </httpHandlers>


    Markus

    PS: SF 4.4 just released still on site screenshot_02.png
  2. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    07 Mar 2012
    Link to this post
    I remembered that I usually got this error when I switch for example from .net 4.0 to .net 4 integrated Pipeline.

    When I set to 4.0 I get a 404 error on the site and on site/sitefinity
    When I set to 4.0 Integrated pipeline I get the above mentioned error.

    Using the integrated server localy connecting to the remote db I can acess the backend. So it must be a server setting problem. 

    Sorry it's a new server so i might go back to RTFM of hot to setup SF in the first place and the error messag is simply missleading.

    Markus
  3. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    07 Mar 2012
    Link to this post
    I was wrong. I had and have an 4.4 test site on that server and that runs perfect. 

    So I am stuck with this error.

    Markus
  4. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    09 Mar 2012
    Link to this post
    Thanks to support we found the problem.
    The whole handlers section was missing from the web.config. Have no clue how this could have happen.

    <handlers>
          <remove name="WebDAV" />
          <remove name="ScriptHandlerFactory" />
          <remove name="ScriptHandlerFactoryAppServices" />
          <remove name="ScriptResource" />
          <remove name="UrlRoutingHandler" />
          <remove name="WildCard" />
          <remove name="WildCard32" />
          <remove name="Telerik.Web.UI.DialogHandler" />
          <remove name="Telerik.RadUploadProgressHandler" />
          <remove name="Telerik.Sitefinity.FilesDownloadHandler" />
          <remove name="Telerik.Sitefinity.LibrariesRadUploadHandler" />
          <remove name="Telerik.Sitefinity.AsyncImageUploadHandler" />
          <remove name="Telerik.Sitefinity.AsyncFileUploadHandler" />
          <remove name="Telerik.Sitefinity.AsyncToolsetXmlUploadHandler" />
          <remove name="Telerik.Web.UI.SpellCheckHandler" />
          <remove name="Telerik_Web_UI_WebResource_axd" />
          <remove name="Telerik_Web_UI_DialogHandler_aspx" />
          <add name="ScriptHandlerFactory" verb="*" path="*.asmx" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
          <add name="ScriptHandlerFactoryAppServices" verb="*" path="*_AppService.axd" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
          <add name="ScriptResource" preCondition="integratedMode" verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
          <add name="WildCard" path="*" verb="*" modules="IsapiModule" scriptProcessor="%windir%\Microsoft.NET\Framework64\v4.0.30319\aspnet_isapi.dll" resourceType="Unspecified" requireAccess="None" preCondition="classicMode,runtimeVersionv4.0,bitness64" />
          <add name="WildCard32" path="*" verb="*" modules="IsapiModule" scriptProcessor="%windir%\Microsoft.NET\Framework\v4.0.30319\aspnet_isapi.dll" resourceType="Unspecified" requireAccess="None" preCondition="classicMode,runtimeVersionv4.0,bitness32" />
          <add name="Telerik.Web.UI.DialogHandler" path="Telerik.Web.UI.DialogHandler.axd" verb="*" type="Telerik.Web.UI.DialogHandler, Telerik.Web.UI" />
          <add name="Telerik.RadUploadProgressHandler" path="Telerik.RadUploadProgressHandler.ashx" verb="*" type="Telerik.Web.UI.Upload.RadUploadProgressHandler, Telerik.Web.UI" />
          <add name="Telerik.Sitefinity.FilesDownloadHandler" path="Telerik.Sitefinity.FilesDownloadHandler.ashx" verb="*" type="Telerik.Sitefinity.Modules.Files.FilesDownloadHandler, Telerik.Sitefinity" />
          <add name="Telerik.Sitefinity.LibrariesRadUploadHandler" path="Telerik.Sitefinity.LibrariesRadUploadHandler.ashx" verb="*" type="Telerik.Sitefinity.Modules.Libraries.Web.LibrariesRadUploadHandler, Telerik.Sitefinity" />
          <add name="Telerik.Sitefinity.ThumbnailUploadHandler" path="Telerik.Sitefinity.ThumbnailUploadHandler.ashx" verb="*" type="Telerik.Sitefinity.Modules.Libraries.Web.ThumbnailUploadHandler, Telerik.Sitefinity" />
          <add name="Telerik.Sitefinity.AsyncImageUploadHandler" path="Telerik.Sitefinity.AsyncImageUploadHandler.ashx" verb="*" type="Telerik.Sitefinity.Modules.Libraries.Web.AsyncImageUploadHandler, Telerik.Sitefinity" />
          <add name="Telerik.Sitefinity.AsyncFileUploadHandler" path="Telerik.Sitefinity.AsyncFileUploadHandler.ashx" verb="*" type="Telerik.Sitefinity.Workflow.AsyncFileUploadHandler, Telerik.Sitefinity" />
          <add name="Telerik.Sitefinity.AsyncToolsetXmlUploadHandler" path="Telerik.Sitefinity.AsyncToolsetXmlUploadHandler.ashx" verb="*" type="Telerik.Sitefinity.Configuration.Web.Services.AsyncToolsetXmlUploadHandler, Telerik.Sitefinity" />
          <add name="Telerik.Web.UI.SpellCheckHandler" verb="*" path="Telerik.Web.UI.SpellCheckHandler.axd" type="Telerik.Web.UI.SpellCheckHandler, Telerik.Web.UI" />
          <add name="Telerik_Web_UI_WebResource_axd" verb="*" path="Telerik.Web.UI.WebResource.axd" preCondition="integratedMode" type="Telerik.Web.UI.WebResource" />
          <add name="Telerik_Web_UI_DialogHandler_aspx" verb="*" preCondition="integratedMode" path="Telerik.Web.UI.DialogHandler.aspx" type="Telerik.Web.UI.DialogHandler" />
          <add name="Telerik.ReportViewer.axd_*" verb="*" preCondition="integratedMode" path="Telerik.ReportViewer.axd" type="Telerik.ReportViewer.WebForms.HttpHandler, Telerik.ReportViewer.WebForms" />
        </handlers>

    Markus
  5. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    13 Aug 2012
    Link to this post
    I installed two new sitefinity 5.1 SBE on the very same VPS. 
    One went smooth, the other had the handlers section missing.
    Markus
5 posts, 0 answered