More in this section
Forums / Bugs & Issues / admin password reset Sitefinity 5

admin password reset Sitefinity 5

The forums are in read-only mode. In case that you want to directly contact the Progress Sitefinity team use the support center. In our Google Plus group you can find more than one thousand Sitefinity developers discussing different topics. For the Stack Overflow threads don’t forget to use the “Sitefinity” tag.
4 posts, 0 answered
  1. Brian
    Brian avatar
    2 posts
    Registered:
    30 Dec 2008
    04 May 2012
    Link to this post
    HI,

    Followed instructions on http://www.sitefinity.com/help/developer-manual/resetting-administrator-password.html to reset password.

    None appear to work. Using Community edition Version 5.0.2860.0.
  2. Brian
    Brian avatar
    2 posts
    Registered:
    30 Dec 2008
    17 May 2012
    Link to this post
    Amazing how nobody has replied to this yet.
  3. Andrei
    Andrei avatar
    10 posts
    Registered:
    16 Apr 2012
    18 May 2012
    Link to this post
    Brian,
    Are you:
    1 - Trying to provide pasword reset functionality in a control
    2 - Trying to get into your application via the "back-door" because you forgot your password?

    Can you outline step-by-step exactly what you have tried. More information always helps.
    When I forget my password, I go to the database, find the table sf_users, access it in edit mode, then find the field password_format and change it to 0 (zero), and then type a password in the password field. then I try to log in with that password. after that, change the format back.

    Andrei
  4. John
    John avatar
    1 posts
    Registered:
    24 Aug 2012
    24 Aug 2012
    Link to this post
    Brian, I came across your post because I had the same problem, I installed an evaluation copy and forgot the admin password. Following the instructions in that link alone did not work, but here's what I had to do:

    As well as setting "password_format = 0", I had to set the salt = NULL, set the failed_password_attempt_count = 0, last_lockout_date = 0, is_locked_out = 0, and finally what did it was setting is_logged_in = 0. 

    I'm not sure if all of these are required or if "is_logged_in" was all that I had to change, but this combination of steps worked for me. 

    And following the instructions to reset the password did not work for me either, I would press reset and would get a confirmation dialog asking me if I'm sure I want to reset the password, after pressing yes, nothing happens. To resolve that I just created a new user, and manually copied the password and salt generated for it and put them on the admin record, and don't forget to set the format back to 0. 

    I know it's very late and Telerik didn't help you here, but I hope that was helpful to you!


    John
4 posts, 0 answered