More in this section

Forums / Bugs & Issues / Browse and Edit messing up RadWindow

Browse and Edit messing up RadWindow

6 posts, 0 answered
  1. j8
    j8 avatar
    20 posts
    Registered:
    30 Oct 2007
    17 Mar 2011
    Link to this post

    Hi guys,

    I'm using the RadWindow control in my Sitefinity project and noticed something strange. When you're logged in (the browse and edit tools are shown) and open a RadWindow there are no styles applied to it. When you log out and open the RadWindow all is good.

    I'm attaching some pictures to clarify;

    nostyles.png; logged in to the backend, so browseandedit is activated, the window has no styles

    yesstyles.png; logged out of the backend, no browseandedit, the window has styles

    contentblock.png; I've put a Content Block on the page with some text in it. Logged in to the backend. This time there are styles.

    The control I used to test this;

    <%@ Control Language="C#" AutoEventWireup="true" CodeBehind="ListItemList.ascx.cs" Inherits="SitefinityWebApp.Dynamicus.UserControls.Dynamics.Booklists.ListItemList" %>
      
    <input type="button" style="width: 50px" id="openBtn" onclick="ShowDetailsForm(); return false;" title="Open" value="Open" />
      <telerik:radwindowmanager ID="RadWindowManager1" runat="server" EnableShadow="true">
          <Windows>
              <telerik:RadWindow 
            ID="ItemDetailsDialog" 
            runat="server" 
            Title="Artikel details" 
            Height="440px"
                  Width="440px" 
            Left="150px" 
            ReloadOnShow="true" 
            ShowContentDuringLoad="false" 
            Modal="true" 
            visiblestatusbar="false" 
            behaviors="Close, Move, Pin, Reload, Resize"
            skin="Black"
            />
          </Windows>
      </telerik:radwindowmanager>
      
      <telerik:radcodeblock id="RadCodeBlock1" runat="server">
      
        <script type="text/javascript">
                        /* <![CDATA[ */
                        function ShowDetailsForm() {
                            window.radopen("http://www.telerik.com", "ItemDetailsDialog");
                        }
      
                        /* ]]> */
        </script>
      </telerik:radcodeblock>

    Regards,

      Peter

  2. Katia
    Katia avatar
    194 posts
    Registered:
    01 Jul 2016
    18 Mar 2011
    Link to this post
    Hello j8,

    Thanks for reporting this issue. It is logged (№110905) and will be fixed for one of the next releases. It looks like that the CSS which is used for styling "Browse and edit" dialogs applies to your Rad Window as well. However, as you have noticed, when you are not logged in the administration and "Browse and edit" is off, the extra CSS files will not be linked to the public pages.

    Let us know if yo need further help.



    Greetings,
    Katia
    the Telerik team
  3. Andrei
    Andrei avatar
    553 posts
    Registered:
    27 Nov 2008
    24 Mar 2011
    Link to this post
    Hi,

    Is there a way to turn off the "editing whilst browsing" feature? 
    It is annoying to have a big thumb nail on the side of the screen.

    I know I can just log off, but wondering if there is a way to switch it off
    from appearing whilst you are still logged in?

    Thanks,
    Andrei
  4. Lyubomir Dokov
    Lyubomir Dokov avatar
    43 posts
    Registered:
    06 Jun 2017
    24 Mar 2011
    Link to this post
    Hi Andrei,

    Yes, there is a way to turn inline editing off:

    1. Go to Administration -> Settings and click Advanced mode.
    2. Go to Pages and there you will find EnableBrowseAndEdit option.
    3. You can set it to false and it will be disabled.

    Note, that this setting is available as of SP1.


    Greetings,
    Lyubomir Dokov
    the Telerik team
  5. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    24 Mar 2011
    Link to this post
    @Lyubomir

    Will that be a per user profile option soon?
  6. Andrei
    Andrei avatar
    553 posts
    Registered:
    27 Nov 2008
    25 Mar 2011
    Link to this post
    Lyubomir,
    Thanks,
    Andrei
6 posts, 0 answered