More in this section
Forums / Bugs & Issues / Custom urlFormat not working for Events

Custom urlFormat not working for Events

The forums are in read-only mode. In case that you want to directly contact the Progress Sitefinity team use the support center. In our Google Plus group you can find more than one thousand Sitefinity developers discussing different topics. For the Stack Overflow threads don’t forget to use the “Sitefinity” tag.
1 posts, 0 answered
  1. kavede
    kavede avatar
    0 posts
    Registered:
    27 Oct 2016
    10 Jan 2017
    Link to this post

    Hi,

    By default event items get URLs like this:
    http://localhost/eventdetails/2017/04/25/default-calendar/my-event

    I want them to be like this:
    http://localhost/eventdetails/my-event

    So without the date and without the calendar in the URL.
    For this I went into Administration > Settings > Advanced > Events > Providers > OpenAccessDataProvider > Parameters
    There I've added a new parameter called urlFormat and I gave it value /[UrlName]

    Then I restarted Sitefinity in different ways:
    - clicked "save changes" on user authentication settings
    - restarted both site and application pool in IIS

    But when I create a new event, it still keeps the old URL format and not the new one.
    What am I missing ?

1 posts, 0 answered