More in this section

Forums / Bugs & Issues / Enter button does not submit form when RadTextBox has focus in 5.0 SP1

Enter button does not submit form when RadTextBox has focus in 5.0 SP1

3 posts, 0 answered
  1. cli
    cli avatar
    50 posts
    Registered:
    21 May 2007
    04 May 2012
    Link to this post
    Please tell me I'm missing something.  Has the default behavior of the RadTextBox changed to ignore enter key presses to submit a form?  I upgraded from 4.4 to 5.0 SP1.  My forms utilizing RadTextBoxes submit fine with an enter keypress in 4.4.  Now that I've upgraded if the RadTextBox is in focus you can't hit enter to submit the form.  You have to do a mouse click on the submit button.  A regular asp:textbox will submit fine.  I've tested this both on a plain aspx page (outside the CMS) and with in the CMS using a custom control.  I then realized there are RadTextBoxes in the Sitefinity backend pages when you edit a profile.  Indeed I cannot update a profile by hitting the enter key.  Is this a RadControl bug?  Can I go to a different telerik.web.ui version in 5.0 SP1 without problems?
  2. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    06 May 2012
    Link to this post
    Hmmm, in the Q1 2012 SP1 radcontrols there's a fix note for "Auto postback does not work for [Enter] key when the value is not changed for the RadNumericTextBox"

    Could that be it?  SF 5.0 SP1 just has the RadControls Q1 2012 (not the service pack)

    Release Notes
  3. cli
    cli avatar
    50 posts
    Registered:
    21 May 2007
    07 May 2012
    Link to this post
    Thanks, it does indeed sound related to that.  There are various [Enter] button issues listed apparently.  Not totally certain but maybe I'll mess w/ Q1 2012 SP1 and try to get it in there and find out.
3 posts, 0 answered