More in this section

Forums / Bugs & Issues / Error in custom module

Error in custom module

2 posts, 0 answered
  1. Luc Baeten
    Luc Baeten avatar
    169 posts
    Registered:
    23 Sep 2005
    15 Mar 2012
    Link to this post
    Hi

    I am using the latest version of Sitefinity: version 5. I try to create a module with the module builder.
    I first created a new module with a couple of fields. Everythingh worked fine. But after making changes to the fields (remove field and add a new one) and selecting the button ;Update widget templates and finish' I get an error on the page where I defined the new module.

    The ContentViewDefinition with name 'ImagesFrontend' does not exist in configuration files.
    You should either add the ContentViewDefiniton with such name to the configuration;
    change ControlDefinitionName or load ControlDefinition programatically by setting
    the ControlDefinition property.


    t has to do with the type of field I added: media field. After removing the field reference from the created widget template, everything worked fine again.

    What is the reason of this error?
    Regards
    Luc
  2. Luc Baeten
    Luc Baeten avatar
    169 posts
    Registered:
    23 Sep 2005
    15 Mar 2012
    Link to this post
    Hello

    For your info:
    I created a small business edition with Sitefinity version 5.2500. I have seen that in this version there were some problems with image libraries.So I installed version 2523 now and will try to create the custom module with the media type field again. See if the problem has been solved...

    regards
    Luc Baeten
2 posts, 0 answered