More in this section

Forums / Bugs & Issues / heirachry works on menus - not in sitefinity 4.1 edit mode

heirachry works on menus - not in sitefinity 4.1 edit mode

6 posts, 0 answered
  1. Brandon
    Brandon avatar
    50 posts
    Registered:
    30 Jul 2009
    19 Apr 2011
    Link to this post
    i'm staring at my site page with a menu on it and the pages are ordered how we had them in sitefinity before the 4.1 release.

    now they are still in that order when i view the site - but in sitefinity edit mode i'm looking at the sitemap/page structure and anytime i move a page up or down it says "whatever page name reordered" but then if i refresh, go off the "pages" page and come back to it they just re-order themselves again. they will not stay how i set them but they do not order like this when i view the live site?

    any ideas, anyone else have this problem?

    edit: nevermind - they dont show in the correct order on the site either...they will not maintain the order i place them.
  2. Scott
    Scott avatar
    28 posts
    Registered:
    12 Nov 2010
    19 Apr 2011
    Link to this post
    I WAS experiencing the same problem - however once I did some rearranging in the site tree, they re-ordered correctly.
  3. Brandon
    Brandon avatar
    50 posts
    Registered:
    30 Jul 2009
    19 Apr 2011
    Link to this post
    so i can recreate this everytime now.

    doesnt matter what browser (normally use firefox) but i have done it in ie8, chrome as well.

    starting with a fresh browser window and not logged in to the site - i can go to the login page and login. upon logging in everything is sorted how it should be. i can view a live page and the menu will be in the same order as it appears in the pages tab of the cms. all looks good and this is when sorting set to hierarchy.

    then just click the pages link up at the top menu or refresh the page and bam - entire sections of the sitemap reorder themselves - but not really. they do in the cms but if you flip back over to a live site page the menu remains in it's original order.

    even if i reorder the pages (by dragging or one at a time - check marking, click actions > move up/down) it says page reordered in cms but nothing actually happened.

    this is with a structure similar to this:
    home
      Main link 1
      Main link 2
        Group 1
          Page 1
          Page 2
          Page 3
          Sub Group 1
            Page 1
            Page 2
        Group 2
          Page 1
          Page 2
          Page 3
      Main link 3
      Main link 4
  4. Momchil Mitev
    Momchil Mitev avatar
    13 posts
    Registered:
    14 Jul 2016
    20 Apr 2011
    Link to this post
    Hello Brandon,

    Please, excuse us for the inconvenience. There seems to be a bug introduced with 4.1 version concerning the pages ordering. We have logged it in our bug tracking system with high priority and we are working on fixing it. The fix is scheduled for the next internal build. You can track its progress in PITS

     We have added points to your account for reporting this. Don't hesitate to contact us if you have other questions.


    Best wishes,
    Momo
    the Telerik team

  5. Momchil Mitev
    Momchil Mitev avatar
    13 posts
    Registered:
    14 Jul 2016
    20 Apr 2011
    Link to this post
    Hi Brandon,

    You can workaround this issue by reordering your pages manually as shown in the image by placing them as last in their level.

    Regards,
    Momchil Mitev
    the Telerik team

  6. Brandon
    Brandon avatar
    50 posts
    Registered:
    30 Jul 2009
    20 Apr 2011
    Link to this post
    cool thank you for the update!
6 posts, 0 answered