More in this section

Forums / Bugs & Issues / Image library renaming multiple URLs

Image library renaming multiple URLs

8 posts, 0 answered
  1. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    31 Aug 2011
    Link to this post
    I created a image library and named it Ford (small) and uploaded image.

    Now I realised it should have been namend Ford (medium) so I rename it.

    Now I want to crate another libray with Ford (small) and get an error that an element with Ford (small) already exits.

    Goint into the uploade images (now in Ford (medium)) I see that they have an adtional ULR pointing to the old Ford (small). Unfortunately it seem that if I remove the tick in the checkbox the setting is not saved.

    Markus
  2. Lubomir Velkov
    Lubomir Velkov avatar
    688 posts
    Registered:
    03 Nov 2014
    02 Sep 2011
    Link to this post
    Hi Markus Berchtold,

    Unfortunately this is how the multiple URLs feature works. Once you create a URL you cannot delete it, because we suppose that you have already linked this item somewhere. The only solution is to remove the URL from the database - the table is sf_url_data.

    Greetings,
    Lubomir Velkov
    the Telerik team

    Thank you for being the most amazing .NET community! Your unfailing support is what helps us charge forward! We'd appreciate your vote for Telerik in this year's DevProConnections Awards. We are competing in mind-blowing 20 categories and every vote counts! VOTE for Telerik NOW >>

  3. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    21 Sep 2011
    Link to this post
    Dear Lubmir

    Am I supposed to fix that every time a client makes a mistake. Or is Telerik fixing this?

    Markus
  4. Lubomir Velkov
    Lubomir Velkov avatar
    688 posts
    Registered:
    03 Nov 2014
    22 Sep 2011
    Link to this post
    Hi Markus Berchtold,

    This seems to be a bug only when you are in multilingual mode and for other content items. I was able to reproduce your scenario with the image libraries without issue - after renaming the first library I successfully created a new one with the old name. I don't see the fix for additional urls for multilingual mode in the release notes for SP1 though so I guess it will be fixed in the next service releases.

    Best wishes,
    Lubomir Velkov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    22 Sep 2011
    Link to this post
    Dear Lubomir

    Here we go again: http://www.youtube.com/watch?v=rY0WxgSXdEE

    You probably don't know it but every time I find a bug this song pubs into mind with a bit different lyrics.

    Another one finds a bug instead of another one bits the dust :-)

    Try to sing along and you will finding bugs fun :-) If I ever find time I make up SF lyrics for the whole song and mybe get Wierd Al to cover it for me.

    Markus
  6. Lubomir Velkov
    Lubomir Velkov avatar
    688 posts
    Registered:
    03 Nov 2014
    22 Sep 2011
    Link to this post
    Hello Markus Berchtold,

    The additional urls issue in Multilingual mode for Pages is a known issue, but I still wonder about your initial question about the Image Library - as I mentioned I wasn't able to reproduce the issue.

    Best wishes,
    Lubomir Velkov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  7. Markus
    Markus avatar
    2763 posts
    Registered:
    25 Nov 2005
    22 Sep 2011
    Link to this post
    Did you try to reproduce it?

    I created a image library and named it Ford (small) and uploaded image.

    Now I realised it should have been namend Ford (medium) so I rename it.

    Now I want to crate another libray with Ford (small) and get an error that an element with Ford (small) already exits.

    Markus

  8. Lubomir Velkov
    Lubomir Velkov avatar
    688 posts
    Registered:
    03 Nov 2014
    22 Sep 2011
    Link to this post
    Hi Markus Berchtold,

    I just realised that I was doing this with the latest release branch and I was successful. This means that this issue has been fixed and made it to SP1 that will be released in the beginning of the next week.

    Sorry for the misundestanding.

    Best wishes,
    Lubomir Velkov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
8 posts, 0 answered