More in this section

Forums / Bugs & Issues / Layout Change Deletes Content Block

Layout Change Deletes Content Block

3 posts, 0 answered
  1. Michael H.
    Michael H. avatar
    16 posts
    Registered:
    10 Nov 2007
    26 Dec 2010
    Link to this post
    Changing page layout causes content widget to disappear.

    Version: Sitefinity_4.0.1030.0

    Steps
    1. Create a new page "test".
    2. Add Content Block widget and set to "asdf".
    3. Publish Page.
    4. View "test" page ("asdf" is displayed).
    5. Edit "test" page.
    6. Add layout 100%
    7. Move existing Content Block widget "asdf" into layout 100%
    8. Publish page.
    9. Edit "test" page.
    10. Content Block widget is gone.
  2. Sonya
    Sonya avatar
    205 posts
    Registered:
    09 Dec 2016
    28 Dec 2010
    Link to this post
    Hello Michael,

    Thank you for reporting this issue.

    This is a known issue in the RC2. The issue was logged as a bug with ID=103214.


    Best wishes,
    Sonya
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Lasse
    Lasse avatar
    30 posts
    Registered:
    08 Jun 2012
    30 Dec 2010
    Link to this post
    Hello Sonya & Michael.

    Just wanted to post a workaround: after adding the layout controls, save as draft or publish, then return to pages / templates list and open the page/template again - at this point it seems save to add the content into layout control.

    -Lasse
3 posts, 0 answered