More in this section

Forums / Bugs & Issues / Lingering issue, fixed in Q1 2011?

Lingering issue, fixed in Q1 2011?

7 posts, 0 answered
  1. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    09 Apr 2011
    Link to this post
    I reported this a few releases ago and it's still an issue....

    The "browse and edit" links come down visible and then (I assume jQuery) hides them...should be reversed.  Should come down hidden, and shown later with the links in the tab on the right.

    Will\Is this fixed in Q1 2011?  Looks terrible when someone is logged in (page popping)
  2. Boyan Barnev
    Boyan Barnev avatar
    1429 posts
    Registered:
    28 Aug 2017
    09 Apr 2011
    Link to this post
    Hi Steve,

    Can you please elaborate more on the desired functionality, maybe give me an example of a use case scenario where you want this implemented. Also, pointing me to the thread where you requested this issue would be very useful for further inspecting your request and notifying you of its status. Currently the behavior of the inline editing is to be hidden unless you select Show editing tools (To edit content while browsing the site) which shows the sections of the page that can be edited.

    All the best,
    Boyan Barnev
    the Telerik team

  3. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    09 Apr 2011
    Link to this post
    Agh darn I cant find the thread. Ok but on every postback the black browse and edit buttons below each widget are visible on the page...then I guess your script runs to hide them (when logged in if course). If you send them down with style="display:none" (or a class that hasnthe style) then we won't see the popping as they disappear.
  4. Boyan Barnev
    Boyan Barnev avatar
    1429 posts
    Registered:
    28 Aug 2017
    11 Apr 2011
    Link to this post
    Hi Steve,

    When you are not logged in you should not see the browse and edit buttons at all. When logged in, there's a cookie saving your selection (whether Browse and Edit is on or off) So if on a certain page you've selected browse and edit to be on, an if you close this page, next time you open it, the links will be shown, if you switch it off then next time you visit this page they'll be off - that's the default behavior of the widget. Of course, if you do not need this functionality, or you don't want ti displayed anymore, you can just set EnableBrowseAndEdit to False (from ~/Sitefinity/Administration/Settings/Advanced ->Pages).
    Please provide some more information if the issue you are reporting differs from what I've described above (if you could include a video snapshot describing how the problem reproduces it would be very useful).

    Greetings,
    Boyan Barnev
    the Telerik team

  5. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    11 Apr 2011
    Link to this post
    Right...thats the annoying issue. If it's OFF when I postback and am logged in then they are still visible for a second then the script hides them. They occupy space in the page so content gets all stretched out, the they hide and it all looks normal again. I'll record a video...
  6. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    11 Apr 2011
    Link to this post
    Here

    http://screencast.com/t/KjdneVjdP

    Notice when I click back to the Home Tab you see the black Browse\Edit buttons every time, then they pop out
  7. Boyan Barnev
    Boyan Barnev avatar
    1429 posts
    Registered:
    28 Aug 2017
    12 Apr 2011
    Link to this post
    Hi Steve,

    Thanks for your kind cooperation. Indeed this behavior is not appropriate, so I've logged this issue as a bug in our system and we'll be working on fixing it. You can track its progress in PITS on this public URL.

    Best wishes,
    Boyan Barnev
    the Telerik team

7 posts, 0 answered