More in this section
Forums / Bugs & Issues / Multiple URLs for items not working.

Multiple URLs for items not working.

The forums are in read-only mode. In case that you want to directly contact the Progress Sitefinity team use the support center. In our Google Plus group you can find more than one thousand Sitefinity developers discussing different topics. For the Stack Overflow threads don’t forget to use the “Sitefinity” tag.
12 posts, 0 answered
  1. Owain
    Owain avatar
    110 posts
    Registered:
    17 Jan 2012
    26 Sep 2012
    Link to this post
    Hi!
    I have a document within my library which is a PDF. The url for this file just now is - http://www.mydomain.com/docs/about/chapter1.pdf

    This works fine, however, this is on our development site and there is a link to the same document currently on our live site which is -
    http://www.mydomain.com/reviews/report/chapter1.pdf

    I had hoped that I could manually enter the url /reviews/report/chapter1.pdf in to the allow multiple URLs but I get an error saying the url is not valid. Ive tried the url with http:// and without but it still doesnt work.

    Is there a way to set this up so that old urls will point to this new location?

    Thanks.
  2. Stefani Tacheva
    Stefani Tacheva avatar
    718 posts
    Registered:
    31 May 2017
    17 Jun 2013
    Link to this post
    Hello,

    This is a known bug in Sitefinity. For your convenience please review the bug description in PITS on the following URL. You could track the status of the bug and vote for it. I hope that the problem will be fixed soon.

    Regards,
    Stefani Tacheva
    Telerik
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Beth
    Beth avatar
    29 posts
    Registered:
    30 Oct 2013
    04 Aug 2014
    Link to this post

    The link to the bug description no longer appears to be working. It's over a year later and I'm still encountering this bug (albeit, we are not using the latest version of Sitefinity). Where can I view the status of the bug?

  4. Pavel Benov
    Pavel Benov avatar
    341 posts
    Registered:
    14 Mar 2016
    07 Aug 2014
    Link to this post
    Hello Beth,

    I have checked the bug's status and unfortunately it is not yet resolved. You can follow on its progress in our Feedback portal:

    http://feedback.telerik.com/Project/153/Feedback/Details/100754-media-additional-urls-get-404-error

    Regards,
    Pavel Benov
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  5. Beth
    Beth avatar
    29 posts
    Registered:
    30 Oct 2013
    07 Aug 2014 in reply to Pavel Benov
    Link to this post

    Thank you!

  6. Richard
    Richard avatar
    103 posts
    Registered:
    04 Apr 2013
    27 Jan 2015 in reply to Pavel Benov
    Link to this post
    Can anyone comment on the resolution to this? Or include a possible workaround?
  7. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    27 Jan 2015 in reply to Richard
    Link to this post

    Richard said:Can anyone comment on the resolution to this? Or include a possible workaround?

     I would maybe say handle the global errors message and look for file not found or something, then search documents additional field for a match and if found 301 the user over to that document...sounds like it would work (in theory I suppose)

  8. Richard
    Richard avatar
    103 posts
    Registered:
    04 Apr 2013
    27 Jan 2015 in reply to Steve
    Link to this post

    @Steve: Nice creative workaround! I suppose if the whole process can be completed in not too long, it would be implementable. 

    If anyone else tries this, let us know. I'll give her a look in the near future and post my findings.... then sell it to Telerik ;)

  9. Devin
    Devin avatar
    16 posts
    Registered:
    27 Aug 2013
    03 Feb 2016
    Link to this post
    From Telerik support:
    To enable such additional URLs, go to Advanced Settings -> Libraries -> MediaFileAdditionalUrls and check the Media items additional URLs relative to site root (not to a containing page) checkbox.
  10. Beth
    Beth avatar
    29 posts
    Registered:
    30 Oct 2013
    03 Feb 2016 in reply to Devin
    Link to this post
    Thanks for the info. What version of Sitefinity are you using? I don't see "MediaFileAdditionalUrls" in the Libraries option tree in my version. (7.3)
  11. Devin
    Devin avatar
    16 posts
    Registered:
    27 Aug 2013
    03 Feb 2016
    Link to this post
    It was implemented in 8.0.5703.0.
  12. Beth
    Beth avatar
    29 posts
    Registered:
    30 Oct 2013
    03 Feb 2016 in reply to Devin
    Link to this post
    Thank you!
12 posts, 0 answered