More in this section

Forums / Bugs & Issues / Page no longer editable, viewable, and not able to revert to older reversion of it

Page no longer editable, viewable, and not able to revert to older reversion of it

3 posts, 0 answered
  1. Ryan
    Ryan avatar
    17 posts
    Registered:
    18 Jun 2012
    02 Jul 2012
    Link to this post
    This is very frustrating.  I had a working page and the only thing I changed was that I checked the "Requires SSL" checkbox (and then published).  Now I can no longer view or edit the page because it gives the 404 error.  Obviously, first thought was maybe this was because of Requires SSL, so I  unchecked the box and republished.  But now, even with Requires SSL unchecked, the page can still not be viewed or edited.  When I attempt to revert to an older version of the page, it gives the error also.

    Since I can't revert the page, it looks like my only option is to delete it and recreate it.

    EDIT: It looks like the page is still wanting SSL even though the "Requires SSL" option is unchecked.  In fiddler, when I browse to the page, it sends it to port 443, even though the scheme is http://.

    EDIT AGAIN:  What makes this more interesting is that in firefox, the page loads just fine on the front-end.  But when I attempt to load it in IE on the front-end, it gives the "Internet Explorer cannot display the webpage" error.  So why would the page be viewable to a user in firefox but not IE...

    Any ideas on how to resolve this issue?
  2. Ryan
    Ryan avatar
    17 posts
    Registered:
    18 Jun 2012
    02 Jul 2012
    Link to this post
    Fixed all this by changing the URL for the page.  If I change it back to the old URL, then it happens again.  Somehow checking the "Requires SSL" box for the page messed up the URL and now I am afraid to ever touch that checkbox again.
  3. Jochem Bökkers
    Jochem Bökkers avatar
    787 posts
    Registered:
    13 Aug 2007
    03 Jul 2012
    Link to this post
    Hey Ryan,

    It's not a Sitefinity bug or something, where it doesn't set the 'require ssl' flag to false.
    It's a caching issue (whether it's browser or server based I haven't tested). 

    After reading your 1st post, I tested it by setting require ssl to true, then back to false. Initially it wouldn't show the page. After server reset and browser cache clearing the page loaded perfectly again.

    Jochem
3 posts, 0 answered