More in this section
Forums / Bugs & Issues / Pagination in search results not working correctly

Pagination in search results not working correctly

The forums are in read-only mode. In case that you want to directly contact the Progress Sitefinity team use the support center. In our Google Plus group you can find more than one thousand Sitefinity developers discussing different topics. For the Stack Overflow threads don’t forget to use the “Sitefinity” tag.
3 posts, 0 answered
  1. Manivannan
    Manivannan avatar
    2 posts
    Registered:
    17 Sep 2014
    18 Sep 2014
    Link to this post

    I am using Sitefinity version 5.4.

    I have implemented search functionality with ItemsPerPage set as 10. But I am getting a random number of results on each page and in some pages there are no results. Refer attached file results.png

    Kindly advice.

     

  2. Manivannan
    Manivannan avatar
    2 posts
    Registered:
    17 Sep 2014
    19 Sep 2014
    Link to this post
    Can anyone from Telerik team please respond?
  3. Vassil Vassilev
     Vassil Vassilev avatar
    308 posts
    Registered:
    21 Jan 2015
    23 Sep 2014
    Link to this post
    Hello Manivannan,

    I was not able to reproduce this behavior - can you reproduce it on a brand new project?

    This could be caused if you have not checked "Allow parameter validation" on you page as described here: 404 and custom Parameters 

    Regards,
    Vassil Vassilev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
3 posts, 0 answered